# Failed to start Elasticsearch on windows

**URL:** <https://discuss.elastic.co/t/failed-to-start-elasticsearch-on-windows/323211>\
**Category:** Elasticsearch\
**Created:** [January 16, 2023, 3:21am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-on-windows/323211 "2023-01-16T03:21:18Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![FoamQuicksand](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/foamquicksand/32/115953_2.png) [@FoamQuicksand](https://discuss.elastic.co/u/FoamQuicksand)\
**Post date:** [January 16, 2023, 3:21am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-on-windows/323211/1 "2023-01-16T03:21:18Z")

</div>

I failed to start Elasticsearch8.5.1 and 8.6.0 locally, but 8.2.2 and 8.4.1 can start normally.  
anyone know what the problem？

report errors:

```auto
warning: ignoring JAVA_HOME=C:\Program Files\Java\jdk-17.0.4.1; using bundled JDK
[2023-01-16T12:01:06,076][ERROR][o.e.b.Elasticsearch] [A11181221041080] fatal exception while booting Elasticsearchjava.nio.file.InvalidPathException: Trailing char < > at index 0:
        at java.base/sun.nio.fs.WindowsPathParser.normalize(WindowsPathParser.java:191)
        at java.base/sun.nio.fs.WindowsPathParser.parse(WindowsPathParser.java:153)
        at java.base/sun.nio.fs.WindowsPathParser.parse(WindowsPathParser.java:77)
        at java.base/sun.nio.fs.WindowsPath.parse(WindowsPath.java:92)
        at java.base/sun.nio.fs.WindowsFileSystem.getPath(WindowsFileSystem.java:232)

```

log:

```auto
[2023-01-16T12:01:06,076][ERROR][o.e.b.Elasticsearch] [A11181221041080] fatal exception while booting Elasticsearch
java.nio.file.InvalidPathException: Trailing char < > at index 0:  
	at sun.nio.fs.WindowsPathParser.normalize(WindowsPathParser.java:191) ~[?:?]
	at sun.nio.fs.WindowsPathParser.parse(WindowsPathParser.java:153) ~[?:?]
	at sun.nio.fs.WindowsPathParser.parse(WindowsPathParser.java:77) ~[?:?]
	at sun.nio.fs.WindowsPath.parse(WindowsPath.java:92) ~[?:?]
	at sun.nio.fs.WindowsFileSystem.getPath(WindowsFileSystem.java:232) ~[?:?]
	at org.elasticsearch.core.PathUtils.get(PathUtils.java:47) ~[elasticsearch-core-8.6.0.jar:?]
	at org.elasticsearch.jdk.JarHell.parseClassPath(JarHell.java:150) ~[elasticsearch-core-8.6.0.jar:?]
	at org.elasticsearch.jdk.JarHell.parseClassPath(JarHell.java:93) ~[elasticsearch-core-8.6.0.jar:?]
	at org.elasticsearch.jdk.JarHell.checkJarHell(JarHell.java:84) ~[elasticsearch-core-8.6.0.jar:?]
	at org.elasticsearch.bootstrap.Elasticsearch.initPhase2(Elasticsearch.java:180) ~[elasticsearch-8.6.0.jar:?]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:66) ~[elasticsearch-8.6.0.jar:?]

```

---

<div class="post-metadata">

**Author:** ![Rios](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rios/32/95745_2.png) [@Rios](https://discuss.elastic.co/u/Rios)\
**Post date:** [January 16, 2023, 9:56am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-on-windows/323211/2 "2023-01-16T09:56:23Z")

</div>

> [2023-01-16T12:01:06,076][ERROR][o.e.b.Elasticsearch] [A11181221041080] fatal exception while booting Elasticsearch  
> java.nio.file.InvalidPathException: Trailing char \< \> at index 0:

It might be something wrong in yml. Can you post elasticsearch.yml? Use [https://www.yamllint.com/](https://www.yamllint.com/) for the validation.

---

<div class="post-metadata">

**Author:** ![mbooh](https://avatars.discourse-cdn.com/v4/letter/m/e495f1/32.png) [@mbooh](https://discuss.elastic.co/u/mbooh)\
**Post date:** [January 16, 2023, 12:42pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-on-windows/323211/3 "2023-01-16T12:42:41Z")

</div>

Same for me I cannot start the Windows service on 8.5.3 or 8.6.0, but I get another error. Any ideas?

[https://discuss.elastic.co/t/after-upgrade-from-8-2-2-to-8-5-3-elasticsearch-bat-works-just-fine-but-the-elasticsearch-service-bat-start-fails/322167/2](https://discuss.elastic.co/t/after-upgrade-from-8-2-2-to-8-5-3-elasticsearch-bat-works-just-fine-but-the-elasticsearch-service-bat-start-fails/322167/2)

Thanks!

/Kristoffer

---

<div class="post-metadata">

**Author:** ![Rios](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rios/32/95745_2.png) [@Rios](https://discuss.elastic.co/u/Rios)\
**Post date:** [January 16, 2023, 12:54pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-on-windows/323211/4 "2023-01-16T12:54:34Z")

</div>

Updated without any problems, Win 10 and Centos.

How did you upgrade? From zip?ES was installed as the service? If did, remove the service, install and run.

---

<div class="post-metadata">

**Author:** ![mbooh](https://avatars.discourse-cdn.com/v4/letter/m/e495f1/32.png) [@mbooh](https://discuss.elastic.co/u/mbooh)\
**Post date:** [January 16, 2023, 2:54pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-on-windows/323211/5 "2023-01-16T14:54:11Z")

</div>

Hi,  
Now I got it to work. I used:

```auto
 elasticsearch-service.bat remove 

```

to remove the existing one and then

```auto
 elasticsearch-service.bat install

```

and the service started.

/Kristoffer

---

<div class="post-metadata">

**Author:** ![Rios](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rios/32/95745_2.png) [@Rios](https://discuss.elastic.co/u/Rios)\
**Post date:** [January 16, 2023, 3:26pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-on-windows/323211/6 "2023-01-16T15:26:36Z")

</div>

Well done.  
You can use: ` elasticsearch-service.bat install <servicename>`  
You can change params: `elasticsearch-service.bat manager <servicename>`

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 13, 2023, 3:27pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-on-windows/323211/7 "2023-02-13T15:27:22Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
