# Failed to start elasticsearch.service

**URL:** <https://discuss.elastic.co/t/failed-to-start-elasticsearch-service/206895>\
**Category:** Elasticsearch\
**Created:** [November 7, 2019, 6:00am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-service/206895 "2019-11-07T06:00:00Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![MKU](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mku/32/48327_2.png) [@MKU](https://discuss.elastic.co/u/MKU)\
**Post date:** [November 7, 2019, 6:00am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-service/206895/1 "2019-11-07T06:00:00Z")

</div>

Hi,  
I am trying to start elasticsearch service using these commands,

```auto
sudo /bin/systemctl daemon-reload
sudo /bin/systemctl enable elasticsearch.service
sudo systemctl start elasticsearch.service

```

but i get this,

```auto
Failed to start elasticsearch.service: Unit elasticsearch.service failed to load: No such file or directory.

```

elasticsearch version - 7.4.2  
OS - sles12

---

<div class="post-metadata">

**Author:** ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)\
**Post date:** [November 7, 2019, 9:01am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-service/206895/2 "2019-11-07T09:01:09Z")

</div>

Hey,

can you use the systemd commands to check for any potential log output? See [https://www.elastic.co/guide/en/elasticsearch/reference/7.4/starting-elasticsearch.html#start-es-deb-systemd](https://www.elastic.co/guide/en/elasticsearch/reference/7.4/starting-elasticsearch.html#start-es-deb-systemd) - also checking log files in `/var/log/elasticsearch` might help to figure out why starting failed.

Thanks!

--Alex

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 5, 2019, 9:01am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-service/206895/3 "2019-12-05T09:01:12Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
