# Failed to start elasticsearch service

**URL:** <https://discuss.elastic.co/t/failed-to-start-elasticsearch-service/67062>\
**Category:** Elasticsearch\
**Created:** [November 24, 2016, 7:41am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-service/67062 "2016-11-24T07:41:57Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![aniketpatil](https://avatars.discourse-cdn.com/v4/letter/a/85f322/32.png) [@aniketpatil](https://discuss.elastic.co/u/aniketpatil)\
**Post date:** [November 24, 2016, 7:41am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-service/67062/1 "2016-11-24T07:41:57Z")

</div>

I am having issue when starting elasticsearch service. Service is installed properly. Sharing console code.

```
D:\Softwares\Elastic_Project\elasticsearch-5.0.0\bin>elasticsearch-service install
Installing service : "elasticsearch-service-x64"
Using JAVA_HOME (64-bit): "C:\Program Files\Java\jdk1.8.0_66"
The service 'elasticsearch-service-x64' has been installed.

D:\Softwares\Elastic_Project\elasticsearch-5.0.0\bin>elasticsearch-service start
Failed starting 'elasticsearch-service-x64' service

```

I have checked log files error .

```
[2016-11-24 13:06:00] [info] [11780] Running 'elasticsearch-service-x64' Service...
[2016-11-24 13:06:00] [info] [4412] Starting service...
[2016-11-24 13:06:00] [error] [4412] Failed creating java %JAVA_HOME%\jre\bin\server\jvm.dll
[2016-11-24 13:06:00] [error] [4412] The system cannot find the path specified.
[2016-11-24 13:06:00] [error] [4412] ServiceStart returned 1
[2016-11-24 13:06:00] [error] [4412] The system cannot find the path specified.
[2016-11-24 13:06:00] [info] [11780] Run service finished.
[2016-11-24 13:06:00] [info] [11780] Commons Daemon procrun finished
[2016-11-24 13:06:02] [error] [9316] Failed to start 'elasticsearch-service-x64' service
[2016-11-24 13:06:02] [error] [9316] The data area passed to a system call is too small.
[2016-11-24 13:06:02] [info] [9316] Start service finished.
[2016-11-24 13:06:02] [error] [9316] Commons Daemon procrun failed with exit value: 5 (Failed to start service)
[2016-11-24 13:06:02] [error] [9316] The data area passed to a system call is too small.

```

I have check jvm.dll file location but it is correct. Can anyone please help ?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 22, 2016, 7:42am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-service/67062/2 "2016-12-22T07:42:07Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
