# Failed To start elasticsearch with GCE cloud plugin

**URL:** <https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176>\
**Category:** Elasticsearch\
**Created:** [December 30, 2015, 1:05pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176 "2015-12-30T13:05:53Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![eprst](https://avatars.discourse-cdn.com/v4/letter/e/a6a055/32.png) [@eprst](https://discuss.elastic.co/u/eprst)\
**Post date:** [December 30, 2015, 1:05pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176/1 "2015-12-30T13:05:53Z")

</div>

i installed cloud gce plugin for elasticsearch 2.0 (sudo bin/plugin install cloud-gce). but it is not started even if just set _gce_ for network.host. No logs were found for this case. i use debian and elastic is started as service.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [December 30, 2015, 1:06pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176/2 "2015-12-30T13:06:56Z")

</div>

Which exact version are you using?

---

<div class="post-metadata">

**Author:** ![eprst](https://avatars.discourse-cdn.com/v4/letter/e/a6a055/32.png) [@eprst](https://discuss.elastic.co/u/eprst)\
**Post date:** [December 30, 2015, 1:07pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176/3 "2015-12-30T13:07:45Z")

</div>

"version" : {  
"number" : "2.0.0",  
"build\_hash" : "de54438d6af8f9340d50c5c786151783ce7d6be5",  
"build\_timestamp" : "2015-10-22T08:09:48Z",  
"build\_snapshot" : false,  
"lucene\_version" : "5.2.1"  
},

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [December 30, 2015, 1:10pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176/4 "2015-12-30T13:10:13Z")

</div>

Can you try 2.0.2?

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [December 30, 2015, 1:11pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176/5 "2015-12-30T13:11:00Z")

</div>

And when you said that "it is not started", do you mean that elasticsearch stops?

---

<div class="post-metadata">

**Author:** ![eprst](https://avatars.discourse-cdn.com/v4/letter/e/a6a055/32.png) [@eprst](https://discuss.elastic.co/u/eprst)\
**Post date:** [December 30, 2015, 1:14pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176/6 "2015-12-30T13:14:12Z")

</div>

I can try 2.0.2 or even 2.1.  
when i said "it is not started" i meant that i can't connect to it after restart and also i don't see started event in log

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [December 30, 2015, 1:15pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176/7 "2015-12-30T13:15:16Z")

</div>

Can you share the full logs please?

---

<div class="post-metadata">

**Author:** ![eprst](https://avatars.discourse-cdn.com/v4/letter/e/a6a055/32.png) [@eprst](https://discuss.elastic.co/u/eprst)\
**Post date:** [December 30, 2015, 1:15pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176/8 "2015-12-30T13:15:56Z")

</div>

there is nothing in log at all and also no java processes

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [December 30, 2015, 1:16pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176/9 "2015-12-30T13:16:45Z")

</div>

Nothing at all? Even a single line?

But how did you get:

```auto
"version" : {
"number" : "2.0.0",
"build_hash" : "de54438d6af8f9340d50c5c786151783ce7d6be5",
"build_timestamp" : "2015-10-22T08:09:48Z",
"build_snapshot" : false,
"lucene_version" : "5.2.1"
},

```

---

<div class="post-metadata">

**Author:** ![eprst](https://avatars.discourse-cdn.com/v4/letter/e/a6a055/32.png) [@eprst](https://discuss.elastic.co/u/eprst)\
**Post date:** [December 30, 2015, 1:17pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176/10 "2015-12-30T13:17:18Z")

</div>

when i set default value for host (0.0.0.0) it works

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [December 30, 2015, 1:18pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176/11 "2015-12-30T13:18:49Z")

</div>

Ok. Can you share your `elasticsearch.yml` file then?

---

<div class="post-metadata">

**Author:** ![eprst](https://avatars.discourse-cdn.com/v4/letter/e/a6a055/32.png) [@eprst](https://discuss.elastic.co/u/eprst)\
**Post date:** [December 30, 2015, 1:24pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176/12 "2015-12-30T13:24:01Z")

</div>

```auto
 cluster.name: my-staging
 node.name: ${HOSTNAME}
 path.data: /var/data/elasticsearch/
 path.logs: /var/log/elasticsearch
 bootstrap.mlockall: true
 ES_HEAP_SIZE: 1.5G
 network.host: "_gce_"

```

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [December 30, 2015, 1:53pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176/13 "2015-12-30T13:53:52Z")

</div>

`ES_HEAP_SIZE: 1.5G` is useless here. But that should not cause that issue

Are you sure that cloud-gce plugin is started? Can you share the full logs?

---

<div class="post-metadata">

**Author:** ![eprst](https://avatars.discourse-cdn.com/v4/letter/e/a6a055/32.png) [@eprst](https://discuss.elastic.co/u/eprst)\
**Post date:** [December 30, 2015, 9:14pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176/14 "2015-12-30T21:14:54Z")

</div>

i don't see any logs at all

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [December 30, 2015, 10:14pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176/15 "2015-12-30T22:14:33Z")

</div>

Even when it works?

---

<div class="post-metadata">

**Author:** ![eprst](https://avatars.discourse-cdn.com/v4/letter/e/a6a055/32.png) [@eprst](https://discuss.elastic.co/u/eprst)\
**Post date:** [December 30, 2015, 10:35pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176/16 "2015-12-30T22:35:44Z")

</div>

yes even then

---

<div class="post-metadata">

**Author:** ![eprst](https://avatars.discourse-cdn.com/v4/letter/e/a6a055/32.png) [@eprst](https://discuss.elastic.co/u/eprst)\
**Post date:** [December 30, 2015, 11:56pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176/17 "2015-12-30T23:56:12Z")

</div>

on elastic 2.1:

loaded [cloud-gce], sites [head]

java.lang.IllegalArgumentException: No interface named 'gce' found, got [name:lo (lo), name:eth0 (eth0)]  
at org.elasticsearch.common.network.NetworkUtils.getAddressesForInterface(NetworkUtils.java:188)  
at org.elasticsearch.common.network.NetworkService.resolveInetAddress(NetworkService.java:196)  
at org.elasticsearch.common.network.NetworkService.resolveBindHostAddress(NetworkService.java:111)  
at org.elasticsearch.transport.netty.NettyTransport.bindServerBootstrap(NettyTransport.java:430)  
at org.elasticsearch.transport.netty.NettyTransport.doStart(NettyTransport.java:319)  
at org.elasticsearch.common.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:68)  
at org.elasticsearch.transport.TransportService.doStart(TransportService.java:170)  
at org.elasticsearch.common.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:68)  
at org.elasticsearch.node.Node.start(Node.java:254)  
at org.elasticsearch.bootstrap.Bootstrap.start(Bootstrap.java:221)  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:287)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:35)

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [December 31, 2015, 4:00am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176/18 "2015-12-31T04:00:27Z")

</div>

So you found logs?

I'll check that later today. Might be a bug.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [December 31, 2015, 9:36am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176/19 "2015-12-31T09:36:27Z")

</div>

I checked it and actually `_gce_` is only available if you are using gce discovery.

Which means that you need to have:

```auto
cloud.gce.project_id: YOUR_GCE_PROJECT
cloud.gce.zone: YOUR_ZONE
discovery.type: gce

```

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [December 31, 2015, 9:52am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176/20 "2015-12-31T09:52:54Z")

</div>

I opened [https://github.com/elastic/elasticsearch/issues/15724](https://github.com/elastic/elasticsearch/issues/15724) to check if we can do a better job here.

[Next page](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176.md?page=2)
