# Failed To start elasticsearch with GCE cloud plugin

**URL:** <https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176>\
**Category:** Elasticsearch\
**Created:** [December 30, 2015, 1:05pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176 "2015-12-30T13:05:53Z")\
**Posts on this page:** 11\
**Page:** 2

<div class="post-metadata">

**Author:** ![eprst](https://avatars.discourse-cdn.com/v4/letter/e/a6a055/32.png) [@eprst](https://discuss.elastic.co/u/eprst)\
**Post date:** [December 31, 2015, 10:42am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176/21 "2015-12-31T10:42:22Z")

</div>

thank you, but initially i tried with discovery and it also didn't work.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [December 31, 2015, 11:00am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176/22 "2015-12-31T11:00:00Z")

</div>

So can you try again and paste all the logs?

---

<div class="post-metadata">

**Author:** ![eprst](https://avatars.discourse-cdn.com/v4/letter/e/a6a055/32.png) [@eprst](https://discuss.elastic.co/u/eprst)\
**Post date:** [December 31, 2015, 11:01am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176/23 "2015-12-31T11:01:37Z")

</div>

they were deleted after i reinstall the newer version of ES

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [December 31, 2015, 11:17am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176/24 "2015-12-31T11:17:56Z")

</div>

And?

Did you try again with the new version?

---

<div class="post-metadata">

**Author:** ![eprst](https://avatars.discourse-cdn.com/v4/letter/e/a6a055/32.png) [@eprst](https://discuss.elastic.co/u/eprst)\
**Post date:** [December 31, 2015, 11:18am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176/25 "2015-12-31T11:18:47Z")

</div>

i did not try gce discovery yet

---

<div class="post-metadata">

**Author:** ![eprst](https://avatars.discourse-cdn.com/v4/letter/e/a6a055/32.png) [@eprst](https://discuss.elastic.co/u/eprst)\
**Post date:** [December 31, 2015, 11:58am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176/26 "2015-12-31T11:58:19Z")

</div>

i set gce discovery parameters  
[2015-12-31 11:51:12,400][INFO][node] [es] stopping ...  
[2015-12-31 11:51:12,409][INFO][node] [es] stopped  
[2015-12-31 11:51:12,410][INFO][node] [es] closing ...  
[2015-12-31 11:51:12,415][INFO][node] [es] closed  
there is only stopping log no starting at all

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [December 31, 2015, 12:14pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176/27 "2015-12-31T12:14:06Z")

</div>

What is you `elasticsearch.yml`?

---

<div class="post-metadata">

**Author:** ![eprst](https://avatars.discourse-cdn.com/v4/letter/e/a6a055/32.png) [@eprst](https://discuss.elastic.co/u/eprst)\
**Post date:** [December 31, 2015, 12:30pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176/28 "2015-12-31T12:30:32Z")

</div>

```auto
cluster.name: my-es
 node.name: ${HOSTNAME}
 network.host: es
cloud.gce.project_id: my-es
cloud.gce.zone: us-central1-b
discovery.type: gce

```

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [December 31, 2015, 12:47pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176/29 "2015-12-31T12:47:35Z")

</div>

Be careful with indentation.

---

<div class="post-metadata">

**Author:** ![eprst](https://avatars.discourse-cdn.com/v4/letter/e/a6a055/32.png) [@eprst](https://discuss.elastic.co/u/eprst)\
**Post date:** [December 31, 2015, 12:52pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176/30 "2015-12-31T12:52:02Z")

</div>

Ah,yeah it was wrong. Now it is started

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 11:27pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176/31 "2017-07-05T23:27:37Z")

</div>



[Previous page](https://discuss.elastic.co/t/failed-to-start-elasticsearch-with-gce-cloud-plugin/38176.md?page=1)
