# Failed to start Elasticsearch

**URL:** <https://discuss.elastic.co/t/failed-to-start-elasticsearch/271251>\
**Category:** Elasticsearch\
**Created:** [April 26, 2021, 12:11pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch/271251 "2021-04-26T12:11:41Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![Rizky\_Hudha](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rizky_hudha/32/87736_2.png) [@Rizky\_Hudha](https://discuss.elastic.co/u/Rizky_Hudha)\
**Post date:** [April 26, 2021, 12:11pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch/271251/1 "2021-04-26T12:11:41Z")

</div>

hello, I have a problem regarding elasticsearch, where to start, the error "Failed to start Elasticsearch" always appears, please help to solve my error, thank you  
`Apr 27 02:48:09 bigdata systemd[1]: Unit elasticsearch.service entered failed state.`  
`Apr 27 02:48:09 bigdata systemd[1]: elasticsearch.service failed.`  
`Apr 27 02:48:09 bigdata polkitd[581]: Unregistered Authentication Agent for unix-process:4610:5433475 (system bus name :1.96, object path /org/freedesktop/PolicyKit1/Aut`  
`Apr 27 02:54:29 bigdata sudo[4815]: root : TTY=pts/0 ; PWD=/var/log/elasticsearch ; USER=root ; COMMAND=/bin/yum update`  
`Apr 27 02:54:29 bigdata sudo[4815]: pam_unix(sudo:session): session opened for user root by root(uid=0)`  
`Apr 27 02:54:37 bigdata sudo[4815]: pam_unix(sudo:session): session closed for user root`  
`Apr 27 02:54:45 bigdata sudo[4837]: root : TTY=pts/0 ; PWD=/var/log/elasticsearch ; USER=root ; COMMAND=/bin/yum upgrade`  
`Apr 27 02:54:45 bigdata sudo[4837]: pam_unix(sudo:session): session opened for user root by root(uid=0)`  
`Apr 27 02:54:48 bigdata sudo[4837]: pam_unix(sudo:session): session closed for user root `

and this report error command journalctl -xe  
`Apr 27 02:48:09 bigdata systemd[1]: Unit elasticsearch.service entered failed state.`  
`Apr 27 02:48:09 bigdata systemd[1]: elasticsearch.service failed.`  
`Apr 27 02:48:09 bigdata polkitd[581]: Unregistered Authentication Agent for unix-process:4610:5433475 (system bus name :1.96, object path /org/freedesktop/PolicyKit1/Aut`

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [April 26, 2021, 1:12pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch/271251/2 "2021-04-26T13:12:21Z")

</div>

Welcome!

Please don't post images of text as they are hard to read, may not display correctly for everyone, and are not searchable.

Instead, paste the text and format it with `</>` icon or pairs of triple backticks (```), and check the preview window to make sure it's properly formatted before posting it. This makes it more likely that your question will receive a useful answer.

It would be great if you could update your post to solve this.

Also please share the full elasticsearch logs.

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [April 26, 2021, 1:14pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch/271251/3 "2021-04-26T13:14:10Z")

</div>

Please provide information about which version you are using and how your cluster is deployed.

---

<div class="post-metadata">

**Author:** ![Rizky\_Hudha](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rizky_hudha/32/87736_2.png) [@Rizky\_Hudha](https://discuss.elastic.co/u/Rizky_Hudha)\
**Post date:** [April 27, 2021, 3:04am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch/271251/4 "2021-04-27T03:04:51Z")

</div>

> [@Rizky\_Hudha](#):
>
> hello, I have a problem regarding elasticsearch, where to start, the error "Failed to start Elasticsearch" always appears, please help to solve my error, thank you  
> `Apr 27 02:48:09 bigdata systemd[1]: Unit elasticsearch.service entered failed state.`  
> `Apr 27 02:48:09 bigdata systemd[1]: elasticsearch.service failed.`  
> `Apr 27 02:48:09 bigdata polkitd[581]: Unregistered Authentication Agent for unix-process:4610:5433475 (system bus name :1.96, object path /org/freedesktop/PolicyKit1/Aut`  
> `Apr 27 02:54:29 bigdata sudo[4815]: root : TTY=pts/0 ; PWD=/var/log/elasticsearch ; USER=root ; COMMAND=/bin/yum update`  
> `Apr 27 02:54:29 bigdata sudo[4815]: pam_unix(sudo:session): session opened for user roo`

I' m sorry ,

and this report error my elasticsearch command

`Apr 27 02:48:09 bigdata systemd[1]: Unit elasticsearch.service entered failed state.`  
`Apr 27 02:48:09 bigdata systemd[1]: elasticsearch.service failed.`  
`Apr 27 02:48:09 bigdata polkitd[581]: Unregistered Authentication Agent for unix-process:4610:5433475 (system bus name :1.96, object path /org/freedesktop/PolicyKit1/Aut`  
`Apr 27 02:54:29 bigdata sudo[4815]: root : TTY=pts/0 ; PWD=/var/log/elasticsearch ; USER=root ; COMMAND=/bin/yum update`  
`Apr 27 02:54:29 bigdata sudo[4815]: pam_unix(sudo:session): session opened for user root by root(uid=0)`  
`Apr 27 02:54:37 bigdata sudo[4815]: pam_unix(sudo:session): session closed for user root`  
`Apr 27 02:54:45 bigdata sudo[4837]: root : TTY=pts/0 ; PWD=/var/log/elasticsearch ; USER=root ; COMMAND=/bin/yum upgrade`  
`Apr 27 02:54:45 bigdata sudo[4837]: pam_unix(sudo:session): session opened for user root by root(uid=0)`  
`Apr 27 02:54:48 bigdata sudo[4837]: pam_unix(sudo:session): session closed for user root`

and this report error command journalctl -xe  
`Apr 27 02:48:09 bigdata systemd[1]: Unit elasticsearch.service entered failed state.`  
`Apr 27 02:48:09 bigdata systemd[1]: elasticsearch.service failed.`  
`Apr 27 02:48:09 bigdata polkitd[581]: Unregistered Authentication Agent for unix-process:4610:5433475 (system bus name :1.96, object path /org/freedesktop/PolicyKit1/Aut`

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [April 27, 2021, 4:10am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch/271251/5 "2021-04-27T04:10:54Z")

</div>

Could you please share the elasticsearch logs? I believe you will find them in `/var/log/elasticsearch`

---

<div class="post-metadata">

**Author:** ![Rizky\_Hudha](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rizky_hudha/32/87736_2.png) [@Rizky\_Hudha](https://discuss.elastic.co/u/Rizky_Hudha)\
**Post date:** [April 27, 2021, 4:55am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch/271251/6 "2021-04-27T04:55:49Z")

</div>

this file /var/log/elasticsearch

> `gc.log gc.log.00 gc.log.01 gc.log.02 gc.log.03 gc.log.04 gc.log.05 gc.log.06 gc.log.07 gc.log.08 gc.log.09 gc.log.10 gc.log.11 gc.log.12`

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [April 27, 2021, 6:37am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch/271251/7 "2021-04-27T06:37:29Z")

</div>

There's no `elasticsearch.log` file in this dir?

How did you install elasticsearch exactly?

---

<div class="post-metadata">

**Author:** ![Rizky\_Hudha](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rizky_hudha/32/87736_2.png) [@Rizky\_Hudha](https://discuss.elastic.co/u/Rizky_Hudha)\
**Post date:** [April 27, 2021, 7:17am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch/271251/8 "2021-04-27T07:17:16Z")

</div>

I installed using debian, can you tell me what the logs mean?

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [April 27, 2021, 7:30am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch/271251/9 "2021-04-27T07:30:33Z")

</div>

Did you follow this guide exactly?

> **[Install Elasticsearch with Debian Package | Elasticsearch Guide \[7.12\] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/current/deb.html)**

If you did, what exact step went wrong?

---

<div class="post-metadata">

**Author:** ![Rizky\_Hudha](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rizky_hudha/32/87736_2.png) [@Rizky\_Hudha](https://discuss.elastic.co/u/Rizky_Hudha)\
**Post date:** [April 27, 2021, 12:11pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch/271251/10 "2021-04-27T12:11:16Z")

</div>

oke thanks for your answer, I will double check the elasticsearch installation

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 25, 2021, 12:11pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch/271251/11 "2021-05-25T12:11:27Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
