# Failed to start Elasticsearch

**URL:** <https://discuss.elastic.co/t/failed-to-start-elasticsearch/296727>\
**Category:** Elasticsearch\
**Created:** [February 9, 2022, 1:14pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch/296727 "2022-02-09T13:14:55Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ivan\_Scorpey](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ivan_scorpey/32/101596_2.png) [@Ivan\_Scorpey](https://discuss.elastic.co/u/Ivan_Scorpey)\
**Post date:** [February 9, 2022, 1:14pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch/296727/1 "2022-02-09T13:14:55Z")

</div>

I start ES but have Failed to start Elasticsearch and in log  
` java.security.AccessControlException: access denied ("java.lang.RuntimePermission" "setContextClassLoader")`

---

<div class="post-metadata">

**Author:** ![wsouza](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/wsouza/32/92547_2.png) [@wsouza](https://discuss.elastic.co/u/wsouza)\
**Post date:** [February 9, 2022, 1:42pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch/296727/2 "2022-02-09T13:42:31Z")

</div>

I don't know if this is your case but a similar error was reported in the topic below:

> [@\[SOLVED\]Caused by: java.security.AccessControlException: access denied](https://discuss.elastic.co/t/solved-caused-by-java-security-accesscontrolexception-access-denied/154566):
>
> Hi There, I' ve got this strange issue with my certs.... I know the certs should go in the conf dir (which is the case: [root@esmaster01dev esmaster01dev]# echo $ES\_CONF\_DIR /etc/elasticsearch/esmaster01dev Contents of the directory: [root@esmaster01dev esmaster01dev]# ll total 32 -rw-r--r--. 1 elasticsearch elasticsearch 3440 30. Okt 06:32 elastic-certificates.p12 -rw-rw----. 1 elasticsearch elasticsearch 249 29. Okt 15:20 elasticsearch.keystore -rw-r--r--. 1 elasticsearch elasticsear…

---

<div class="post-metadata">

**Author:** ![Ivan\_Scorpey](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ivan_scorpey/32/101596_2.png) [@Ivan\_Scorpey](https://discuss.elastic.co/u/Ivan_Scorpey)\
**Post date:** [February 9, 2022, 2:50pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch/296727/3 "2022-02-09T14:50:28Z")

</div>

it is case with cert, my case with start  
Elastic with javaagent APM pinpoint

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 9, 2022, 2:50pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch/296727/4 "2022-03-09T14:50:55Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
