# Failed to start Elasticsearch

**URL:** https://discuss.elastic.co/t/failed-to-start-elasticsearch/322433
**Category:** Elasticsearch
**Created:** [January 4, 2023, 8:36am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch/322433 "2023-01-04T08:36:38Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![alam02](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alam02/32/115526_2.png) [@alam02](https://discuss.elastic.co/u/alam02)
#### Post date: [January 4, 2023, 8:36am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch/322433/1 "2023-01-04T08:36:38Z")

</div>

Hello i have kibana, logstash started but impossible to start elastic.service and i got this error code when i run systemctl start elastic.service.  
Also on the website i receive this message " kibana is not ready yet".

\</× elastic.service - Elasticsearch  
Loaded: loaded (/etc/systemd/system/elastic.service; enabled; vendor preset: enabled)  
Active: failed (Result: exit-code) since Tue 2023-01-03 22:41:20 UTC; 9h ago  
Docs: [https://www.elastic.co](https://www.elastic.co)  
Process: 30673 ExecStart=/opt/elasticsearch/bin/elasticsearch -p ${PID\_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)  
Main PID: 30673 (code=exited, status=1/FAILURE)  
CPU: 1.600s

Jan 03 22:41:20 ns55598 elasticsearch[30673]: at java.base/java.nio.file.Files.newInputStream(Files.java:160)  
Jan 03 22:41:20 ns55598 elasticsearch[30673]: at org.elasticsearch.server.cli.JvmOptionsParser.readJvmOptionsFiles(JvmOptionsParser.java:175)  
Jan 03 22:41:20 ns55598 elasticsearch[30673]: at org.elasticsearch.server.cli.JvmOptionsParser.jvmOptions(JvmOptionsParser.java:130)  
Jan 03 22:41:20 ns55598 elasticsearch[30673]: at org.elasticsearch.server.cli.JvmOptionsParser.determineJvmOptions(JvmOptionsParser.java:92)  
Jan 03 22:41:20 ns55598 elasticsearch[30673]: at org.elasticsearch.server.cli.ServerProcess.createProcess(ServerProcess.java:214)  
Jan 03 22:41:20 ns55598 elasticsearch[30673]: at org.elasticsearch.server.cli.ServerProcess.start(ServerProcess.java:108)  
Jan 03 22:41:20 ns55598 elasticsearch[30673]: ... 7 more  
Jan 03 22:41:20 ns55598 systemd[1]: elastic.service: Main process exited, code=exited, status=1/FAILURE  
Jan 03 22:41:20 ns55598 systemd[1]: elastic.service: Failed with result 'exit-code'.  
Jan 03 22:41:20 ns55598 systemd[1]: elastic.service: Consumed 1.600s CPU time.

> 

Any helps would be great.

---

<div class="post-metadata">

### Author: ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)
#### Post date: [January 15, 2023, 3:09am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch/322433/2 "2023-01-15T03:09:50Z")

</div>

Hi @alam02 welcome to the community!

How did you install?

What OS?

What version?

We need to see the logs per the [docs](https://www.elastic.co/guide/en/elasticsearch/reference/current/rpm.html#rpm-running-systemd)

`sudo journalctl --unit elasticsearch`

I.e... more details needed...

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [February 12, 2023, 3:10am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch/322433/3 "2023-02-12T03:10:48Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
