# Failed to start Elasticsearch

**URL:** <https://discuss.elastic.co/t/failed-to-start-elasticsearch/335146>\
**Category:** Elasticsearch\
**Created:** [June 3, 2023, 10:41pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch/335146 "2023-06-03T22:41:33Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![surajhekare](https://avatars.discourse-cdn.com/v4/letter/s/eb9ed0/32.png) [@surajhekare](https://discuss.elastic.co/u/surajhekare)\
**Post date:** [June 3, 2023, 10:41pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch/335146/1 "2023-06-03T22:41:33Z")

</div>

ubuntu@ip-172-31-37-106:~$ systemctl status elasticsearch.service  
● elasticsearch.service - Elasticsearch  
Loaded: loaded (/lib/systemd/system/elasticsearch.service; disabled; vendor preset: enabled)  
Active: failed (Result: exit-code) since Sat 2023-06-03 20:17:48 UTC; 2min 13s ago  
Docs: [https://www.elastic.co](https://www.elastic.co)  
Process: 1510 ExecStart=/usr/share/elasticsearch/bin/systemd-entrypoint -p ${PID\_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)  
Main PID: 1510 (code=exited, status=1/FAILURE)

Jun 03 20:17:48 ip-172-31-37-106 systemd-entrypoint[1510]: at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:160)  
Jun 03 20:17:48 ip-172-31-37-106 systemd-entrypoint[1510]: at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.j\>  
Jun 03 20:17:48 ip-172-31-37-106 systemd-entrypoint[1510]: at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:112)  
Jun 03 20:17:48 ip-172-31-37-106 systemd-entrypoint[1510]: at org.elasticsearch.cli.Command.main(Command.java:77)  
Jun 03 20:17:48 ip-172-31-37-106 systemd-entrypoint[1510]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:125)  
Jun 03 20:17:48 ip-172-31-37-106 systemd-entrypoint[1510]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:80)  
Jun 03 20:17:48 ip-172-31-37-106 systemd-entrypoint[1510]: For complete error details, refer to the log at /var/log/elasticsearch/magento-cluster.log  
Jun 03 20:17:48 ip-172-31-37-106 systemd[1]: elasticsearch.service: Main process exited, code=exited, status=1/FAILURE  
Jun 03 20:17:48 ip-172-31-37-106 systemd[1]: elasticsearch.service: Failed with result 'exit-code'.  
Jun 03 20:17:48 ip-172-31-37-106 systemd[1]: Failed to start Elasticsearch.

---

<div class="post-metadata">

**Author:** ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)\
**Post date:** [June 3, 2023, 11:04pm UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch/335146/2 "2023-06-03T23:04:41Z")

</div>

Hello and welcome,

Please provide some context, just pasting some logs does not help to understand what your issue is.

You need to share logs from Elasticsearch and also look at your system log since you are having issues with the systemd service.

Since you use Ubuntu it is probably on `/var/log/syslog`.

---

<div class="post-metadata">

**Author:** ![surajhekare](https://avatars.discourse-cdn.com/v4/letter/s/eb9ed0/32.png) [@surajhekare](https://discuss.elastic.co/u/surajhekare)\
**Post date:** [June 4, 2023, 4:36am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch/335146/3 "2023-06-04T04:36:10Z")

</div>

Sorry, issue resolved.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 2, 2023, 4:36am UTC](https://discuss.elastic.co/t/failed-to-start-elasticsearch/335146/4 "2023-07-02T04:36:53Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
