# Failed to start Filebeat sends log files to Logstash or directly to Elasticsearch - Certificate problem?

**URL:** <https://discuss.elastic.co/t/failed-to-start-filebeat-sends-log-files-to-logstash-or-directly-to-elasticsearch-certificate-problem/157909>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [November 22, 2018, 4:01pm UTC](https://discuss.elastic.co/t/failed-to-start-filebeat-sends-log-files-to-logstash-or-directly-to-elasticsearch-certificate-problem/157909 "2018-11-22T16:01:12Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![rpaterson](https://avatars.discourse-cdn.com/v4/letter/r/5daacb/32.png) [@rpaterson](https://discuss.elastic.co/u/rpaterson)\
**Post date:** [November 22, 2018, 4:01pm UTC](https://discuss.elastic.co/t/failed-to-start-filebeat-sends-log-files-to-logstash-or-directly-to-elasticsearch-certificate-problem/157909/1 "2018-11-22T16:01:12Z")

</div>

Hey followed this guide to install ELK on a Ubuntu VM. [https://www.howtoforge.com/tutorial/ubuntu-elastic-stack/](https://www.howtoforge.com/tutorial/ubuntu-elastic-stack/)

Can't get filebeat to start. Don't know what I've done wrong. Get this error when running 'sudo service filebeat status'

● filebeat.service - Filebeat sends log files to Logstash or directly to Elasticsearch.  
Loaded: loaded (/lib/systemd/system/filebeat.service; enabled; vendor preset: enabled)  
Active: inactive (dead) (Result: exit-code) since Thu 2018-11-22 07:47:44 PST; 6min ago  
Docs: [https://www.elastic.co/products/beats/filebeat](https://www.elastic.co/products/beats/filebeat)  
Process: 13032 ExecStart=/usr/share/filebeat/bin/filebeat -c /etc/filebeat/filebeat.yml -path.home /usr/share/filebeat -path.config /etc/filebeat -path.data /var/lib/filebeat -path.logs /var/log/file  
Main PID: 13032 (code=exited, status=1/FAILURE)

Nov 22 07:47:44 ubuntu systemd[1]: filebeat.service: Main process exited, code=exited, status=1/FAILURE  
Nov 22 07:47:44 ubuntu systemd[1]: filebeat.service: Unit entered failed state.  
Nov 22 07:47:44 ubuntu systemd[1]: filebeat.service: Failed with result 'exit-code'.  
Nov 22 07:47:44 ubuntu systemd[1]: filebeat.service: Service hold-off time over, scheduling restart.  
Nov 22 07:47:44 ubuntu systemd[1]: Stopped Filebeat sends log files to Logstash or directly to Elasticsearch..  
Nov 22 07:47:44 ubuntu systemd[1]: filebeat.service: Start request repeated too quickly.  
Nov 22 07:47:44 ubuntu systemd[1]: Failed to start Filebeat sends log files to Logstash or directly to Elasticsearch..

[https://pastebin.com/pbBV85WX](https://pastebin.com/pbBV85WX) - Pastebin of Filebeat.yml  
[https://pastebin.com/NUere47q](https://pastebin.com/NUere47q) - Pastebin of Logstash.yml

Sorry if I'm missing anything first time posting here and I'm a complete noob to all of this. But I'm thinking it might be a certificate problem with SSL? I have no idea, been looking through some of the other posts similar to this here but couldn't find anything clear.

---

<div class="post-metadata">

**Author:** ![pierhugues](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pierhugues/32/48383_2.png) [@pierhugues](https://discuss.elastic.co/u/pierhugues)\
**Post date:** [November 22, 2018, 5:23pm UTC](https://discuss.elastic.co/t/failed-to-start-filebeat-sends-log-files-to-logstash-or-directly-to-elasticsearch-certificate-problem/157909/2 "2018-11-22T17:23:54Z")

</div>

Hello @rpaterson,

I saw a few things in the config, I see a few deprecated options used in the filebeat.yml.  
I also see that you have 2 outputs enabled at the same time, Filebeat only support 1 output.

The following error message also mention the two outputs.

```auto
Nov 22 07:47:44 ubuntu systemd[1]: Stopped Filebeat sends log files to Logstash or directly to Elasticsearch..

```

Can you remove the `output.elasticsearch:` from your configuration and try again?

Also, if that doesn't work I suggest to start from fresh and use our [getting started guide](https://www.elastic.co/guide/en/beats/filebeat/current/filebeat-getting-started.html) the options are up to date.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 20, 2018, 5:23pm UTC](https://discuss.elastic.co/t/failed-to-start-filebeat-sends-log-files-to-logstash-or-directly-to-elasticsearch-certificate-problem/157909/3 "2018-12-20T17:23:55Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
