# Failed to start Filebeat sends log files to Logstash or directly to Elasticsearch

**URL:** https://discuss.elastic.co/t/failed-to-start-filebeat-sends-log-files-to-logstash-or-directly-to-elasticsearch/276176
**Category:** Beats
**Tags:** docker, filebeat
**Created:** [June 16, 2021, 5:27pm UTC](https://discuss.elastic.co/t/failed-to-start-filebeat-sends-log-files-to-logstash-or-directly-to-elasticsearch/276176 "2021-06-16T17:27:29Z")
**Posts on this page:** 5
**Page:** 2

<div class="post-metadata">

### Author: ![Akanksha\_Pandey](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/akanksha_pandey/32/89539_2.png) [@Akanksha\_Pandey](https://discuss.elastic.co/u/Akanksha_Pandey)
#### Post date: [June 18, 2021, 7:09pm UTC](https://discuss.elastic.co/t/failed-to-start-filebeat-sends-log-files-to-logstash-or-directly-to-elasticsearch/276176/21 "2021-06-18T19:09:03Z")

</div>

You were right! This worked and versioning was the actual cause-which made me struggle uptil now!

Thanks a lot, I would have never be able to do this without your help! I do not have enough words to thank you. You really helped me a lot and saved me 🙂

---

<div class="post-metadata">

### Author: ![Akanksha\_Pandey](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/akanksha_pandey/32/89539_2.png) [@Akanksha\_Pandey](https://discuss.elastic.co/u/Akanksha_Pandey)
#### Post date: [June 22, 2021, 6:53pm UTC](https://discuss.elastic.co/t/failed-to-start-filebeat-sends-log-files-to-logstash-or-directly-to-elasticsearch/276176/22 "2021-06-22T18:53:59Z")

</div>

In my `docker-compose.yaml` file, when I change the path of source from `conf` to `config`- my Kibana alerts are disabled and it says to enable TLS:

 ![Screenshot (148)](https://us1.discourse-cdn.com/elastic/original/3X/2/3/23227bef862d14e638ca65ceb5da76042b738e35.png)

PS. I am changing the source path from `conf` to `config` in order to enable user login in `Kibana`

Here is my `docker-compose.yaml` file:

```auto
services: 
  elasticsearch: 
    build:
      context: elasticsearch/
    container_name: elasticsearch
    volumes:
      - type: bind
        source: ./elasticsearch/conf/elasticsearch.yml
        target: /usr/share/elasticsearch/config/elasticsearch.yml
        read_only: true
      - type: volume
        source: elasticsearch
        target: /usr/share/elasticsearch/data
    ports:
      - "9200:9200"
    environment:
      ES_JAVA_OPTS: "-Xmx2g -Xms2g"
      ELASTIC_PASSWORD: 
      ELASTIC_USERNAME : 
      # Use single node discovery in order to disable production mode and avoid bootstrap checks.
      # see: https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html
      discovery.type: single-node
    networks:
      - elastic
    restart: always
  
  logstash:
    container_name: logstash
    build: 
      context: logstash/
    # command: logstash -f /conf/logstash.conf
    volumes:
      - type: bind
        source: ./logstash/conf/logstash.yml
        target: /usr/share/logstash/config/logstash.yml
        read_only: true
      - type: bind
        source: ./logstash/pipeline
        target: /usr/share/logstash/pipeline
        read_only: true
    ports:
     - "5043:5043"
     - "5044:5044"
    environment:
      LS_JAVA_OPTS: "-Xmx1g -Xms1g"
    networks:
      - elastic
    depends_on:
     - elasticsearch
    restart: always

  kibana:
    build:
      context: kibana/
    container_name: 
    environment:
      XPACK_APM_SERVICEMAPENABLED: "true"
      XPACK_ENCRYPTEDSAVEDOBJECTS_ENCRYPTIONKEY: " "
    volumes:
      - type: bind
        source: ./kibana/conf/kibana.yml
        target: /usr/share/kibana/config/kibana.yml
        read_only: true
    ports:
      - "5601:5601"
    networks:
        - elastic
    depends_on:
      - elasticsearch
    restart: always

```

Can you please help me what I'm missing?

---

<div class="post-metadata">

### Author: ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)
#### Post date: [June 22, 2021, 10:08pm UTC](https://discuss.elastic.co/t/failed-to-start-filebeat-sends-log-files-to-logstash-or-directly-to-elasticsearch/276176/23 "2021-06-22T22:08:36Z")

</div>

Alerts require TLS. Always have, I don't think that is just because you changed your path.

Are you sure it worked before you changed it? I suspect Alerts did not function before.

Alerts require pretty much a fully secured cluster.

Here are the instructions I would be very careful and follow them closely.

> **[Running the Elastic Stack on Docker | Getting Started \[7.13\] | Elastic](https://www.elastic.co/guide/en/elastic-stack-get-started/current/get-started-docker.html)**

I am confused why you are also running on such and old version 7.9.2

> **[Running the Elastic Stack on Docker | Getting Started \[7.9\] | Elastic](https://www.elastic.co/guide/en/elastic-stack-get-started/7.9/get-started-docker.html)**

---

<div class="post-metadata">

### Author: ![Akanksha\_Pandey](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/akanksha_pandey/32/89539_2.png) [@Akanksha\_Pandey](https://discuss.elastic.co/u/Akanksha_Pandey)
#### Post date: [June 23, 2021, 7:04am UTC](https://discuss.elastic.co/t/failed-to-start-filebeat-sends-log-files-to-logstash-or-directly-to-elasticsearch/276176/24 "2021-06-23T07:04:51Z")

</div>

yes, When the path was `conf` alerts were working.

Also, I'm using Elastic version `7.9.2` as in our `Dockerfile` we pull this image version from Docker hub configured in our elastic codebase

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 21, 2021, 9:04am UTC](https://discuss.elastic.co/t/failed-to-start-filebeat-sends-log-files-to-logstash-or-directly-to-elasticsearch/276176/25 "2021-07-21T09:04:53Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.

[Previous page](https://discuss.elastic.co/t/failed-to-start-filebeat-sends-log-files-to-logstash-or-directly-to-elasticsearch/276176.md?page=1)
