# Failed to start Filebeat sends log files to Logstash or directly to Elasticsearch

**URL:** https://discuss.elastic.co/t/failed-to-start-filebeat-sends-log-files-to-logstash-or-directly-to-elasticsearch/309477
**Category:** Beats
**Tags:** filebeat
**Created:** [July 13, 2022, 5:52am UTC](https://discuss.elastic.co/t/failed-to-start-filebeat-sends-log-files-to-logstash-or-directly-to-elasticsearch/309477 "2022-07-13T05:52:03Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Nishi\_Shah](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nishi_shah/32/108228_2.png) [@Nishi\_Shah](https://discuss.elastic.co/u/Nishi_Shah)
#### Post date: [July 13, 2022, 5:52am UTC](https://discuss.elastic.co/t/failed-to-start-filebeat-sends-log-files-to-logstash-or-directly-to-elasticsearch/309477/1 "2022-07-13T05:52:03Z")

</div>

**I am trying to configure filebeat(7.17.5). when i restart filebeat only status is showing active**

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/f/b/fb05d65a04d61f2a560553e17dca63070fb7f309.png)  
[root@ELK-LAB-VM filebeat]# systemctl status filebeat  
● filebeat.service - Filebeat sends log files to Logstash or directly to Elasticsearch.  
Loaded: loaded (/usr/lib/systemd/system/filebeat.service; enabled; vendor preset: disabled)  
Active: active (running) since Wed 2022-07-13 13:36:41 HKT; 3s ago  
Docs: [Filebeat: Lightweight Log Analysis & Elasticsearch | Elastic](https://www.elastic.co/beats/filebeat)  
Main PID: 27750 (filebeat)  
Tasks: 10 (limit: 101074)  
Memory: 82.0M  
CGroup: /system.slice/filebeat.service  
└─27750 /usr/share/filebeat/bin/filebeat --environment systemd -c /etc/filebeat/filebeat.yml --path.home /usr/share/filebeat --path.config /etc/filebeat --p\>

Jul 13 13:36:41 ELK-LAB-VM filebeat[27750]: 2022-07-13T13:36:41.471+0800 INFO [beat] instance/beat.go:1055 Host info {"system\_info":\>  
Jul 13 13:36:41 ELK-LAB-VM filebeat[27750]: 2022-07-13T13:36:41.472+0800 INFO [beat] instance/beat.go:1084 Process info {"system\_inf\>  
Jul 13 13:36:41 ELK-LAB-VM filebeat[27750]: 2022-07-13T13:36:41.472+0800 INFO instance/beat.go:328 Setup Beat: filebeat; Version: 7.17.5  
Jul 13 13:36:41 ELK-LAB-VM filebeat[27750]: 2022-07-13T13:36:41.472+0800 INFO [index-management] idxmgmt/std.go:184 Set output.elasticsearc\>  
Jul 13 13:36:41 ELK-LAB-VM filebeat[27750]: 2022-07-13T13:36:41.472+0800 INFO [esclientleg] eslegclient/connection.go:105 elasticsearch url\>  
Jul 13 13:36:41 ELK-LAB-VM filebeat[27750]: 2022-07-13T13:36:41.472+0800 INFO [publisher] pipeline/module.go:113 Beat name: ELK-LAB-VM  
Jul 13 13:36:41 ELK-LAB-VM filebeat[27750]: 2022-07-13T13:36:41.473+0800 INFO [monitoring] log/log.go:142 Starting metrics logging every 30s  
Jul 13 13:36:41 ELK-LAB-VM filebeat[27750]: 2022-07-13T13:36:41.473+0800 INFO kibana/client.go:180 Kibana url: [http://10.226.16.50:5601](http://10.226.16.50:5601)  
Jul 13 13:36:41 ELK-LAB-VM filebeat[27750]: 2022-07-13T13:36:41.485+0800 INFO [add\_cloud\_metadata] add\_cloud\_metadata/add\_cloud\_metadata.go:105 \>  
Jul 13 13:36:43 ELK-LAB-VM filebeat[27750]: 2022-07-13T13:36:43.275+0800 INFO kibana/client.go:180 Kibana url: [http://10.226.16.50:5601](http://10.226.16.50:5601)

**But when I restart elasticsearch or kibana service and then restart filebeat it is showing error as below**

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/d/7/d725b52251eb97f8fd79b756b99a34a59cfcf176.png)  
filebeat.service - Filebeat sends log files to Logstash or directly to Elasticsearch.  
Loaded: loaded (/usr/lib/systemd/system/filebeat.service; enabled; vendor preset: disabled)  
Active: failed (Result: exit-code) since Wed 2022-07-13 13:46:14 HKT; 42s ago  
Docs: [Filebeat: Lightweight Log Analysis & Elasticsearch | Elastic](https://www.elastic.co/beats/filebeat)  
Process: 29566 ExecStart=/usr/share/filebeat/bin/filebeat --environment systemd $BEAT\_LOG\_OPTS $BEAT\_CONFIG\_OPTS $BEAT\_PATH\_OPTS (code=exited, status=1/FAILURE)  
Main PID: 29566 (code=exited, status=1/FAILURE)

Jul 13 13:46:13 ELK-LAB-VM systemd[1]: filebeat.service: Failed with result 'exit-code'.  
Jul 13 13:46:14 ELK-LAB-VM systemd[1]: filebeat.service: Service RestartSec=100ms expired, scheduling restart.  
Jul 13 13:46:14 ELK-LAB-VM systemd[1]: filebeat.service: Scheduled restart job, restart counter is at 5.  
Jul 13 13:46:14 ELK-LAB-VM systemd[1]: Stopped Filebeat sends log files to Logstash or directly to Elasticsearch..  
Jul 13 13:46:14 ELK-LAB-VM systemd[1]: filebeat.service: Start request repeated too quickly.  
Jul 13 13:46:14 ELK-LAB-VM systemd[1]: filebeat.service: Failed with result 'exit-code'.  
Jul 13 13:46:14 ELK-LAB-VM systemd[1]: Failed to start Filebeat sends log files to Logstash or directly to Elasticsearch..

**This is my filebeat.yml file**

###################### Filebeat Configuration Example #########################

# This file is an example configuration file highlighting only the most common

# options. The filebeat.reference.yml file from the same directory contains all the

# supported options with more comments. You can use it as a reference.

# 

# You can find the full configuration reference here:

# [Filebeat Reference | Elastic](https://www.elastic.co/guide/en/beats/filebeat/index.html)

# For more available modules and options, please see the filebeat.reference.yml sample

# configuration file.

# ============================== Filebeat inputs ===============================

filebeat.inputs:

# Each - is an input. Most options can be set at the input level, so

# you can use different inputs for various configurations.

# Below are the input specific configurations.

# filestream is an input for collecting log messages from files.

- type: filestream

# are matching any regular expression from the list. By default, no files are dropped.

#prospector.scanner.exclude\_files: ['.gz$']

# Optional additional fields. These fields can be freely picked

# to add additional information to the crawled log files for filtering

#fields:

# level: debug

# review: 1

# ============================== Filebeat modules ==============================

filebeat.config.modules:

# Glob pattern for configuration loading

path: ${path.config}/modules.d/\*.yml

# Set to true to enable config reloading

reload.enabled: false

# Period on which files under path should be checked for changes

#reload.period: 10s

# ======================= Elasticsearch template setting =======================

setup.template.settings:  
index.number\_of\_shards: 1  
#index.codec: best\_compression  
#\_source.enabled: false

# ================================== General ===================================

# The name of the shipper that publishes the network data. It can be used to group

# all the transactions sent by a single shipper in the web interface.

#name:

# The tags of the shipper are included in their own field with each

# transaction published.

#tags: ["service-X", "web-tier"]

# Optional fields that you can specify to add additional information to the

# output.

#fields:

# env: staging

# ================================= Dashboards =================================

# These settings control loading the sample dashboards to the Kibana index. Loading

# the dashboards is disabled by default and can be enabled either by setting the

# options here or by using the `setup` command.

setup.dashboards.enabled: true

# The URL from where to download the dashboards archive. By default this URL

# has a value which is computed based on the Beat name and version. For released

# versions, this URL points to the dashboard archive on the [artifacts.elastic.co](http://artifacts.elastic.co)

# website.

#setup.dashboards.url:

# =================================== Kibana ===================================

# Starting with Beats version 6.0.0, the dashboards are loaded via the Kibana API.

# This requires a Kibana endpoint configuration.

setup.kibana:

# Kibana Host

# Scheme and port can be left out and will be set to the default (http and 5601)

# In case you specify and additional path, the scheme is required: [http://localhost:5601/path](http://localhost:5601/path)

# IPv6 addresses should always be defined as: https://[2001:db8::1]:5601

host: "10.226.16.50:5601"

# Kibana Space ID

# ID of the Kibana Space into which the dashboards should be loaded. By default,

# the Default Space will be used.

#space.id:

# =============================== Elastic Cloud ================================

# These settings simplify using Filebeat with the Elastic Cloud ([https://cloud.elastic.co/](https://cloud.elastic.co/)).

# The cloud.id setting overwrites the `output.elasticsearch.hosts` and

# `setup.kibana.host` options.

# You can find the `cloud.id` in the Elastic Cloud web UI.

#cloud.id:

# The cloud.auth setting overwrites the `output.elasticsearch.username` and

# `output.elasticsearch.password` settings. The format is `<user>:<pass>`.

#cloud.auth:

# ================================== Outputs ===================================

# Configure what output to use when sending the data collected by the beat.

# ---------------------------- Elasticsearch Output ----------------------------

output.elasticsearch:

# Array of hosts to connect to.

```
    hosts: ["http://10.226.16.50:9200"]

```

# Protocol - either `http` (default) or `https`.

#protocol: "https"

# Authentication credentials - either API key or username/password.

#api\_key: "id:api\_key"  
#username: "elastic"  
#password: "changeme"

# ------------------------------ Logstash Output -------------------------------

#output.logstash:

# The Logstash hosts

#hosts: ["localhost:5044"]

# Optional SSL. By default is off.

# List of root certificates for HTTPS server verifications

#ssl.certificate\_authorities: ["/etc/pki/root/ca.pem"]

# Certificate for SSL client authentication

#ssl.certificate: "/etc/pki/client/cert.pem"

# Client Certificate Key

#ssl.key: "/etc/pki/client/cert.key"

# ================================= Processors =================================

processors:

- add\_host\_metadata:  
when.not.contains.tags: forwarded
- add\_cloud\_metadata: ~
- add\_docker\_metadata: ~
- add\_kubernetes\_metadata: ~

# ================================== Logging ===================================

# Sets log level. The default log level is info.

# Available log levels are: error, warning, info, debug

#logging.level: debug

# At debug level, you can selectively enable logging only for some components.

# To enable all selectors use ["\*"]. Examples of other selectors are "beat",

# "publisher", "service".

#logging.selectors: ["\*"]

# ============================= X-Pack Monitoring ==============================

# Filebeat can export internal metrics to a central Elasticsearch monitoring

# cluster. This requires xpack monitoring to be enabled in Elasticsearch. The

# reporting is disabled by default.

# Set to true to enable the monitoring reporter.

#monitoring.enabled: false

# Sets the UUID of the Elasticsearch cluster under which monitoring data for this

# Filebeat instance will appear in the Stack Monitoring UI. If output.elasticsearch

# is enabled, the UUID is derived from the Elasticsearch cluster referenced by output.elasticsearch.

#monitoring.cluster\_uuid:

# Uncomment to send the metrics to Elasticsearch. Most settings from the

# Elasticsearch output are accepted here as well.

# Note that the settings should point to your Elasticsearch _monitoring_ cluster.

# Any setting that is not set is automatically inherited from the Elasticsearch

# output configuration, so if you have the Elasticsearch output configured such

# that it is pointing to your Elasticsearch monitoring cluster, you can simply

# uncomment the following line.

#monitoring.elasticsearch:

# ============================== Instrumentation ===============================

# Instrumentation support for the filebeat.

#instrumentation:  
# Set to true to enable instrumentation of filebeat.  
#enabled: false

```
# Environment in which filebeat is running on (eg: staging, production, etc.)
#environment: ""

# APM Server hosts to report instrumentation results to.

```

#hosts:  
# - [http://localhost:8200](http://localhost:8200)

```
# API Key for the APM Server(s).
# If api_key is set then secret_token will be ignored.
#api_key:

# Secret token for the APM Server(s).
#secret_token:

```

# ================================= Migration ==================================

# This allows to enable 6.7 migration aliases

#migration.6\_to\_7.enabled: true

---

<div class="post-metadata">

### Author: ![Serena\_Chou](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/serena_chou/32/100087_2.png) [@Serena\_Chou](https://discuss.elastic.co/u/Serena_Chou)
#### Post date: [July 13, 2022, 7:54pm UTC](https://discuss.elastic.co/t/failed-to-start-filebeat-sends-log-files-to-logstash-or-directly-to-elasticsearch/309477/2 "2022-07-13T19:54:38Z")

</div>

Hey there, just checking - are you using Enterprise Search or just sending logs to a Elasticsearch only cluster?

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [July 17, 2022, 10:53pm UTC](https://discuss.elastic.co/t/failed-to-start-filebeat-sends-log-files-to-logstash-or-directly-to-elasticsearch/309477/3 "2022-07-17T22:53:44Z")

</div>

Welcome to our community @Nishi_Shah ! 😃

A few things;

- Please don't post pictures of text, logs or code. They are difficult to read, impossible to search and replicate (if it's code), and some people may not be even able to see them
- Please format your code/logs/config using the `</>` button, or markdown style back ticks. It helps to make things easy to read which helps us help you

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [August 14, 2022, 10:53pm UTC](https://discuss.elastic.co/t/failed-to-start-filebeat-sends-log-files-to-logstash-or-directly-to-elasticsearch/309477/4 "2022-08-14T22:53:53Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
