# Failed to start Kibana after upgrade 7.17 to 8.12

**URL:** <https://discuss.elastic.co/t/failed-to-start-kibana-after-upgrade-7-17-to-8-12/355032>\
**Category:** Kibana\
**Created:** [March 8, 2024, 11:59am UTC](https://discuss.elastic.co/t/failed-to-start-kibana-after-upgrade-7-17-to-8-12/355032 "2024-03-08T11:59:20Z")\
**Posts on this page:** 1\
**Showing post:** 2

<div class="post-metadata">

**Author:** ![carly.richmond](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/carly.richmond/32/104935_2.png) [@carly.richmond](https://discuss.elastic.co/u/carly.richmond)\
**Post date:** [March 8, 2024, 1:27pm UTC](https://discuss.elastic.co/t/failed-to-start-kibana-after-upgrade-7-17-to-8-12/355032/2 "2024-03-08T13:27:55Z")

</div>

Hi @michael8,

Welcome to the community!

> [@michael8](#):
>
> `Configuring logger failed: ValidationError: [config validation of [logging].dest]: definition for this key is missing`

The above error message looks similar to that described in [this discuss topic](https://discuss.elastic.co/t/kibana-error-after-upgrade-to-version-8-0-config-validation-of-logging-dest-definition-for-this-key-is-missing/297948). Can you try the solution in that thread and let us know if it resolves your issue?

---

_[View the full topic](https://discuss.elastic.co/t/failed-to-start-kibana-after-upgrade-7-17-to-8-12/355032)._
