# Failed to start logstash5.6.3 after I terminated it

**URL:** <https://discuss.elastic.co/t/failed-to-start-logstash5-6-3-after-i-terminated-it/105496>\
**Category:** Logstash\
**Created:** [October 27, 2017, 1:25am UTC](https://discuss.elastic.co/t/failed-to-start-logstash5-6-3-after-i-terminated-it/105496 "2017-10-27T01:25:08Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![lwolf86](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lwolf86/32/23455_2.png) [@lwolf86](https://discuss.elastic.co/u/lwolf86)\
**Post date:** [October 27, 2017, 1:25am UTC](https://discuss.elastic.co/t/failed-to-start-logstash5-6-3-after-i-terminated-it/105496/1 "2017-10-27T01:25:08Z")

</div>

I'm using logstash5.6.3 to dealing logs, after it show a retryable error which I post it here, then I stop it.  
But I can't start logstash again, show a error log like this:

```auto
[2017-10-27T08:59:00,544][ERROR][logstash.pipeline] Logstash failed to create queue {"exception"=>"java.io.IOException: Page file size 0 different to configured page capacity 262144000 for D:\\Tools\\ElasticStack\\logstash-5.6.3\\data\\queue\\main\\page.31"}
[2017-10-27T08:59:00,591][ERROR][logstash.agent] Cannot create pipeline {:reason=>"java.io.IOException: Page file size 0 different to configured page capacity 262144000 for D:\\Tools\\ElasticStack\\logstash-5.6.3\\data\\queue\\main\\page.31"}

```

I checked persistent queue, there is a page.31 which size is 0.  
 ![page](https://us1.discourse-cdn.com/elastic/original/3X/f/5/f539da7f521218e619bcb29169459e4521001c28.png)  
Can anybody help me out?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 24, 2017, 1:25am UTC](https://discuss.elastic.co/t/failed-to-start-logstash5-6-3-after-i-terminated-it/105496/2 "2017-11-24T01:25:09Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
