# Failed to start shard NumberFormatException

**URL:** <https://discuss.elastic.co/t/failed-to-start-shard-numberformatexception/7834>\
**Category:** Elasticsearch\
**Created:** [May 24, 2012, 7:58am UTC](https://discuss.elastic.co/t/failed-to-start-shard-numberformatexception/7834 "2012-05-24T07:58:38Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![John\_Watson](https://avatars.discourse-cdn.com/v4/letter/j/58f4c7/32.png) [@John\_Watson](https://discuss.elastic.co/u/John_Watson)\
**Post date:** [May 24, 2012, 7:58am UTC](https://discuss.elastic.co/t/failed-to-start-shard-numberformatexception/7834/1 "2012-05-24T07:58:38Z")

</div>

Couple nodes ran out space on their disks that stored the ES shards. After  
shutting down the nodes, clearing some space and starting them back up, the  
log keeps filling with:

[2012-05-24 07:40:38,952][WARN][cluster.action.shard] [Firearm]  
received shard failed for [threads][4], node[5sT1SgOxR16I92QKymk9yw], [P],  
s[INITIALIZING], reason [Failed to start shard, message  
[IndexShardGatewayRecoveryException[[threads][4] failed recovery]; nested:  
NumberFormatException[For input string: "3hr.1337807144597"]; ]]

The [4] (which I assume is the shard number) changes for all shards 0-5 and  
so does the input string.

ES 0.19.4  
Java 1.6.0\_31  
3 nodes - 1 index (6 shards - 1 replica)

---

<div class="post-metadata">

**Author:** ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)\
**Post date:** [May 25, 2012, 10:32pm UTC](https://discuss.elastic.co/t/failed-to-start-shard-numberformatexception/7834/2 "2012-05-25T22:32:08Z")

</div>

There should be another log message on the other node with more details,  
can you gist it?

On Thu, May 24, 2012 at 9:58 AM, John Watson [john@disqus.com](mailto:john@disqus.com) wrote:

> Couple nodes ran out space on their disks that stored the ES shards. After  
> shutting down the nodes, clearing some space and starting them back up, the  
> log keeps filling with:
> 
> [2012-05-24 07:40:38,952][WARN][cluster.action.shard] [Firearm]  
> received shard failed for [threads][4], node[5sT1SgOxR16I92QKymk9yw], [P],  
> s[INITIALIZING], reason [Failed to start shard, message  
> [IndexShardGatewayRecoveryException[[threads][4] failed recovery]; nested:  
> NumberFormatException[For input string: "3hr.1337807144597"]; ]]
> 
> The [4] (which I assume is the shard number) changes for all shards 0-5  
> and so does the input string.
> 
> ES 0.19.4  
> Java 1.6.0\_31  
> 3 nodes - 1 index (6 shards - 1 replica)

---

<div class="post-metadata">

**Author:** ![John\_Watson](https://avatars.discourse-cdn.com/v4/letter/j/58f4c7/32.png) [@John\_Watson](https://discuss.elastic.co/u/John_Watson)\
**Post date:** [May 26, 2012, 3:02am UTC](https://discuss.elastic.co/t/failed-to-start-shard-numberformatexception/7834/3 "2012-05-26T03:02:51Z")

</div>

Here you go: [https://gist.github.com/9393ee7e0f3a70952e3c](https://gist.github.com/9393ee7e0f3a70952e3c)

I was able to recover my cluster by moving the \_state/state- file to  
the replica shards since the cluster seem to always wait for the primary  
shards to attempt recovery.

On Friday, May 25, 2012 3:32:08 PM UTC-7, kimchy wrote:

> There should be another log message on the other node with more details,  
> can you gist it?
> 
> On Thu, May 24, 2012 at 9:58 AM, John Watson [john@disqus.com](mailto:john@disqus.com) wrote:
> 
> > Couple nodes ran out space on their disks that stored the ES shards.  
> > After shutting down the nodes, clearing some space and starting them back  
> > up, the log keeps filling with:
> > 
> > [2012-05-24 07:40:38,952][WARN][cluster.action.shard] [Firearm]  
> > received shard failed for [threads][4], node[5sT1SgOxR16I92QKymk9yw], [P],  
> > s[INITIALIZING], reason [Failed to start shard, message  
> > [IndexShardGatewayRecoveryException[[threads][4] failed recovery]; nested:  
> > NumberFormatException[For input string: "3hr.1337807144597"]; ]]
> > 
> > The [4] (which I assume is the shard number) changes for all shards 0-5  
> > and so does the input string.
> > 
> > ES 0.19.4  
> > Java 1.6.0\_31  
> > 3 nodes - 1 index (6 shards - 1 replica)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 3:26am UTC](https://discuss.elastic.co/t/failed-to-start-shard-numberformatexception/7834/4 "2017-07-06T03:26:50Z")

</div>


