# Failed to start shard

**URL:** <https://discuss.elastic.co/t/failed-to-start-shard/18809>\
**Category:** Elasticsearch\
**Created:** [July 23, 2014, 3:55am UTC](https://discuss.elastic.co/t/failed-to-start-shard/18809 "2014-07-23T03:55:51Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Mohamed\_Lrhazi](https://avatars.discourse-cdn.com/v4/letter/m/74df32/32.png) [@Mohamed\_Lrhazi](https://discuss.elastic.co/u/Mohamed_Lrhazi)\
**Post date:** [July 23, 2014, 3:55am UTC](https://discuss.elastic.co/t/failed-to-start-shard/18809/1 "2014-07-23T03:55:51Z")

</div>

Hello,

Our master is constantly logging this error, about twice per second....

I saw similar error mentioned in the release notes for a previous verion, this cluster is running 1.0.1. Is it the same issue? What work arounds do we have?

[2014-07-22 23:50:28,533][WARN][cluster.action.shard] [rap-es2] [de\_2007][0] received shard failed for [de\_2007][0], node[EtDIFKT7Qi-nAuvG47tGYQ], [P], s[INITIALIZING], indexUUID [yLrHy5k7RqO6rLnl\_b4kww], reason [Failed to start shard, message [IndexShardGatewayRecoveryException[[de\_2007][0] failed to fetch index version after copying it over]; nested: IndexShardGatewayRecoveryException[[de\_2007][0] shard allocated for local recovery (post api), should exist, but doesn't, current files: []]; nested: IndexNotFoundException[no segments\* file found in store(least\_used[rate\_limited(mmapfs(/data/elasticsearch/data/Odine2/nodes/0/indices/de\_2007/0/index), type=MERGE, rate=20.0)]): files: []]; ]]

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/fd9dfaef-7179-4abf-bb60-b8a93982d76a%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/fd9dfaef-7179-4abf-bb60-b8a93982d76a%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Mohamed\_Lrhazi](https://avatars.discourse-cdn.com/v4/letter/m/74df32/32.png) [@Mohamed\_Lrhazi](https://discuss.elastic.co/u/Mohamed_Lrhazi)\
**Post date:** [July 23, 2014, 4:35am UTC](https://discuss.elastic.co/t/failed-to-start-shard/18809/2 "2014-07-23T04:35:42Z")

</div>

I went ahead and upgraded to elasticsearch-1.2.2-1.noarch, but the same  
errors continues after cluster start.

I notice that the node inquestion is the master, and is supposed to be a  
non data node. it should not be starting any shards, right?

Thanks a lot,  
Mohamed.

On Tue, Jul 22, 2014 at 11:55 PM, Mohamed Lrhazi [ml623@georgetown.edu](mailto:ml623@georgetown.edu)  
wrote:

> Hello,
> 
> Our master is constantly logging this error, about twice per second....
> 
> I saw similar error mentioned in the release notes for a previous verion, this cluster is running 1.0.1. Is it the same issue? What work arounds do we have?
> 
> [2014-07-22 23:50:28,533][WARN][cluster.action.shard] [rap-es2] [de\_2007][0] received shard failed for [de\_2007][0], node[EtDIFKT7Qi-nAuvG47tGYQ], [P], s[INITIALIZING], indexUUID [yLrHy5k7RqO6rLnl\_b4kww], reason [Failed to start shard, message [IndexShardGatewayRecoveryException[[de\_2007][0] failed to fetch index version after copying it over]; nested: IndexShardGatewayRecoveryException[[de\_2007][0] shard allocated for local recovery (post api), should exist, but doesn't, current files: ]; nested: IndexNotFoundException[no segments\* file found in store(least\_used[rate\_limited(mmapfs(/data/elasticsearch/data/Odine2/nodes/0/indices/de\_2007/0/index), type=MERGE, rate=20.0)]): files: ]; ]]
> 
> --  
> You received this message because you are subscribed to a topic in the  
> Google Groups "elasticsearch" group.  
> To unsubscribe from this topic, visit  
> [https://groups.google.com/d/topic/elasticsearch/OVc\_0Kqm2yk/unsubscribe](https://groups.google.com/d/topic/elasticsearch/OVc_0Kqm2yk/unsubscribe).  
> To unsubscribe from this group and all its topics, send an email to  
> [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> To view this discussion on the web visit  
> [https://groups.google.com/d/msgid/elasticsearch/fd9dfaef-7179-4abf-bb60-b8a93982d76a%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/fd9dfaef-7179-4abf-bb60-b8a93982d76a%40googlegroups.com)  
> [https://groups.google.com/d/msgid/elasticsearch/fd9dfaef-7179-4abf-bb60-b8a93982d76a%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/fd9dfaef-7179-4abf-bb60-b8a93982d76a%40googlegroups.com?utm_medium=email&utm_source=footer)  
> .  
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/CAEU\_gmfNi6nowVSM1FMxWn6XKZkk\_szcy1%3DCVZ%3Dz%2BZWoZC%3D8HA%40mail.gmail.com](https://groups.google.com/d/msgid/elasticsearch/CAEU_gmfNi6nowVSM1FMxWn6XKZkk_szcy1%3DCVZ%3Dz%2BZWoZC%3D8HA%40mail.gmail.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Anirudh\_Perugu](https://avatars.discourse-cdn.com/v4/letter/a/5daacb/32.png) [@Anirudh\_Perugu](https://discuss.elastic.co/u/Anirudh_Perugu)\
**Post date:** [October 27, 2014, 12:12pm UTC](https://discuss.elastic.co/t/failed-to-start-shard/18809/3 "2014-10-27T12:12:35Z")

</div>

Hi Mohamed,

Did you find a solution to this problem?

On Wednesday, July 23, 2014 10:06:16 AM UTC+5:30, Mohamed Lrhazi wrote:

> I went ahead and upgraded to elasticsearch-1.2.2-1.noarch, but the same  
> errors continues after cluster start.
> 
> I notice that the node inquestion is the master, and is supposed to be a  
> non data node. it should not be starting any shards, right?
> 
> Thanks a lot,  
> Mohamed.
> 
> On Tue, Jul 22, 2014 at 11:55 PM, Mohamed Lrhazi \<ml...@georgetown.edu  
> \<javascript:\>\> wrote:
> 
> > Hello,
> > 
> > Our master is constantly logging this error, about twice per second....
> > 
> > I saw similar error mentioned in the release notes for a previous verion, this cluster is running 1.0.1. Is it the same issue? What work arounds do we have?
> > 
> > [2014-07-22 23:50:28,533][WARN][cluster.action.shard] [rap-es2] [de\_2007][0] received shard failed for [de\_2007][0], node[EtDIFKT7Qi-nAuvG47tGYQ], [P], s[INITIALIZING], indexUUID [yLrHy5k7RqO6rLnl\_b4kww], reason [Failed to start shard, message [IndexShardGatewayRecoveryException[[de\_2007][0] failed to fetch index version after copying it over]; nested: IndexShardGatewayRecoveryException[[de\_2007][0] shard allocated for local recovery (post api), should exist, but doesn't, current files: ]; nested: IndexNotFoundException[no segments\* file found in store(least\_used[rate\_limited(mmapfs(/data/elasticsearch/data/Odine2/nodes/0/indices/de\_2007/0/index), type=MERGE, rate=20.0)]): files: ]; ]]
> > 
> > --  
> > You received this message because you are subscribed to a topic in the  
> > Google Groups "elasticsearch" group.  
> > To unsubscribe from this topic, visit  
> > [https://groups.google.com/d/topic/elasticsearch/OVc\_0Kqm2yk/unsubscribe](https://groups.google.com/d/topic/elasticsearch/OVc_0Kqm2yk/unsubscribe).  
> > To unsubscribe from this group and all its topics, send an email to  
> > [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com) \<javascript:\>.  
> > To view this discussion on the web visit  
> > [https://groups.google.com/d/msgid/elasticsearch/fd9dfaef-7179-4abf-bb60-b8a93982d76a%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/fd9dfaef-7179-4abf-bb60-b8a93982d76a%40googlegroups.com)  
> > [https://groups.google.com/d/msgid/elasticsearch/fd9dfaef-7179-4abf-bb60-b8a93982d76a%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/fd9dfaef-7179-4abf-bb60-b8a93982d76a%40googlegroups.com?utm_medium=email&utm_source=footer)  
> > .  
> > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/52f5a6c8-847c-4294-a2eb-308eb9aa3fe7%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/52f5a6c8-847c-4294-a2eb-308eb9aa3fe7%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Mohamed\_Lrhazi\_2](https://avatars.discourse-cdn.com/v4/letter/m/d6d6ee/32.png) [@Mohamed\_Lrhazi\_2](https://discuss.elastic.co/u/Mohamed_Lrhazi_2)\
**Post date:** [October 27, 2014, 1:09pm UTC](https://discuss.elastic.co/t/failed-to-start-shard/18809/4 "2014-10-27T13:09:31Z")

</div>

Sorry dont recall! but I find this in an email sent on the same thread  
think:

> For me the change that seemed to have worked, I keep my fingers crossed,  
> is to add node.master=False to all nodes except one... black magic!

Other things we did involve: Adding more nodes and deleting indexes with  
zero documents.

HTH,  
Mohamed.

On Mon, Oct 27, 2014 at 8:12 AM, Anirudh Perugu [anirudh@unbxd.com](mailto:anirudh@unbxd.com) wrote:

> Hi Mohamed,
> 
> Did you find a solution to this problem?
> 
> On Wednesday, July 23, 2014 10:06:16 AM UTC+5:30, Mohamed Lrhazi wrote:
> 
> > I went ahead and upgraded to elasticsearch-1.2.2-1.noarch, but the same  
> > errors continues after cluster start.
> > 
> > I notice that the node inquestion is the master, and is supposed to be a  
> > non data node. it should not be starting any shards, right?
> > 
> > Thanks a lot,  
> > Mohamed.
> > 
> > On Tue, Jul 22, 2014 at 11:55 PM, Mohamed Lrhazi [ml...@georgetown.edu](mailto:ml...@georgetown.edu)  
> > wrote:
> > 
> > > Hello,
> > > 
> > > Our master is constantly logging this error, about twice per second....
> > > 
> > > I saw similar error mentioned in the release notes for a previous verion, this cluster is running 1.0.1. Is it the same issue? What work arounds do we have?
> > > 
> > > [2014-07-22 23:50:28,533][WARN][cluster.action.shard] [rap-es2] [de\_2007][0] received shard failed for [de\_2007][0], node[EtDIFKT7Qi-nAuvG47tGYQ], [P], s[INITIALIZING], indexUUID [yLrHy5k7RqO6rLnl\_b4kww], reason [Failed to start shard, message [IndexShardGatewayRecoveryException[[de\_2007][0] failed to fetch index version after copying it over]; nested: IndexShardGatewayRecoveryException[[de\_2007][0] shard allocated for local recovery (post api), should exist, but doesn't, current files: ]; nested: IndexNotFoundException[no segments\* file found in store(least\_used[rate\_limited(mmapfs(/data/elasticsearch/data/Odine2/nodes/0/indices/de\_2007/0/index), type=MERGE, rate=20.0)]): files: ]; ]]
> > > 
> > > --  
> > > You received this message because you are subscribed to a topic in the  
> > > Google Groups "elasticsearch" group.  
> > > To unsubscribe from this topic, visit [https://groups.google.com/d/](https://groups.google.com/d/)  
> > > topic/elasticsearch/OVc\_0Kqm2yk/unsubscribe.  
> > > To unsubscribe from this group and all its topics, send an email to  
> > > [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com).  
> > > To view this discussion on the web visit [https://groups.google.com/d/](https://groups.google.com/d/)  
> > > msgid/elasticsearch/fd9dfaef-7179-4abf-bb60-b8a93982d76a%  
> > > [40googlegroups.com](http://40googlegroups.com)  
> > > [https://groups.google.com/d/msgid/elasticsearch/fd9dfaef-7179-4abf-bb60-b8a93982d76a%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/fd9dfaef-7179-4abf-bb60-b8a93982d76a%40googlegroups.com?utm_medium=email&utm_source=footer)  
> > > .  
> > > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).
> > 
> > --  
> > You received this message because you are subscribed to a topic in the  
> > Google Groups "elasticsearch" group.  
> > To unsubscribe from this topic, visit  
> > [https://groups.google.com/d/topic/elasticsearch/OVc\_0Kqm2yk/unsubscribe](https://groups.google.com/d/topic/elasticsearch/OVc_0Kqm2yk/unsubscribe).  
> > To unsubscribe from this group and all its topics, send an email to  
> > [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> > To view this discussion on the web visit  
> > [https://groups.google.com/d/msgid/elasticsearch/52f5a6c8-847c-4294-a2eb-308eb9aa3fe7%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/52f5a6c8-847c-4294-a2eb-308eb9aa3fe7%40googlegroups.com)  
> > [https://groups.google.com/d/msgid/elasticsearch/52f5a6c8-847c-4294-a2eb-308eb9aa3fe7%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/52f5a6c8-847c-4294-a2eb-308eb9aa3fe7%40googlegroups.com?utm_medium=email&utm_source=footer)  
> > .
> 
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/CAEU\_gmdtPD8Cxg%2BJmqJhtZRgMv%3DQ8SNo7qds1GT%2BOdegkGKQ-w%40mail.gmail.com](https://groups.google.com/d/msgid/elasticsearch/CAEU_gmdtPD8Cxg%2BJmqJhtZRgMv%3DQ8SNo7qds1GT%2BOdegkGKQ-w%40mail.gmail.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 12:53am UTC](https://discuss.elastic.co/t/failed-to-start-shard/18809/5 "2017-07-06T00:53:43Z")

</div>


