# Failed to start shard

**URL:** https://discuss.elastic.co/t/failed-to-start-shard/22577
**Category:** Elasticsearch
**Created:** [March 9, 2015, 6:15am UTC](https://discuss.elastic.co/t/failed-to-start-shard/22577 "2015-03-09T06:15:44Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![Sephen\_Xu](https://avatars.discourse-cdn.com/v4/letter/s/ed8c4c/32.png) [@Sephen\_Xu](https://discuss.elastic.co/u/Sephen_Xu)
#### Post date: [March 9, 2015, 6:15am UTC](https://discuss.elastic.co/t/failed-to-start-shard/22577/1 "2015-03-09T06:15:44Z")

</div>

[2015-03-09 13:46:33,720][WARN][indices.cluster] [es\_node\_4\_2]  
[ossdatabse-2015-02-10][6] failed to start shard  
org.elasticsearch.index.gateway.IndexShardGatewayRecoveryException:  
[ossdatabse-2015-02-10][6] failed to fetch index version after copying it  
over  
at  
org.elasticsearch.index.gateway.local.LocalIndexShardGateway.recover(LocalIndexShardGateway.java:136)  
at  
org.elasticsearch.index.gateway.IndexShardGatewayService$1.run(IndexShardGatewayService.java:197)  
at  
java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)  
at  
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)  
at java.lang.Thread.run(Thread.java:662)  
Caused by:  
org.elasticsearch.index.gateway.IndexShardGatewayRecoveryException:  
[ossdatabse-2015-02-10][6] shard allocated for local recovery (post api),  
should exist, but doesn't, current files: [\_checksums-1424994155456,  
segments.gen]  
at  
org.elasticsearch.index.gateway.local.LocalIndexShardGateway.recover(LocalIndexShardGateway.java:115)  
... 4 more  
Caused by: java.io.FileNotFoundException: segments\_r8  
at  
org.elasticsearch.index.store.Store$StoreDirectory.openInput(Store.java:471)  
at org.apache.lucene.index.SegmentInfos.read(SegmentInfos.java:324)  
at org.apache.lucene.index.SegmentInfos$1.doBody(SegmentInfos.java:404)  
at  
org.apache.lucene.index.SegmentInfos$FindSegmentsFile.run(SegmentInfos.java:843)  
at  
org.apache.lucene.index.SegmentInfos$FindSegmentsFile.run(SegmentInfos.java:694)  
at org.apache.lucene.index.SegmentInfos.read(SegmentInfos.java:400)  
at org.elasticsearch.common.lucene.Lucene.readSegmentInfos(Lucene.java:117)  
at  
org.elasticsearch.index.gateway.local.LocalIndexShardGateway.recover(LocalIndexShardGateway.java:106)  
... 4 more  
[2015-03-09 13:46:33,720][WARN][cluster.action.shard] [es\_node\_4\_2]  
[ossdatabse-2015-02-11][6] sending failed shard for  
[ossdatabse-2015-02-11][6], node[cq\_HPV1ZSlKArq6HgciNSg], [P],  
s[INITIALIZING], indexUUID [7yEPLOpYQciVdw\_W1IF5Hg], reason [Failed to  
start shard, message  
[IndexShardGatewayRecoveryException[[ossdatabse-2015-02-11][6] failed to  
fetch index version after copying it over]; nested:  
IndexShardGatewayRecoveryException[[ossdatabse-2015-02-11][6] shard  
allocated for local recovery (post api), should exist, but doesn't, current  
files: [segments.gen, \_checksums-1425594266760]]; nested:  
FileNotFoundException[segments\_r7]; ]]

How to solve this problem?  
thx

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/40deb4ef-d445-4ed6-a821-68a383354fff%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/40deb4ef-d445-4ed6-a821-68a383354fff%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 12:27am UTC](https://discuss.elastic.co/t/failed-to-start-shard/22577/2 "2017-07-06T00:27:49Z")

</div>


