# Failed to start shard

**URL:** https://discuss.elastic.co/t/failed-to-start-shard/5655
**Category:** Elasticsearch
**Created:** [October 21, 2011, 9:46am UTC](https://discuss.elastic.co/t/failed-to-start-shard/5655 "2011-10-21T09:46:14Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![gnulinux](https://avatars.discourse-cdn.com/v4/letter/g/6de8d8/32.png) [@gnulinux](https://discuss.elastic.co/u/gnulinux)
#### Post date: [October 21, 2011, 9:46am UTC](https://discuss.elastic.co/t/failed-to-start-shard/5655/1 "2011-10-21T09:46:14Z")

</div>

Hi

I am evaluating ElasticSearch (0.17.8) for a spatial search platform. I was able to setup a two-node cluster and everything was working fine. But after rebooting both the nodes, I am getting the following error on both.

[2011-10-19 06:02:45,243][WARN][indices.cluster] [linux Ubu2] [books][1] failed to start shard  
org.elasticsearch.index.gateway.IndexShardGatewayRecoveryException: [books][1] shard allocated for local recovery (post api), should exists, but doesn't  
at org.elasticsearch.index.gateway.local.LocalIndexShardGateway.recover(LocalIndexShardGateway.java:99)  
at org.elasticsearch.index.gateway.IndexShardGatewayService$1.run(IndexShardGatewayService.java:179)  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)  
at java.lang.Thread.run(Thread.java:679)

**Config Files:**

Node01 (Master)

cluster:  
name: gnulinux

node.name: "linux Ubu2"  
node.master: true  
node.data: true  
node.rack: rack01

network:  
bindHost: 192.168.2.10  
publishHost: 192.168.2.10

index.engine.robin.refreshInterval: -1  
index.gateway.snapshot\_interval: -1  
index.gateway.type: local  
index.number\_of\_shards: 5  
index.number\_of\_replicas: 1

gateway.recover\_after\_nodes: 2  
gateway.recover\_after\_time: 5m  
gateway.expected\_nodes: 2  
cluster.routing.allocation.node\_initial\_primaries\_recoveries: 4  
cluster.routing.allocation.node\_concurrent\_recoveries: 2  
indices.recovery.concurrent\_streams: 5

index:  
store:  
fs:  
memory:  
enabled: true  
discovery:  
jgroups:  
config: tcp  
bind\_port: 9700  
bind\_address: 192.168.2.10  
tcpping:  
initial\_hosts: 192.168.2.10[9700], 192.168.2.11[9700]

**Node02:**

cluster:  
name: gnulinux

node.name: "linux Ubu1"  
node.master: false  
node.data: true  
node.rack: rack01

network:  
bindHost: 192.168.2.11  
publishHost: 192.168.2.11

index.engine.robin.refreshInterval: -1  
index.gateway.snapshot\_interval: -1  
index.gateway.type: local  
index.number\_of\_shards: 5  
index.number\_of\_replicas: 1

gateway.recover\_after\_nodes: 2  
gateway.recover\_after\_time: 5m  
gateway.expected\_nodes: 2  
cluster.routing.allocation.node\_initial\_primaries\_recoveries: 4  
cluster.routing.allocation.node\_concurrent\_recoveries: 2  
indices.recovery.concurrent\_streams: 5

index:  
store:  
fs:  
memory:  
enabled: true  
discovery:  
jgroups:  
config: tcp  
bind\_port: 9700  
bind\_address: 192.168.2.11  
tcpping:  
initial\_hosts: 192.168.2.10[9700], 192.168.2.11[9700]

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 3:51am UTC](https://discuss.elastic.co/t/failed-to-start-shard/5655/2 "2017-07-06T03:51:15Z")

</div>


