# Failed to submit a listener notification task... A plugin had an unrecoverable error

**URL:** <https://discuss.elastic.co/t/failed-to-submit-a-listener-notification-task-a-plugin-had-an-unrecoverable-error/60932>\
**Category:** Logstash\
**Created:** [September 19, 2016, 6:41pm UTC](https://discuss.elastic.co/t/failed-to-submit-a-listener-notification-task-a-plugin-had-an-unrecoverable-error/60932 "2016-09-19T18:41:13Z")\
**Posts on this page:** 10\
**Page:** 1

<div class="post-metadata">

**Author:** ![agonzalez](https://avatars.discourse-cdn.com/v4/letter/a/ba8739/32.png) [@agonzalez](https://discuss.elastic.co/u/agonzalez)\
**Post date:** [September 19, 2016, 6:41pm UTC](https://discuss.elastic.co/t/failed-to-submit-a-listener-notification-task-a-plugin-had-an-unrecoverable-error/60932/1 "2016-09-19T18:41:13Z")

</div>

I am seeing this error in logstash every few seconds. any help how to fix this? I am running 5.0-alpha5.

20:34:34.228 [[main]\<beats] ERROR io.netty.util.concurrent.DefaultPromise.rejectedExecution - Failed to submit a listener notification task. Event loop shut down?  
java.util.concurrent.RejectedExecutionException: event executor terminated  
at io.netty.util.concurrent.SingleThreadEventExecutor.reject(SingleThreadEventExecutor.java:840) ~[netty-all-4.1.3.Final.jar:4.1.3.Final]

..  
at org.jruby.javasupport.JavaMethod.invokeDirectWithExceptionHandling(JavaMethod.java:436) [?:?]  
at org.jruby.javasupport.JavaMethod.invokeDirect(JavaMethod.java:300) [?:?]  
at org.jruby.java.invokers.InstanceMethodInvoker.call(InstanceMethodInvoker.java:35) [?:?]  
at org.jruby.runtime.callsite.CachingCallSite.call(CachingCallSite.java:134) [?:?]  
at rubyjit.LogStash::Inputs::Beats$$run\_d71aefd1f73bd440f7e6d0b3603d8ed9fb9fcbcd1173230247. **file** (/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-beats-3.1.0.beta4-java/lib/logstash/inputs/beats.rb:169) [?:?]  
at rubyjit.LogStash::Inputs::Beats$$run\_d71aefd1f73bd440f7e6d0b3603d8ed9fb9fcbcd1173230247. **file** (/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-beats-3.1.0.beta4-java/lib/logstash/inputs/beats.rb) [?:?]  
at org.jruby.internal.runtime.methods.JittedMethod.call(JittedMethod.java:181) [?:?]  
at org.jruby.runtime.callsite.CachingCallSite.call(CachingCallSite.java:168) [?:?]  
...  
at org.jruby.internal.runtime.RubyRunnable.run(RubyRunnable.java:99) [?:?]  
at java.lang.Thread.run(Thread.java:745) [?:1.8.0\_102]  
{:timestamp=\>"2016-09-19T20:34:34.230000+0000", :message=\>"A plugin had an unrecoverable error. Will restart this plugin.\n Plugin: \<LogStash::Inputs::Beats port=\>5044, enable\_metric=\>true, codec=\>\<LogStash::Codecs::Plain enable\_metric=\>true, charset=\>"UTF-8"\>, host=\>"0.0.0.0", ssl=\>false, ssl\_verify\_mode=\>"none", ssl\_handshake\_timeout=\>10000, congestion\_threshold=\>5, target\_field\_for\_codec=\>"message", tls\_min\_version=\>1, tls\_max\_version=\>1.2, cipher\_suites=\>["TLS\_ECDHE\_ECDSA\_WITH\_AES\_256\_GCM\_SHA38", "TLS\_ECDHE\_RSA\_WITH\_AES\_256\_GCM\_SHA384", "TLS\_ECDHE\_ECDSA\_WITH\_AES\_128\_GCM\_SHA256", "TLS\_ECDHE\_RSA\_WITH\_AES\_128\_GCM\_SHA256", "TLS\_ECDHE\_ECDSA\_WITH\_AES\_256\_CBC\_SHA384", "TLS\_ECDHE\_RSA\_WITH\_AES\_256\_CBC\_SHA384", "TLS\_ECDHE\_ECDSA\_WITH\_AES\_128\_CBC\_SHA256"], client\_inactivity\_timeout=\>15\>\n Error: event executor terminated", :level=\>:error}  
{:timestamp=\>"2016-09-19T20:34:34.505000+0000", :message=\>"SNMP Trap listener died", :exception=\>#\<SocketError: bind: name or service not known\>, :backtrace=\>["org/jruby/ext/socket/RubyUDPSocket.java:160:in `bind'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/snmp-1.2.0/lib/snmp/manager.rb:540:in`initialize'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/snmp-1.2.0/lib/snmp/manager.rb:585:in `create_transport'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/snmp-1.2.0/lib/snmp/manager.rb:618:in`initialize'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-snmptrap-3.0.2/lib/logstash/inputs/snmptrap.rb:74:in `build_trap_listener'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-snmptrap-3.0.2/lib/logstash/inputs/snmptrap.rb:78:in`snmptrap\_listener'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-snmptrap-3.0.2/lib/logstash/inputs/snmptrap.rb:53:in `run'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:323:in`inputworker'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:317:in `start\_input'"], :level=\>:warn}

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 20, 2016, 12:48am UTC](https://discuss.elastic.co/t/failed-to-submit-a-listener-notification-task-a-plugin-had-an-unrecoverable-error/60932/2 "2016-09-20T00:48:27Z")

</div>

What's your config look like?

---

<div class="post-metadata">

**Author:** ![agonzalez](https://avatars.discourse-cdn.com/v4/letter/a/ba8739/32.png) [@agonzalez](https://discuss.elastic.co/u/agonzalez)\
**Post date:** [September 20, 2016, 1:38pm UTC](https://discuss.elastic.co/t/failed-to-submit-a-listener-notification-task-a-plugin-had-an-unrecoverable-error/60932/3 "2016-09-20T13:38:23Z")

</div>

```
input {
        beats {
                port => 5044
        }

        snmptrap {
                type => "snmptrap"
                community => "public"
                port => 8162
        }
}

### Add your filters / logstash plugins configuration here

filter {
  if "_grokparsefailure" in [tags] {
        drop {}
  }
}

output {
        elasticsearch {
                hosts => "elasticsearch:9200"
                index => "%{[index]}-%{+YYYY.MM.dd}"
                document_type => "%{type}"
        }
}
```

---

<div class="post-metadata">

**Author:** ![cromaniuc](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cromaniuc/32/12838_2.png) [@cromaniuc](https://discuss.elastic.co/u/cromaniuc)\
**Post date:** [October 31, 2016, 2:06pm UTC](https://discuss.elastic.co/t/failed-to-submit-a-listener-notification-task-a-plugin-had-an-unrecoverable-error/60932/4 "2016-10-31T14:06:25Z")

</div>

I'm having exactly the same error when starting logstash with a Beats input. Logstash works ok with a file input. Any progress here ?

I'm using logstash 5.0.0-rc1.

---

<div class="post-metadata">

**Author:** ![kmroz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kmroz/32/62741_2.png) [@kmroz](https://discuss.elastic.co/u/kmroz)\
**Post date:** [December 5, 2016, 9:40pm UTC](https://discuss.elastic.co/t/failed-to-submit-a-listener-notification-task-a-plugin-had-an-unrecoverable-error/60932/5 "2016-12-05T21:40:46Z")

</div>

Was there ever a solution for this? Running into this now.

---

<div class="post-metadata">

**Author:** ![fei](https://avatars.discourse-cdn.com/v4/letter/f/59ef9b/32.png) [@fei](https://discuss.elastic.co/u/fei)\
**Post date:** [January 9, 2017, 9:52pm UTC](https://discuss.elastic.co/t/failed-to-submit-a-listener-notification-task-a-plugin-had-an-unrecoverable-error/60932/6 "2017-01-09T21:52:08Z")

</div>

Same error here, running filebeat-5.1.1-darwin-x86\_64 and logstash-5.1.1. Any suggestion?

Follow the instruction: [https://www.elastic.co/guide/en/beats/filebeat/current/config-filebeat-logstash.html](https://www.elastic.co/guide/en/beats/filebeat/current/config-filebeat-logstash.html)

---

<div class="post-metadata">

**Author:** ![mattt](https://avatars.discourse-cdn.com/v4/letter/m/46a35a/32.png) [@mattt](https://discuss.elastic.co/u/mattt)\
**Post date:** [January 12, 2017, 12:12am UTC](https://discuss.elastic.co/t/failed-to-submit-a-listener-notification-task-a-plugin-had-an-unrecoverable-error/60932/7 "2017-01-12T00:12:22Z")

</div>

Hi, I'm seeing this error too

filebeat-5.1.1-darwin-x86\_64 and logstash-5.1.1.

---

<div class="post-metadata">

**Author:** ![Troy\_C](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/troy_c/32/14509_2.png) [@Troy\_C](https://discuss.elastic.co/u/Troy_C)\
**Post date:** [January 20, 2017, 5:07pm UTC](https://discuss.elastic.co/t/failed-to-submit-a-listener-notification-task-a-plugin-had-an-unrecoverable-error/60932/8 "2017-01-20T17:07:00Z")

</div>

Yeah, I'm having this issue as well. Would love to get some feedback on this.

---

<div class="post-metadata">

**Author:** ![Troy\_C](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/troy_c/32/14509_2.png) [@Troy\_C](https://discuss.elastic.co/u/Troy_C)\
**Post date:** [January 20, 2017, 6:06pm UTC](https://discuss.elastic.co/t/failed-to-submit-a-listener-notification-task-a-plugin-had-an-unrecoverable-error/60932/9 "2017-01-20T18:06:22Z")

</div>

PS to all, didn't get this working for 5.1, but I downgraded to 5.0.1 and it seems to work fine again.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 4:29am UTC](https://discuss.elastic.co/t/failed-to-submit-a-listener-notification-task-a-plugin-had-an-unrecoverable-error/60932/10 "2017-07-06T04:29:12Z")

</div>


