# Failed to verify server certificate - APM Go Agent with ECK

**URL:** https://discuss.elastic.co/t/failed-to-verify-server-certificate-apm-go-agent-with-eck/280738
**Category:** APM
**Tags:** elastic-stack-security, go
**Created:** [August 8, 2021, 3:34pm UTC](https://discuss.elastic.co/t/failed-to-verify-server-certificate-apm-go-agent-with-eck/280738 "2021-08-08T15:34:39Z")
**Posts on this page:** 1
**Showing post:** 3

<div class="post-metadata">

### Author: ![Hongbo-Miao](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hongbo-miao/32/92664_2.png) [@Hongbo-Miao](https://discuss.elastic.co/u/Hongbo-Miao)
#### Post date: [August 8, 2021, 5:06pm UTC](https://discuss.elastic.co/t/failed-to-verify-server-certificate-apm-go-agent-with-eck/280738/3 "2021-08-08T17:06:24Z")

</div>

Thank you so much @stephenb , that is a good catch!

Now my error becomes

> {"level":"debug","time":"2021-08-08T17:00:09Z","message":"request failed: sending event request failed: Post "[https://hm-apm-apm-http.elastic:8200/intake/v2/events\](https://hm-apm-apm-http.elastic:8200/intake/v2/events%5C)": x509: certificate signed by unknown authority (next request in ~36s)"}

As this is a self signed certificate, I found this answer: [X509: certificate signed by unknown authority - #2 by jsoriano](https://discuss.elastic.co/t/x509-certificate-signed-by-unknown-authority/156815/2)

As I am using Elastic Cloud on Kubernetes (ECK) way to install, I am not sure how to change the config.

I also tried to change to

```auto
ELASTIC_APM_VERIFY_SERVER_CERT: "false"

```

for my Go app. However, just like [the doc](https://www.elastic.co/guide/en/apm/agent/go/current/configuration.html#config-verify-server-cert) says, if I am using `ELASTIC_APM_SERVER_CERT`, the `ELASTIC_APM_VERIFY_SERVER_CERT` will be ignored.

Any guide? Thanks!

---

_[View the full topic](https://discuss.elastic.co/t/failed-to-verify-server-certificate-apm-go-agent-with-eck/280738)._
