# Failed Upgrade from 1.6 to 2

**URL:** <https://discuss.elastic.co/t/failed-upgrade-from-1-6-to-2/57573>\
**Category:** Elasticsearch\
**Created:** [August 9, 2016, 9:46am UTC](https://discuss.elastic.co/t/failed-upgrade-from-1-6-to-2/57573 "2016-08-09T09:46:04Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![NiGame](https://avatars.discourse-cdn.com/v4/letter/n/f475e1/32.png) [@NiGame](https://discuss.elastic.co/u/NiGame)\
**Post date:** [August 9, 2016, 9:46am UTC](https://discuss.elastic.co/t/failed-upgrade-from-1-6-to-2/57573/1 "2016-08-09T09:46:04Z")

</div>

Upgrading from 1.6  
Single node, following instructions from [https://www.elastic.co/guide/en/elasticsearch/reference/current/setup-upgrade.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/setup-upgrade.html)

Disabled shard allocation  
Sync flushed  
shut down elasticsearch plus kibana and logstash to be safe  
installed the new version from updated repositories  
kept old configuration files  
tried to start and get 'Failed' on loop

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [August 9, 2016, 9:55am UTC](https://discuss.elastic.co/t/failed-upgrade-from-1-6-to-2/57573/2 "2016-08-09T09:55:58Z")

</div>

Did you install the migration plugin before upgrading and/or read [https://www.elastic.co/blog/key-point-to-be-aware-of-when-upgrading-from-elasticsearch-1-to-2](https://www.elastic.co/blog/key-point-to-be-aware-of-when-upgrading-from-elasticsearch-1-to-2)? Are there any clues in the ES logs?

---

<div class="post-metadata">

**Author:** ![NiGame](https://avatars.discourse-cdn.com/v4/letter/n/f475e1/32.png) [@NiGame](https://discuss.elastic.co/u/NiGame)\
**Post date:** [August 9, 2016, 10:01am UTC](https://discuss.elastic.co/t/failed-upgrade-from-1-6-to-2/57573/3 "2016-08-09T10:01:25Z")

</div>

No I did not use plugin, was not mentioned in the upgrade pages I looked at.  
Nothing in logs.  
I have since run the command manually to get output from running it and found 2 config errors that I have now corrected. Currently got a new error that I am trying to work out:

[2016-08-09 10:58:50,058][INFO][bootstrap] es.default.config is no longer supported. elasticsearch.yml must be placed in the config directory and cannot be renamed.

My config file is named and owned correctly, guessing it's another config change, but unsure at this time.

---

<div class="post-metadata">

**Author:** ![NiGame](https://avatars.discourse-cdn.com/v4/letter/n/f475e1/32.png) [@NiGame](https://discuss.elastic.co/u/NiGame)\
**Post date:** [August 9, 2016, 10:04am UTC](https://discuss.elastic.co/t/failed-upgrade-from-1-6-to-2/57573/4 "2016-08-09T10:04:59Z")

</div>

Thinking the default directory has changed.  
The logs are now showing this newer error, after my initial fixes

---

<div class="post-metadata">

**Author:** ![NiGame](https://avatars.discourse-cdn.com/v4/letter/n/f475e1/32.png) [@NiGame](https://discuss.elastic.co/u/NiGame)\
**Post date:** [August 9, 2016, 10:12am UTC](https://discuss.elastic.co/t/failed-upgrade-from-1-6-to-2/57573/5 "2016-08-09T10:12:27Z")

</div>

New error, had a logging.xml config file in my config directory it didn't like.

log4j:WARN No appenders could be found for logger (bootstrap).  
log4j:WARN Please initialize the log4j system properly.  
log4j:WARN See [http://logging.apache.org/log4j/1.2/faq.html#noconfig](http://logging.apache.org/log4j/1.2/faq.html#noconfig) for more info.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [August 9, 2016, 10:25am UTC](https://discuss.elastic.co/t/failed-upgrade-from-1-6-to-2/57573/6 "2016-08-09T10:25:58Z")

</div>

Should be `logging.yml`

---

<div class="post-metadata">

**Author:** ![NiGame](https://avatars.discourse-cdn.com/v4/letter/n/f475e1/32.png) [@NiGame](https://discuss.elastic.co/u/NiGame)\
**Post date:** [August 9, 2016, 10:27am UTC](https://discuss.elastic.co/t/failed-upgrade-from-1-6-to-2/57573/7 "2016-08-09T10:27:57Z")

</div>

thanks, so the error must be in my logging.xml

---

<div class="post-metadata">

**Author:** ![NiGame](https://avatars.discourse-cdn.com/v4/letter/n/f475e1/32.png) [@NiGame](https://discuss.elastic.co/u/NiGame)\
**Post date:** [August 9, 2016, 10:43am UTC](https://discuss.elastic.co/t/failed-upgrade-from-1-6-to-2/57573/8 "2016-08-09T10:43:02Z")

</div>

Got it working had to edit /etc/init.d/elasticsearch  
removed '--default.config=$CONF\_FILE' reference

Worked out from old forum posts.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 10:29pm UTC](https://discuss.elastic.co/t/failed-upgrade-from-1-6-to-2/57573/9 "2017-07-05T22:29:07Z")

</div>


