# Fails to deploy ES Helm Chart on Kubernetes

**URL:** <https://discuss.elastic.co/t/fails-to-deploy-es-helm-chart-on-kubernetes/212040>\
**Category:** Elasticsearch\
**Created:** [December 16, 2019, 4:56pm UTC](https://discuss.elastic.co/t/fails-to-deploy-es-helm-chart-on-kubernetes/212040 "2019-12-16T16:56:15Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![nobound](https://avatars.discourse-cdn.com/v4/letter/n/f07891/32.png) [@nobound](https://discuss.elastic.co/u/nobound)\
**Post date:** [December 16, 2019, 4:56pm UTC](https://discuss.elastic.co/t/fails-to-deploy-es-helm-chart-on-kubernetes/212040/1 "2019-12-16T16:56:15Z")

</div>

Hi,

I am using the elasticsearch helm chart ([https://github.com/elastic/helm-charts/tree/master/elasticsearch](https://github.com/elastic/helm-charts/tree/master/elasticsearch)) to deploy to Kubernetes cluster.  
It fails to come up properly. I think it is due to the health check (via http) with its hostname.

I am just wondering if anyone has seen the same issue. Not sure how to debug the issue.

When I run "kubectl describe pods ..."

```auto
.......
 Containers:
  test-es-master-vcqdc-test:
    Container ID: docker://28b6383270b600ef103edd7d1a83b35374fd8fe80d5aba9a673c029a0e86571c
    Image: docker.elastic.co/elasticsearch/elasticsearch:7.4.0
    Image ID: docker-pullable://docker.elastic.co/elasticsearch/elasticsearch@sha256:ccacb1463adc6daee970ed45e34cc46c14ba22116b64d5d4fac58044dfd61e8c
    Port: <none>
    Host Port: <none>
    Command:
      sh
      -c
      #!/usr/bin/env bash -e
      curl -XGET --fail 'test-es-master:9200/_cluster/health?wait_for_status=green&timeout=60s'

    State: Terminated
      Reason: Error
      Exit Code: 7
      Started: Thu, 21 Nov 2019 12:36:16 -0500
      Finished: Thu, 21 Nov 2019 12:36:19 -0500
    Ready: False
    Restart Count: 0
    Environment: <none>
    Mounts:
      /var/run/secrets/kubernetes.io/serviceaccount from default-token-tg24t (ro)

```

---

<div class="post-metadata">

**Author:** ![Julien\_MAILLERET](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/julien_mailleret/32/45074_2.png) [@Julien\_MAILLERET](https://discuss.elastic.co/u/Julien_MAILLERET)\
**Post date:** [December 18, 2019, 7:33am UTC](https://discuss.elastic.co/t/fails-to-deploy-es-helm-chart-on-kubernetes/212040/2 "2019-12-18T07:33:45Z")

</div>

Hi @nobound,  
We'll need more informations to help you,  
Can you post the command you are using to deploy Elasticsearch Helm chart , the content of your `values.yaml` file and the logs of the Elasticsearch pod which is failing?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 15, 2020, 7:33am UTC](https://discuss.elastic.co/t/fails-to-deploy-es-helm-chart-on-kubernetes/212040/3 "2020-01-15T07:33:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
