# Fails to deploy ES on Kubernetes

**URL:** <https://discuss.elastic.co/t/fails-to-deploy-es-on-kubernetes/211499>\
**Category:** Elastic Cloud on Kubernetes (ECK)\
**Created:** [December 11, 2019, 4:36pm UTC](https://discuss.elastic.co/t/fails-to-deploy-es-on-kubernetes/211499 "2019-12-11T16:36:48Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![nobound](https://avatars.discourse-cdn.com/v4/letter/n/f07891/32.png) [@nobound](https://discuss.elastic.co/u/nobound)\
**Post date:** [December 11, 2019, 4:36pm UTC](https://discuss.elastic.co/t/fails-to-deploy-es-on-kubernetes/211499/1 "2019-12-11T16:36:49Z")

</div>

Hi,

I am using the elasticsearch helm chart ([https://github.com/elastic/helm-charts/tree/master/elasticsearch](https://github.com/elastic/helm-charts/tree/master/elasticsearch)) to deploy to Kubernetes cluster.  
It fails to come up properly. I think it is due to the health check (via http) with its hostname.

I am just wondering if anyone has seen the same issue. Not sure how to debug the issue.

When I run "kubectl describe pods ..."

```
.......
 Containers:
  test-es-master-vcqdc-test:
    Container ID: docker://28b6383270b600ef103edd7d1a83b35374fd8fe80d5aba9a673c029a0e86571c
    Image: docker.elastic.co/elasticsearch/elasticsearch:7.4.0
    Image ID: docker-pullable://docker.elastic.co/elasticsearch/elasticsearch@sha256:ccacb1463adc6daee970ed45e34cc46c14ba22116b64d5d4fac58044dfd61e8c
    Port: <none>
    Host Port: <none>
    Command:
      sh
      -c
      #!/usr/bin/env bash -e
      curl -XGET --fail 'test-es-master:9200/_cluster/health?wait_for_status=green&timeout=60s'

    State: Terminated
      Reason: Error
      Exit Code: 7
      Started: Thu, 21 Nov 2019 12:36:16 -0500
      Finished: Thu, 21 Nov 2019 12:36:19 -0500
    Ready: False
    Restart Count: 0
    Environment: <none>
    Mounts:
      /var/run/secrets/kubernetes.io/serviceaccount from default-token-tg24t (ro)
```

---

<div class="post-metadata">

**Author:** ![charith-elastic](https://avatars.discourse-cdn.com/v4/letter/c/3ec8ea/32.png) [@charith-elastic](https://discuss.elastic.co/u/charith-elastic)\
**Post date:** [December 16, 2019, 9:20am UTC](https://discuss.elastic.co/t/fails-to-deploy-es-on-kubernetes/211499/2 "2019-12-16T09:20:42Z")

</div>

As your question is about Helm charts, you might have more luck by posting it to [https://discuss.elastic.co/c/elasticsearch/](https://discuss.elastic.co/c/elasticsearch/) where other Helm users are most likely to see it.

This is the discussion forum for the Kubernetes operator -- which is a different way of orchestrating Elastic stack applications on Kubernetes.

---

<div class="post-metadata">

**Author:** ![nobound](https://avatars.discourse-cdn.com/v4/letter/n/f07891/32.png) [@nobound](https://discuss.elastic.co/u/nobound)\
**Post date:** [December 16, 2019, 4:30pm UTC](https://discuss.elastic.co/t/fails-to-deploy-es-on-kubernetes/211499/3 "2019-12-16T16:30:26Z")

</div>

Thanks. I will give it a try somewhere else.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 4, 2022, 7:37am UTC](https://discuss.elastic.co/t/fails-to-deploy-es-on-kubernetes/211499/4 "2022-11-04T07:37:04Z")

</div>


