# Falha na configuração stack security

**URL:** https://discuss.elastic.co/t/falha-na-configuracao-stack-security/204538
**Category:** Elastic em Português - Brasil
**Created:** [October 21, 2019, 6:58pm UTC](https://discuss.elastic.co/t/falha-na-configuracao-stack-security/204538 "2019-10-21T18:58:16Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![grfneto](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/grfneto/32/125776_2.png) [@grfneto](https://discuss.elastic.co/u/grfneto)
#### Post date: [October 21, 2019, 6:58pm UTC](https://discuss.elastic.co/t/falha-na-configuracao-stack-security/204538/1 "2019-10-21T18:58:16Z")

</div>

Fala pessoal, blz? Então.. estou com dificuldade em configurar um cluster de 3 nós, com o modo security ativo na versão 7.4.0 segue a configuração realizada no cluster:

**elk\_master:**

> cluster.name: homolog  
> node.name: elk\_master  
> node.master: true  
> node.data: false  
> node.ingest: false  
> node.ml: false

> discovery.seed\_hosts: ["10.200.19.121", "10.200.19.122", "10.200.19.123"]  
> cluster.initial\_master\_nodes: ["10.200.19.121"]  
> cluster.remote.connect: false

> xpack.security.enabled: true  
> xpack.security.transport.ssl.enabled: true  
> xpack.security.transport.ssl.verification\_mode: certificate  
> xpack.security.transport.ssl.keystore.path: /etc/elasticsearch/certs/elk\_master.p12  
> xpack.security.transport.ssl.truststore.path: /etc/elasticsearch/certs/elk\_master.p12  
> xpack.security.http.ssl.enabled: true  
> xpack.security.http.ssl.keystore.path: /etc/elasticsearch/certs/elk\_master.p12  
> xpack.security.http.ssl.truststore.path: /etc/elasticsearch/certs/elk\_master.p12

**elk\_node1:**

> cluster.name: homolog  
> node.name: elk\_node1  
> node.data: true  
> node.master: false  
> node.ingest: false  
> node.ml: false

> discovery.seed\_hosts: ["10.200.19.121", "10.200.19.122", "10.200.19.123"]  
> cluster.initial\_master\_nodes: ["10.200.19.121"]  
> cluster.remote.connect: false

> xpack.security.enabled: true  
> xpack.security.transport.ssl.enabled: true  
> xpack.security.transport.ssl.verification\_mode: certificate  
> xpack.security.transport.ssl.keystore.path: /etc/elasticsearch/certs/elk\_node1.p12  
> xpack.security.transport.ssl.truststore.path: /etc/elasticsearch/certs/elk\_node1.p12  
> xpack.security.http.ssl.enabled: true  
> xpack.security.http.ssl.keystore.path: /etc/elasticsearch/certs/elk\_node1.p12  
> xpack.security.http.ssl.truststore.path: /etc/elasticsearch/certs/elk\_node1.p12

**elk\_node2:**

> cluster.name: homolog  
> node.name: elk\_node2  
> node.data: true  
> node.master: false  
> node.ingest: false  
> node.ml: false

> discovery.seed\_hosts: ["10.200.19.121", "10.200.19.122", "10.200.19.123"]  
> cluster.initial\_master\_nodes: ["10.200.19.121"]  
> cluster.remote.connect: false

> xpack.security.enabled: true  
> xpack.security.transport.ssl.enabled: true  
> xpack.security.transport.ssl.verification\_mode: certificate  
> xpack.security.transport.ssl.keystore.path: /etc/elasticsearch/certs/elk\_node2.p12  
> xpack.security.transport.ssl.truststore.path: /etc/elasticsearch/certs/elk\_node2.p12  
> xpack.security.http.ssl.enabled: true  
> xpack.security.http.ssl.keystore.path: /etc/elasticsearch/certs/elk\_node2.p12  
> xpack.security.http.ssl.truststore.path: /etc/elasticsearch/certs/elk\_node2.p12

Segui os passos conforme [documentação](https://www.elastic.co/guide/en/elasticsearch/reference/current/configuring-security.html) porém ao iniciar o serviço do elasticsearch recebo as seguintes informações nos logs do elk\_master:

```auto
org.elasticsearch.xpack.monitoring.exporter.ExportException: failed to flush export bulks
        at org.elasticsearch.xpack.monitoring.exporter.ExportBulk$Compound.lambda$doFlush$0(ExportBulk.java:109) [x-pack-monitoring-7.4.0.jar:7.4.0]
        at org.elasticsearch.action.ActionListener$1.onFailure(ActionListener.java:70) [elasticsearch-7.4.0.jar:7.4.0]
        at org.elasticsearch.xpack.monitoring.exporter.local.LocalBulk.lambda$doFlush$1(LocalBulk.java:112) [x-pack-monitoring-7.4.0.jar:7.4.0]
        at org.elasticsearch.action.ActionListener$1.onFailure(ActionListener.java:70) [elasticsearch-7.4.0.jar:7.4.0]
        at org.elasticsearch.action.support.ContextPreservingActionListener.onFailure(ContextPreservingActionListener.java:50) [elasticsearch-7.4.0.jar:7.4.0]
        at org.elasticsearch.action.support.TransportAction$1.onFailure(TransportAction.java:79) [elasticsearch-7.4.0.jar:7.4.0]
        at org.elasticsearch.action.support.ContextPreservingActionListener.onFailure(ContextPreservingActionListener.java:50) [elasticsearch-7.4.0.jar:7.4.0]
        at org.elasticsearch.action.bulk.TransportBulkAction.doExecute(TransportBulkAction.java:227) [elasticsearch-7.4.0.jar:7.4.0]
        at org.elasticsearch.action.bulk.TransportBulkAction.doExecute(TransportBulkAction.java:93) [elasticsearch-7.4.0.jar:7.4.0]
        at org.elasticsearch.action.support.TransportAction$RequestFilterChain.proceed(TransportAction.java:153) [elasticsearch-7.4.0.jar:7.4.0]
        at org.elasticsearch.xpack.security.action.filter.SecurityActionFilter.lambda$apply$0(SecurityActionFilter.java:86) [x-pack-security-7.4.0.jar:7.4.0]
        at org.elasticsearch.action.ActionListener$1.onResponse(ActionListener.java:62) [elasticsearch-7.4.0.jar:7.4.0]
        at org.elasticsearch.xpack.security.action.filter.SecurityActionFilter.lambda$authorizeRequest$4(SecurityActionFilter.java:172) [x-pack-security-7.4.0.jar:7.4.0]
        at org.elasticsearch.action.ActionListener$1.onResponse(ActionListener.java:62) [elasticsearch-7.4.0.jar:7.4.0]
        at org.elasticsearch.xpack.security.authz.AuthorizationService.lambda$runRequestInterceptors$15(AuthorizationService.java:342) [x-pack-security-7.4.0.jar:7.4.0]
        at org.elasticsearch.action.ActionListener$1.onResponse(ActionListener.java:62) [elasticsearch-7.4.0.jar:7.4.0]
        at org.elasticsearch.common.util.concurrent.ListenableFuture$1.doRun(ListenableFuture.java:99) [elasticsearch-7.4.0.jar:7.4.0]
        at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:37) [elasticsearch-7.4.0.jar:7.4.0]
        at org.elasticsearch.common.util.concurrent.EsExecutors$DirectExecutorService.execute(EsExecutors.java:225) [elasticsearch-7.4.0.jar:7.4.0]
        at org.elasticsearch.common.util.concurrent.ListenableFuture.notifyListener(ListenableFuture.java:93) [elasticsearch-7.4.0.jar:7.4.0]
        at org.elasticsearch.common.util.concurrent.ListenableFuture.lambda$done$0(ListenableFuture.java:85) [elasticsearch-7.4.0.jar:7.4.0]
        at java.util.ArrayList.forEach(ArrayList.java:1507) [?:?]
        at org.elasticsearch.common.util.concurrent.ListenableFuture.done(ListenableFuture.java:85) [elasticsearch-7.4.0.jar:7.4.0]
        at org.elasticsearch.common.util.concurrent.BaseFuture.set(BaseFuture.java:144) [elasticsearch-7.4.0.jar:7.4.0]
        at org.elasticsearch.common.util.concurrent.ListenableFuture.onResponse(ListenableFuture.java:114) [elasticsearch-7.4.0.jar:7.4.0]

```

### OBS.: Também não consigo gerar senha no modo interativo 😕

exibe a seguinte mensagem:

```auto
Unexpected response code [500] from calling GET https://10.200.19.123:9200/_security/_authenticate?pretty
It doesn't look like the X-Pack security feature is enabled on this Elasticsearch node.
Please check if you have enabled X-Pack security in your elasticsearch.yml configuration file.

ERROR: X-Pack Security is disabled by configuration.

```

alguém já passou por isso? poderiam ajudar ?

---

<div class="post-metadata">

### Author: ![luiz.santos](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/luiz.santos/32/24664_2.png) [@luiz.santos](https://discuss.elastic.co/u/luiz.santos)
#### Post date: [October 23, 2019, 2:12pm UTC](https://discuss.elastic.co/t/falha-na-configuracao-stack-security/204538/2 "2019-10-23T14:12:05Z")

</div>

Oi @grfneto,

São dois erros diferentes.

O primeiro deles (`failed to flush export bulks`) está acontecendo porque você desabilitou a role the ingest em todos os nós, portanto eles não podem indexar documentos incluíndo os de monitoramento. Para resolver isso basta remover `node.ingest: false` de todos os `elasticsearch.yml` e reiniciar o serviço.

O segundo problema (`ERROR: X-Pack Security is disabled by configuration.`) é bem estranho porque teoricamente o security está habilitado em todos os nós `xpack.security.enabled: true`.

Você pode conferir novamente os arquivos de configuração e garantir que todos estão com `xpack.security.enabled: true`? Além disso, pode tentar criar as senhas novamente e postar os logs do elasticsearch quando ocorrer o erro?

---

<div class="post-metadata">

### Author: ![grfneto](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/grfneto/32/125776_2.png) [@grfneto](https://discuss.elastic.co/u/grfneto)
#### Post date: [November 5, 2019, 7:07pm UTC](https://discuss.elastic.co/t/falha-na-configuracao-stack-security/204538/3 "2019-11-05T19:07:40Z")

</div>

Oi @luiz.santos,

vlw pela dica. Após remover a propriedade do `node.ingest: false`, continuou a mensagem do segundo problema, sendo que achei um outro [post](https://discuss.elastic.co/t/error-path-does-not-chain-with-any-of-the-trust-anchors-when-enabling-tsl-between-nodes/131078/4) que informa os passos para criar os certificados para cada node, aí consegui resolver.

Contudo, após todos os ajustes, não exibe nenhum `ERROR` nos logs dos nodes, mas também não estão trabalhando em cluster, cada nó está criando seu próprio cluster. Sabe informar o motivo deste comportamento? Já tentei colocar a propriedade `node.master: true` em apenas um nó, porém os outros nó ficam aguardando uma nova eleição para eleger o master.

---

<div class="post-metadata">

### Author: ![grfneto](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/grfneto/32/125776_2.png) [@grfneto](https://discuss.elastic.co/u/grfneto)
#### Post date: [August 20, 2020, 3:19pm UTC](https://discuss.elastic.co/t/falha-na-configuracao-stack-security/204538/4 "2020-08-20T15:19:20Z")

</div>

Para ficar registrado! Após várias análises foi identificado que o problema era de configuração. Para solucionar, apaguei as configurações do cluster com o comando:  
`rm -rf /var/lib/elasticsearch/nodes/`

após reiniciar os serviços, o cluster funcionou corretamente!

Vale ressaltar que não foi necessário a inclusão dessas propriedades:

> node.data: false  
> node.ingest: false  
> node.ml: false

Deixei a configuração _default_ e funcionou corretamente após os ajustes mencionados.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [November 4, 2022, 7:30am UTC](https://discuss.elastic.co/t/falha-na-configuracao-stack-security/204538/5 "2022-11-04T07:30:16Z")

</div>


