# Fatal Error after upgrading from 5.4.2 to 5.5.0

**URL:** https://discuss.elastic.co/t/fatal-error-after-upgrading-from-5-4-2-to-5-5-0/92351
**Category:** Kibana
**Created:** [July 8, 2017, 5:09am UTC](https://discuss.elastic.co/t/fatal-error-after-upgrading-from-5-4-2-to-5-5-0/92351 "2017-07-08T05:09:37Z")
**Posts on this page:** 20
**Page:** 1

<div class="post-metadata">

### Author: ![smlbiobot](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/smlbiobot/32/29622_2.png) [@smlbiobot](https://discuss.elastic.co/u/smlbiobot)
#### Post date: [July 8, 2017, 5:09am UTC](https://discuss.elastic.co/t/fatal-error-after-upgrading-from-5-4-2-to-5-5-0/92351/1 "2017-07-08T05:09:37Z")

</div>

After upgrading from 5.4.2 to 5.5.0, I have received a fatal error when pointing browser to [http://localhost:5901](http://localhost:5901)

What could be the cause of this and how would I fix this?

Uncaught TypeError: Cannot read property 'register' of undefined ([http://localhost:5601/bundles/kibana.bundle.js?v=1:261](http://localhost:5601/bundles/kibana.bundle.js?v=1:261))  
Version: 5.5.0  
Build: 1  
Error: Uncaught TypeError: Cannot read property 'register' of undefined ([http://localhost:5601/bundles/kibana.bundle.js?v=1:261](http://localhost:5601/bundles/kibana.bundle.js?v=1:261))  
at window.onerror ([http://localhost:5601/bundles/commons.bundle.js?v=1:90:20880](http://localhost:5601/bundles/commons.bundle.js?v=1:90:20880))

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [July 8, 2017, 8:45am UTC](https://discuss.elastic.co/t/fatal-error-after-upgrading-from-5-4-2-to-5-5-0/92351/2 "2017-07-08T08:45:48Z")

</div>

What OS?  
What does your config look like?  
How did you install it?

---

<div class="post-metadata">

### Author: ![smlbiobot](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/smlbiobot/32/29622_2.png) [@smlbiobot](https://discuss.elastic.co/u/smlbiobot)
#### Post date: [July 8, 2017, 2:50pm UTC](https://discuss.elastic.co/t/fatal-error-after-upgrading-from-5-4-2-to-5-5-0/92351/3 "2017-07-08T14:50:56Z")

</div>

I am on OSX 10.12.5

MacBookPro (15-inch 2016) 2.9 GHz i7 16GB RAM — not sure that matters but let me know if you need more info. This is my development machine and the production server will be in Linux.

I upgraded to 5.5.0 using

```
brew upgrade elasticsearch
brew upgrade kibana
brew upgrade logstash

```

elasticsearch ran fine but kibana gives that error.

I have some custom plugins installed on the 5.4.2 but even if I have disabled them they do not run

---

<div class="post-metadata">

### Author: ![smlbiobot](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/smlbiobot/32/29622_2.png) [@smlbiobot](https://discuss.elastic.co/u/smlbiobot)
#### Post date: [July 10, 2017, 6:50am UTC](https://discuss.elastic.co/t/fatal-error-after-upgrading-from-5-4-2-to-5-5-0/92351/4 "2017-07-10T06:50:26Z")

</div>

@warkolm To clarify the config, I didn’t do any custom config for it. I didn’t change the kibana.yml file so everything is default, and I did not install any plugins, including no x-pack.

---

<div class="post-metadata">

### Author: ![smlbiobot](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/smlbiobot/32/29622_2.png) [@smlbiobot](https://discuss.elastic.co/u/smlbiobot)
#### Post date: [July 10, 2017, 7:01am UTC](https://discuss.elastic.co/t/fatal-error-after-upgrading-from-5-4-2-to-5-5-0/92351/5 "2017-07-10T07:01:21Z")

</div>

@warkolm This is the full error messages from the log:

```
{"type":"log","@timestamp":"2017-07-10T06:59:14Z","tags":["status","plugin:kibana@5.5.0","info"],"pid":18724,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2017-07-10T06:59:14Z","tags":["status","plugin:elasticsearch@5.5.0","info"],"pid":18724,"state":"yellow","message":"Status changed from uninitialized to yellow - Waiting for Elasticsearch","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2017-07-10T06:59:14Z","tags":["status","plugin:console@5.5.0","info"],"pid":18724,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2017-07-10T06:59:14Z","tags":["status","plugin:metrics@5.5.0","info"],"pid":18724,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2017-07-10T06:59:14Z","tags":["status","plugin:elasticsearch@5.5.0","info"],"pid":18724,"state":"green","message":"Status changed from yellow to green - Kibana index ready","prevState":"yellow","prevMsg":"Waiting for Elasticsearch"}
{"type":"log","@timestamp":"2017-07-10T06:59:15Z","tags":["status","plugin:timelion@5.5.0","info"],"pid":18724,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2017-07-10T06:59:15Z","tags":["listening","info"],"pid":18724,"message":"Server running at http://localhost:5601"}
{"type":"log","@timestamp":"2017-07-10T06:59:15Z","tags":["status","ui settings","info"],"pid":18724,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2017-07-10T06:59:15Z","tags":["connection","client","error"],"pid":18724,"level":"error","message":"Parse Error","error":{"message":"Parse Error","name":"Error","stack":"Error: Parse Error\n at Error (native)","code":"HPE_INVALID_METHOD"}}
```

---

<div class="post-metadata">

### Author: ![tatdat](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tatdat/32/113160_2.png) [@tatdat](https://discuss.elastic.co/u/tatdat)
#### Post date: [July 10, 2017, 7:38am UTC](https://discuss.elastic.co/t/fatal-error-after-upgrading-from-5-4-2-to-5-5-0/92351/6 "2017-07-10T07:38:09Z")

</div>

I got same error when update full elastic Stack from v5.4.3 to v.5.5.0  
OS : centos 7. I update from repo  
Before update, everything worked!

When start kibana, everything is good, no warning log

 ![](https://us1.discourse-cdn.com/elastic/original/3X/b/3/b3e1349954857fe646a61124cdaa2d41fa961271.png)

 ![](https://us1.discourse-cdn.com/elastic/original/3X/b/a/ba20fcccb1df4e8bc78690ea069a9af3c99a1968.png)

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [July 10, 2017, 8:41am UTC](https://discuss.elastic.co/t/fatal-error-after-upgrading-from-5-4-2-to-5-5-0/92351/7 "2017-07-10T08:41:29Z")

</div>

Ignore that sorry.

---

<div class="post-metadata">

### Author: ![bschneiders](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bschneiders/32/20253_2.png) [@bschneiders](https://discuss.elastic.co/u/bschneiders)
#### Post date: [July 10, 2017, 6:59pm UTC](https://discuss.elastic.co/t/fatal-error-after-upgrading-from-5-4-2-to-5-5-0/92351/8 "2017-07-10T18:59:49Z")

</div>

Could this be related to a change in how custom field-formatters are registered? I'm seeing the same error in a custom plugin after updating from 5.4.0 to 5.5.0. I think it's related to imports from 'ui/registry/field\_formats'

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [July 10, 2017, 9:07pm UTC](https://discuss.elastic.co/t/fatal-error-after-upgrading-from-5-4-2-to-5-5-0/92351/9 "2017-07-10T21:07:15Z")

</div>

It doesn't look like it based on [https://www.elastic.co/guide/en/kibana/5.5/release-notes-5.5.0.html](https://www.elastic.co/guide/en/kibana/5.5/release-notes-5.5.0.html)

---

<div class="post-metadata">

### Author: ![Court](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/court/32/6640_2.png) [@Court](https://discuss.elastic.co/u/Court)
#### Post date: [July 10, 2017, 9:38pm UTC](https://discuss.elastic.co/t/fatal-error-after-upgrading-from-5-4-2-to-5-5-0/92351/10 "2017-07-10T21:38:45Z")

</div>

As @bschneiders mentioned, this seems to be related to how we're exporting module files in 5.5, which requires some updates to custom plugins before they are compatible with 5.5.0.

I put some details about this change in a comment on this issue: [https://github.com/elastic/kibana/issues/12707#issuecomment-314216338](https://github.com/elastic/kibana/issues/12707#issuecomment-314216338)

---

<div class="post-metadata">

### Author: ![smlbiobot](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/smlbiobot/32/29622_2.png) [@smlbiobot](https://discuss.elastic.co/u/smlbiobot)
#### Post date: [July 11, 2017, 5:01am UTC](https://discuss.elastic.co/t/fatal-error-after-upgrading-from-5-4-2-to-5-5-0/92351/11 "2017-07-11T05:01:46Z")

</div>

@Court but how do you explain my upgrade / config right now where I still have the same issue after removing all the plugins?

I will add that I did have the old plugins when I upgraded to 5.5.0 and when the fatal error occured. But after removing them all by deleting all the folders inside ./plugins, I still have the same fatal error after restarting.

---

<div class="post-metadata">

### Author: ![LeeDr](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leedr/32/9289_2.png) [@LeeDr](https://discuss.elastic.co/u/LeeDr)
#### Post date: [July 11, 2017, 1:19pm UTC](https://discuss.elastic.co/t/fatal-error-after-upgrading-from-5-4-2-to-5-5-0/92351/12 "2017-07-11T13:19:48Z")

</div>

Did you use the `kibana-plugin remove <your plugin>` or did you just delete your plugins?

If you just deleted files from the plugins dir you might also have to delete files from the optimize directory (while Kibana is stopped). Then when you start it again it should do an `optimize` step that could take a couple of minutes.

Please give that a try.

Thanks,  
Lee

---

<div class="post-metadata">

### Author: ![smlbiobot](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/smlbiobot/32/29622_2.png) [@smlbiobot](https://discuss.elastic.co/u/smlbiobot)
#### Post date: [July 17, 2017, 1:26pm UTC](https://discuss.elastic.co/t/fatal-error-after-upgrading-from-5-4-2-to-5-5-0/92351/13 "2017-07-17T13:26:12Z")

</div>

I did just delete my plugins for the plugins folder, and yes kibana did run optimize — but the fatal error remains. @LeeDr

---

<div class="post-metadata">

### Author: ![LeeDr](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leedr/32/9289_2.png) [@LeeDr](https://discuss.elastic.co/u/LeeDr)
#### Post date: [July 17, 2017, 3:02pm UTC](https://discuss.elastic.co/t/fatal-error-after-upgrading-from-5-4-2-to-5-5-0/92351/14 "2017-07-17T15:02:09Z")

</div>

Hi SML,

I think you might want to just uninstall your current Kibana install and reinstall it again.  
If you have anything customized in your kibana.yml make a safe copy of that.  
Uninstalling Kibana won't delete your .kibana index so you won't loose any saved searches, visualizations, or dashboards.

I'm not familiar with using brew, but you should make sure there is not any plugin files or other files left after the installation so that you know you have a clean install.

Thanks,  
Lee

---

<div class="post-metadata">

### Author: ![smlbiobot](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/smlbiobot/32/29622_2.png) [@smlbiobot](https://discuss.elastic.co/u/smlbiobot)
#### Post date: [July 18, 2017, 6:23am UTC](https://discuss.elastic.co/t/fatal-error-after-upgrading-from-5-4-2-to-5-5-0/92351/15 "2017-07-18T06:23:40Z")

</div>

Ok after installing re-installing all plugins, Kibana is back online. I haven’t upgraded anything and honestly don’t know what happened. That said, I should add that while it’s running fine, I still get this error:

```
  log [06:21:56.071] [info][status][ui settings] Status changed from uninitialized to green - Ready
  log [06:21:56.687] [error][client][connection] Error: Parse Error
at Error (native)

```

But since it is running fine right now I’ll just assume that it’s fine…

---

<div class="post-metadata">

### Author: ![LeeDr](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leedr/32/9289_2.png) [@LeeDr](https://discuss.elastic.co/u/LeeDr)
#### Post date: [July 18, 2017, 3:23pm UTC](https://discuss.elastic.co/t/fatal-error-after-upgrading-from-5-4-2-to-5-5-0/92351/16 "2017-07-18T15:23:36Z")

</div>

I'm not sure but you might possibly see that `Error: Parse Error` if you try to hit [https://localhost:5601](https://localhost:5601) (or wherever your Kibana is) when you're not running with SSL enabled (but you used `https`). Or the other way around.

I'm currently running Kibana with SSL enabled and I'm not seeing that error.

---

<div class="post-metadata">

### Author: ![smlbiobot](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/smlbiobot/32/29622_2.png) [@smlbiobot](https://discuss.elastic.co/u/smlbiobot)
#### Post date: [July 18, 2017, 3:25pm UTC](https://discuss.elastic.co/t/fatal-error-after-upgrading-from-5-4-2-to-5-5-0/92351/17 "2017-07-18T15:25:47Z")

</div>

> [@LeeDr](#):
>
> [https://localhost:5601](https://localhost:5601)

Oh I’ve previously installed ELK with X-Pack to test stuff, then I realized that it was not a free plugin, so I have removed it. So I am unable to use https because I am not running with SSL enabled. I am using http only.

---

<div class="post-metadata">

### Author: ![LeeDr](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leedr/32/9289_2.png) [@LeeDr](https://discuss.elastic.co/u/LeeDr)
#### Post date: [July 18, 2017, 3:43pm UTC](https://discuss.elastic.co/t/fatal-error-after-upgrading-from-5-4-2-to-5-5-0/92351/18 "2017-07-18T15:43:16Z")

</div>

I don't think X-Pack is required to use SSL with Kibana, Elasticsearch, or Logstash. That's all part of the open source products. So you CAN have secure communications without X-Pack.  
You just can't have user authentication/authorization with Users and Roles without X-Pack.

---

<div class="post-metadata">

### Author: ![smlbiobot](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/smlbiobot/32/29622_2.png) [@smlbiobot](https://discuss.elastic.co/u/smlbiobot)
#### Post date: [July 25, 2017, 1:28am UTC](https://discuss.elastic.co/t/fatal-error-after-upgrading-from-5-4-2-to-5-5-0/92351/19 "2017-07-25T01:28:37Z")

</div>

Interesting. Thanks for your help. I will look into it.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [August 22, 2017, 1:29am UTC](https://discuss.elastic.co/t/fatal-error-after-upgrading-from-5-4-2-to-5-5-0/92351/20 "2017-08-22T01:29:06Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
