# FATAL Error: Port 5601 is already in use. Another instance of Kibana may be running!

**URL:** <https://discuss.elastic.co/t/fatal-error-port-5601-is-already-in-use-another-instance-of-kibana-may-be-running/318383>\
**Category:** Kibana\
**Tags:** docker\
**Created:** [November 8, 2022, 3:34am UTC](https://discuss.elastic.co/t/fatal-error-port-5601-is-already-in-use-another-instance-of-kibana-may-be-running/318383 "2022-11-08T03:34:57Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Shadow\_CHN](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shadow_chn/32/107538_2.png) [@Shadow\_CHN](https://discuss.elastic.co/u/Shadow_CHN)\
**Post date:** [November 8, 2022, 3:34am UTC](https://discuss.elastic.co/t/fatal-error-port-5601-is-already-in-use-another-instance-of-kibana-may-be-running/318383/1 "2022-11-08T03:34:57Z")

</div>

Hello Team

I installed Kibana in docker, while the first set up it showed

```auto
[2022-11-07T09:58:18.929+00:00][INFO][node] Kibana process configured with roles: [background_tasks, ui]
[2022-11-07T09:58:40.484+00:00][INFO][plugins-service] Plugin "cloudExperiments" is disabled.
[2022-11-07T09:58:40.495+00:00][INFO][plugins-service] Plugin "profiling" is disabled.
[2022-11-07T09:58:40.580+00:00][FATAL][root] Error: Port 5601 is already in use. Another instance of Kibana may be running!
    at Root.shutdown (/usr/share/kibana/src/core/server/root/index.js:81:18)
    at Root.preboot (/usr/share/kibana/src/core/server/root/index.js:50:18)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)
    at bootstrap (/usr/share/kibana/src/core/server/bootstrap.js:99:9)
    at Command.<anonymous> (/usr/share/kibana/src/cli/serve/serve.js:216:5)

 FATAL Error: Port 5601 is already in use. Another instance of Kibana may be running!

```

And I tried `ps aux | grep kibana`, `lsof -i:5601`, `ss -lntup | grep 5601` I can only know 5601 is listening but dont know the PID.

The content of my `kibana.yml` is:

```auto
# **THIS IS AN AUTO-GENERATED FILE**
#

# Default Kibana configuration for docker target
server.host: "0.0.0.0"
server.shutdownTimeout: "5s"
elasticsearch.hosts: ["http://elasticsearch:9200"]
monitoring.ui.container.elasticsearch.enabled: true

```

Any help please.

---

<div class="post-metadata">

**Author:** ![nickpeihl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nickpeihl/32/112622_2.png) [@nickpeihl](https://discuss.elastic.co/u/nickpeihl)\
**Post date:** [November 8, 2022, 3:13pm UTC](https://discuss.elastic.co/t/fatal-error-port-5601-is-already-in-use-another-instance-of-kibana-may-be-running/318383/2 "2022-11-08T15:13:28Z")

</div>

Are you sure there are no other docker containers using the host port? Does `docker ps` show any other running containers?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 6, 2022, 3:14pm UTC](https://discuss.elastic.co/t/fatal-error-port-5601-is-already-in-use-another-instance-of-kibana-may-be-running/318383/3 "2022-12-06T15:14:21Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
