# FATAL Error: Unable to complete saved object migrations for the \[.kibana\] index: Unable to complete the OUTDATED\_DOCUMENTS\_SEARCH\_OPEN\_PIT step after 15 attempts, terminating

**URL:** <https://discuss.elastic.co/t/fatal-error-unable-to-complete-saved-object-migrations-for-the-kibana-index-unable-to-complete-the-outdated-documents-search-open-pit-step-after-15-attempts-terminating/292210>\
**Category:** Kibana\
**Created:** [December 16, 2021, 6:07pm UTC](https://discuss.elastic.co/t/fatal-error-unable-to-complete-saved-object-migrations-for-the-kibana-index-unable-to-complete-the-outdated-documents-search-open-pit-step-after-15-attempts-terminating/292210 "2021-12-16T18:07:51Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![user23](https://avatars.discourse-cdn.com/v4/letter/u/34f0e0/32.png) [@user23](https://discuss.elastic.co/u/user23)\
**Post date:** [December 16, 2021, 6:07pm UTC](https://discuss.elastic.co/t/fatal-error-unable-to-complete-saved-object-migrations-for-the-kibana-index-unable-to-complete-the-outdated-documents-search-open-pit-step-after-15-attempts-terminating/292210/1 "2021-12-16T18:07:51Z")

</div>

HI!HOW CAN I SOLVE THIS PROBLEM? WHEN I OPEN KIBANA 7.15 VERSION

FATAL Error: Unable to complete saved object migrations for the [.kibana] index: Unable to complete the OUTDATED\_DOCUMENTS\_SEARCH\_OPEN\_PIT step after 15 attempts, terminating.

---

<div class="post-metadata">

**Author:** ![tsullivan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tsullivan/32/31077_2.png) [@tsullivan](https://discuss.elastic.co/u/tsullivan)\
**Post date:** [December 17, 2021, 9:24pm UTC](https://discuss.elastic.co/t/fatal-error-unable-to-complete-saved-object-migrations-for-the-kibana-index-unable-to-complete-the-outdated-documents-search-open-pit-step-after-15-attempts-terminating/292210/2 "2021-12-17T21:24:51Z")

</div>

Hi, can you include the entire error from the server logs, as well as any logs leading to the error?

---

<div class="post-metadata">

**Author:** ![user23](https://avatars.discourse-cdn.com/v4/letter/u/34f0e0/32.png) [@user23](https://discuss.elastic.co/u/user23)\
**Post date:** [December 18, 2021, 5:32am UTC](https://discuss.elastic.co/t/fatal-error-unable-to-complete-saved-object-migrations-for-the-kibana-index-unable-to-complete-the-outdated-documents-search-open-pit-step-after-15-attempts-terminating/292210/3 "2021-12-18T05:32:16Z")

</div>

Hi, following log error might be the error which leads to FATAL Error,

```auto
log [20:43:12.877] [warning][config][plugins][security] Generating a random key for xpack.security.encryptionKey. To prevent sessions from being invalidated on restart, please set xpack.security.encryptionKey in the kibana.yml or use the bin/kibana-encryption-keys command.
  log [20:43:12.878] [warning][config][plugins][security] Session cookies will be transmitted over insecure connections. This is not recommended.
  log [20:43:12.922] [warning][config][plugins][reporting] Generating a random key for xpack.reporting.encryptionKey. To prevent sessions from being invalidated on restart, please set xpack.reporting.encryptionKey in the kibana.yml or use the bin/kibana-encryption-keys command.
 log [20:43:12.948] [warning][encryptedSavedObjects][plugins] Saved objects encryption key is not set. This will severely limit Kibana functionality. Please set xpack.encryptedSavedObjects.encryptionKey in the kibana.yml or use the bin/kibana-encryption-keys command.
  log [20:43:12.991] [warning][actions][plugins] APIs are disabled because the Encrypted Saved Objects plugin is missing encryption key. Please set xpack.encryptedSavedObjects.encryptionKey in the kibana.yml or use the bin/kibana-encryption-keys command.
  log [20:43:13.003] [warning][alerting][plugins] APIs are disabled because the Encrypted Saved Objects plugin is missing encryption key. Please set xpack.encryptedSavedObjects.encryptionKey in the kibana.yml or use the bin/kibana-encryption-keys command.
  log [21:18:39.463] [error][savedobjects-service] [.kibana] migration failed, dumping execution log:
  log [21:18:39.464] [info][savedobjects-service] [.kibana] INIT RESPONSE
  log [21:18:39.691] [info][savedobjects-service] [.kibana] INIT -> OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT
  log [21:18:39.775] [info][savedobjects-service] [.kibana] OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT RESPONSE
  log [21:18:39.787] [info][savedobjects-service] [.kibana] OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT -> OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT
  log [21:18:39.796] [info][savedobjects-service] [.kibana] OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT RESPONSE
  log [21:18:39.796] [info][savedobjects-service] [.kibana] OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT -> OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT
  log [21:18:39.798] [info][savedobjects-service] [.kibana] OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT RESPONSE
  log [21:18:39.799] [info][savedobjects-service] [.kibana] OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT -> OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT
  log [21:18:39.800] [info][savedobjects-service] [.kibana] OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT RESPONSE
  log [21:18:39.801] [info][savedobjects-service] [.kibana] OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT -> OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT
  log [21:18:39.822] [info][savedobjects-service] [.kibana] OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT RESPONSE
  log [21:18:39.826] [info][savedobjects-service] [.kibana] OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT -> OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT
  log [21:18:39.829] [info][savedobjects-service] [.kibana] OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT RESPONSE
  log [21:18:39.832] [info][savedobjects-service] [.kibana] OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT -> OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT
  log [21:18:39.833] [info][savedobjects-service] [.kibana] OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT RESPONSE
  log [21:18:39.836] [info][savedobjects-service] [.kibana] OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT -> OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT
  log [21:18:39.839] [info][savedobjects-service] [.kibana] OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT RESPONSE
  log [21:18:39.840] [info][savedobjects-service] [.kibana] OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT -> OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT
  log [21:18:39.841] [info][savedobjects-service] [.kibana] OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT RESPONSE
  log [21:18:39.843] [info][savedobjects-service] [.kibana] OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT -> OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT
  log [21:18:39.847] [info][savedobjects-service] [.kibana] OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT RESPONSE
  log [21:18:39.850] [info][savedobjects-service] [.kibana] OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT -> OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT
  log [21:18:39.851] [info][savedobjects-service] [.kibana] OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT RESPONSE
  log [21:18:39.856] [info][savedobjects-service] [.kibana] OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT -> OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT
  log [21:18:39.859] [info][savedobjects-service] [.kibana] OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT RESPONSE
  log [21:18:39.862] [info][savedobjects-service] [.kibana] OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT -> OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT
  log [21:18:39.865] [info][savedobjects-service] [.kibana] OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT RESPONSE
  log [21:18:39.868] [info][savedobjects-service] [.kibana] OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT -> OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT
  log [21:18:39.871] [info][savedobjects-service] [.kibana] OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT RESPONSE
  log [21:18:39.874] [info][savedobjects-service] [.kibana] OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT -> OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT
  log [21:18:39.876] [info][savedobjects-service] [.kibana] OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT RESPONSE
  log [21:18:39.877] [info][savedobjects-service] [.kibana] OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT -> OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT
  log [21:18:39.878] [info][savedobjects-service] [.kibana] OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT RESPONSE
  log [21:18:39.879] [info][savedobjects-service] [.kibana] OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT -> FATAL
  log [21:18:39.895] [fatal][root] Error: Unable to complete saved object migrations for the [.kibana] index: Unable to complete the OUTDATED_DOCUMENTS_SEARCH_OPEN_PIT step after 15 attempts, terminating.

  log [21:17:33.198] [error][savedobjects-service] [.kibana] Action failed with 'search_phase_execution_exception: '. Retrying attempt 15 in 64 seconds.
  log [20:52:49.308] [error][savedobjects-service] [.kibana] Action failed with 'search_phase_execution_exception: '. Retrying attempt 14 in 64 seconds.

```

---

<div class="post-metadata">

**Author:** ![tsullivan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tsullivan/32/31077_2.png) [@tsullivan](https://discuss.elastic.co/u/tsullivan)\
**Post date:** [December 20, 2021, 11:09pm UTC](https://discuss.elastic.co/t/fatal-error-unable-to-complete-saved-object-migrations-for-the-kibana-index-unable-to-complete-the-outdated-documents-search-open-pit-step-after-15-attempts-terminating/292210/4 "2021-12-20T23:09:46Z")

</div>

Hi, did any of the kibana.yml settings change from before the upgrade?

Are you using the `kibana_system` user as the Elasticsearch.user in the kibana.yml?

---

<div class="post-metadata">

**Author:** ![user23](https://avatars.discourse-cdn.com/v4/letter/u/34f0e0/32.png) [@user23](https://discuss.elastic.co/u/user23)\
**Post date:** [December 21, 2021, 5:17am UTC](https://discuss.elastic.co/t/fatal-error-unable-to-complete-saved-object-migrations-for-the-kibana-index-unable-to-complete-the-outdated-documents-search-open-pit-step-after-15-attempts-terminating/292210/5 "2021-12-21T05:17:39Z")

</div>

1. 

kibana.yml settings , I have uncomment the elasticsearch.hosts ,

# The URLs of the Elasticsearch instances to use for all your queries.

elasticsearch.hosts: ["[http://localhost:9200](http://localhost:9200)"]  
2.  
kibana\_system user as the Elasticsearch.user in kibana.yml is #elasticsearch.username: "kibana\_system"

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 18, 2022, 5:18am UTC](https://discuss.elastic.co/t/fatal-error-unable-to-complete-saved-object-migrations-for-the-kibana-index-unable-to-complete-the-outdated-documents-search-open-pit-step-after-15-attempts-terminating/292210/6 "2022-01-18T05:18:26Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
