# Fatal in logstash 6.0.0

**URL:** https://discuss.elastic.co/t/fatal-in-logstash-6-0-0/114469
**Category:** Logstash
**Created:** [January 8, 2018, 8:53am UTC](https://discuss.elastic.co/t/fatal-in-logstash-6-0-0/114469 "2018-01-08T08:53:12Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![sbampa](https://avatars.discourse-cdn.com/v4/letter/s/8e7dd6/32.png) [@sbampa](https://discuss.elastic.co/u/sbampa)
#### Post date: [January 8, 2018, 8:53am UTC](https://discuss.elastic.co/t/fatal-in-logstash-6-0-0/114469/1 "2018-01-08T08:53:13Z")

</div>

Hi all,  
i receive the following error in logstash logs and the process died.:

Error: unknown IOException: jnr.enxio.channels.NativeException: Error closing fd 371: Stale NFS file handle  
Exception: Java::JavaLang::RuntimeException  
Stack: org.jruby.util.io.PosixShim.close(PosixShim.java:260)  
.....  
.....  
[2018-01-08T01:26:50,814][FATAL][logstash.runner] An unexpected error occurred! {:error=\>#\<NoMethodError: undefined method `map_cleanup' for nil:NilClass>, :backtrace=>["/export/home/elastic/logstash-6.0.0/vendor/bundle/jruby/2.3.0/gems/logstash-codec-multiline-3.0.7/lib/logstash/codecs/identity_map_codec.rb:55:in`block in start'"]}

I don't know the cause, can someone help me to solve?

---

<div class="post-metadata">

### Author: ![guyboertje](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/guyboertje/32/31592_2.png) [@guyboertje](https://discuss.elastic.co/u/guyboertje)
#### Post date: [January 8, 2018, 9:12am UTC](https://discuss.elastic.co/t/fatal-in-logstash-6-0-0/114469/2 "2018-01-08T09:12:56Z")

</div>

The second FATAL error logged is a known rare case that is logged during shutdown.

The `Stale NFS file handle` exception seems to be causing the LS shutdown.

What is your config? Where is NFS being used?

---

<div class="post-metadata">

### Author: ![sbampa](https://avatars.discourse-cdn.com/v4/letter/s/8e7dd6/32.png) [@sbampa](https://discuss.elastic.co/u/sbampa)
#### Post date: [January 8, 2018, 9:16am UTC](https://discuss.elastic.co/t/fatal-in-logstash-6-0-0/114469/3 "2018-01-08T09:16:47Z")

</div>

LS in my config has 1 beats input and several file input, a grok filte with date and mutate and several output configs. 4 gb of heap, 16 worker (i have 16 cpu) and 250 pipeline.batch.size.

With file input i read from an nfs share....

---

<div class="post-metadata">

### Author: ![guyboertje](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/guyboertje/32/31592_2.png) [@guyboertje](https://discuss.elastic.co/u/guyboertje)
#### Post date: [January 8, 2018, 9:23am UTC](https://discuss.elastic.co/t/fatal-in-logstash-6-0-0/114469/4 "2018-01-08T09:23:46Z")

</div>

There are known problems with the file input and NFS.

> [@Logstash vs NFS (null characters)](https://discuss.elastic.co/t/logstash-vs-nfs-null-characters/25918/3):
>
> I had the same problem. Couldn't find a way around it. Our (dirty) hack/workaround is to have a scheduled task running every 5 minutes to: shutdown logstash indexer copy the file restart logstash and index file This is okay for us as we don't need perfectly real-time indexing at least it works reliably since a couple of months. It also solved the problems with locked resources we encountered before...

[Missing event - file input plugin / NFS - #19 by steffens](https://discuss.elastic.co/t/missing-event-file-input-plugin-nfs/107838/19) (with input from the LS and Beats teams)

You should put Filebeat on the machine that the NFS share points at.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [February 5, 2018, 9:23am UTC](https://discuss.elastic.co/t/fatal-in-logstash-6-0-0/114469/5 "2018-02-05T09:23:54Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
