# FATAL TypeError: Cannot read property 'version' of undefined while starting kibana

**URL:** <https://discuss.elastic.co/t/fatal-typeerror-cannot-read-property-version-of-undefined-while-starting-kibana/210370>\
**Category:** Kibana\
**Created:** [December 3, 2019, 2:17pm UTC](https://discuss.elastic.co/t/fatal-typeerror-cannot-read-property-version-of-undefined-while-starting-kibana/210370 "2019-12-03T14:17:38Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![gapa582](https://avatars.discourse-cdn.com/v4/letter/g/b487fb/32.png) [@gapa582](https://discuss.elastic.co/u/gapa582)\
**Post date:** [December 3, 2019, 2:17pm UTC](https://discuss.elastic.co/t/fatal-typeerror-cannot-read-property-version-of-undefined-while-starting-kibana/210370/1 "2019-12-03T14:17:39Z")

</div>

After upgrading kibana from v7.4 to v7.5, I keep getting this error  
"FATAL TypeError: Cannot read property 'version' of undefined"  
I'm using amazon linux and it was working great before the upgrade

---

<div class="post-metadata">

**Author:** ![millap](https://avatars.discourse-cdn.com/v4/letter/m/3ec8ea/32.png) [@millap](https://discuss.elastic.co/u/millap)\
**Post date:** [December 4, 2019, 7:44am UTC](https://discuss.elastic.co/t/fatal-typeerror-cannot-read-property-version-of-undefined-while-starting-kibana/210370/2 "2019-12-04T07:44:44Z")

</div>

I also have this error on upgrade from 7.4 to 7.5, but in own hosted environment.

```
root@elk01:/usr/share/kibana# sudo -u kibana bin/kibana --verbose 

 FATAL TypeError: Cannot read property 'version' of undefined

```

Andy

---

<div class="post-metadata">

**Author:** ![gapa582](https://avatars.discourse-cdn.com/v4/letter/g/b487fb/32.png) [@gapa582](https://discuss.elastic.co/u/gapa582)\
**Post date:** [December 4, 2019, 10:51am UTC](https://discuss.elastic.co/t/fatal-typeerror-cannot-read-property-version-of-undefined-while-starting-kibana/210370/3 "2019-12-04T10:51:59Z")

</div>

Fixed it, it was a kibana plugin once removed, everything went back to normal

For anyone who face this issue, just make sure that your kibana plugin dir. is empty or at least try removing one by one. One of them is causing this for sure.

---

<div class="post-metadata">

**Author:** ![gapa582](https://avatars.discourse-cdn.com/v4/letter/g/b487fb/32.png) [@gapa582](https://discuss.elastic.co/u/gapa582)\
**Post date:** [December 4, 2019, 10:56am UTC](https://discuss.elastic.co/t/fatal-typeerror-cannot-read-property-version-of-undefined-while-starting-kibana/210370/4 "2019-12-04T10:56:19Z")

</div>

Check your kibana plugins directory, mine was in /usr/share/kibana/plugins  
Make sure it's empty and everything should work fine

---

<div class="post-metadata">

**Author:** ![millap](https://avatars.discourse-cdn.com/v4/letter/m/3ec8ea/32.png) [@millap](https://discuss.elastic.co/u/millap)\
**Post date:** [December 4, 2019, 11:09am UTC](https://discuss.elastic.co/t/fatal-typeerror-cannot-read-property-version-of-undefined-while-starting-kibana/210370/5 "2019-12-04T11:09:12Z")

</div>

Top find! That worked for me.

> root@elk01:/usr/share/kibana/plugins# ls  
> elastalert-kibana-plugin

Andy

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 1, 2020, 11:15am UTC](https://discuss.elastic.co/t/fatal-typeerror-cannot-read-property-version-of-undefined-while-starting-kibana/210370/6 "2020-01-01T11:15:07Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
