# Fetching clusters failed

**URL:** <https://discuss.elastic.co/t/fetching-clusters-failed/146228>\
**Category:** Elasticsearch\
**Created:** [August 27, 2018, 6:43pm UTC](https://discuss.elastic.co/t/fetching-clusters-failed/146228 "2018-08-27T18:43:29Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![hyonkwak](https://avatars.discourse-cdn.com/v4/letter/h/ea5d25/32.png) [@hyonkwak](https://discuss.elastic.co/u/hyonkwak)\
**Post date:** [August 27, 2018, 6:43pm UTC](https://discuss.elastic.co/t/fetching-clusters-failed/146228/1 "2018-08-27T18:43:30Z")

</div>

I have installed ECE on a single AWS EC2 instances (m5.2xlarge). I am able to create a new cluster, but once I click away from clusters in the ECE Admin console (such as clicking on Platform link), it forgets all the clusters. In fact, I have 2 clusters running with Kibana which I am able to log into, but they aren't visible in the Admin console. I get "Fetching clusters failed." This error is similiar to

> [@Kibana Instances "Unable to Connect to Server"](https://discuss.elastic.co/t/kibana-instances-unable-to-connect-to-server/104118):
>
> I have installed ECE on a few machines, and have set up 2 clusters, each with a seperate kibana instance. After about a week of normal operation, I attempted to access one of the kibana dashboards, to received an "internal server error" message, much like this issue. All the kibana instances across my clusters had this problem. [https://discuss.elastic.co/t/500-an-internal-server-error/?source\_topic\_id=104118](https://discuss.elastic.co/t/500-an-internal-server-error/?source_topic_id=104118) I then attempted to restart the Kibana isntance, which didn't work. I then attempted to…

It may be related that when I installed ECE, I never got the root or readonly password instead I got timed out in the logs. I pulled the password from /mnt/data/elastic/bootstrap-state/bootstrap-secrets.json instead. I just thought my timeout was set too low.

Logs:  
proxy.log (tail proxy.log)  
[2018-08-27 18:33:12,343][WARN][no.found.proxy.models.dns.DNSResolverActor$$anon$1] Unable to resolve host [logging-backend] due to [host not found], returning empty list. {}

zookeeper.log (less zookeeper.log | grep WARN)  
2018-08-23 18:37:23,633 [myid:] - WARN [main:QuorumPeerConfig@590] - No server failure will be tolerated. You need at least 3 servers.  
2018-08-23 18:37:23,724 [myid:10] - WARN [main:ContextHandler@1339] - o.e.j.s.ServletContextHandler@29ee9faa{/,null,null} contextPath ends with /\*  
2018-08-23 18:37:23,724 [myid:10] - WARN [main:ContextHandler@1350] - Empty contextPath  
2018-08-23 19:07:41,694 [myid:10] - WARN [NIOWorkerThread-6:NIOServerCnxn@366] - Unable to read additional data from client sessionid 0xa00001a36d00001, likely client has closed socket

client-forwarder.log (less client-forwarder.log | grep WARN)  
[2018-08-23 18:37:25,177][WARN][org.apache.zookeeper.ClientCnxn] Session 0x0 for server null, unexpected error, closing socket connection and attempting reconnect {}  
[2018-08-23 18:37:25,379][WARN][no.found.clientforwarder.curator.CachingEnsembleProvider] Received empty coordinators: [Coordinators(Map())], not updating. Previously was: [Coordinators(Map(10.105.142.78 -\> CoordinatorInfo(10,10.105.142.78,10.105.142.78,2898,3898,2191,{})))] {}

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 24, 2018, 6:43pm UTC](https://discuss.elastic.co/t/fetching-clusters-failed/146228/2 "2018-09-24T18:43:32Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
