# Fielddata error preventing Authentications tab populating

**URL:** <https://discuss.elastic.co/t/fielddata-error-preventing-authentications-tab-populating/197337>\
**Category:** SIEM\
**Created:** [August 29, 2019, 12:38pm UTC](https://discuss.elastic.co/t/fielddata-error-preventing-authentications-tab-populating/197337 "2019-08-29T12:38:55Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![hilt86](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hilt86/32/20308_2.png) [@hilt86](https://discuss.elastic.co/u/hilt86)\
**Post date:** [August 29, 2019, 12:38pm UTC](https://discuss.elastic.co/t/fielddata-error-preventing-authentications-tab-populating/197337/1 "2019-08-29T12:38:55Z")

</div>

Hi all,

I'm using Filebeat 7.3.1 with Elastic Cloud 7.3.0 and the Authentications pane (in SIEM app) is empty (despite being able to view them in Discover / filebeat index.

When I inspect the response in the SIEM app I get :

```auto
type": "illegal_argument_exception",
          "reason": "Fielddata is disabled on text fields by default

```

The index template is loaded so not sure why this is happening? Same is happening on Auditbeat

---

<div class="post-metadata">

**Author:** ![cwurm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cwurm/32/34882_2.png) [@cwurm](https://discuss.elastic.co/u/cwurm)\
**Post date:** [August 29, 2019, 4:11pm UTC](https://discuss.elastic.co/t/fielddata-error-preventing-authentications-tab-populating/197337/2 "2019-08-29T16:11:10Z")

</div>

Most likely `user.name` is a `text` field when it should be `keyword`. Have you loaded the templates for Auditbeat and Filebeat using the `setup` command? Do they contain this section:

```auto
{
          "strings_as_keyword" : {
            "mapping" : {
              "ignore_above" : 1024,
              "type" : "keyword"
            },
            "match_mapping_type" : "string"
          }
        }

```

That should ensure that `user.name` (and all other string fields) is a `keyword` field.

Ideally, you could fix the templates and reindex the data so it's all `keyword` fields. You could also keep your current data and enable fielddata as described in [https://www.elastic.co/guide/en/elasticsearch/reference/current/fielddata.html#enable-fielddata-text-fields](https://www.elastic.co/guide/en/elasticsearch/reference/current/fielddata.html#enable-fielddata-text-fields).

---

<div class="post-metadata">

**Author:** ![hilt86](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hilt86/32/20308_2.png) [@hilt86](https://discuss.elastic.co/u/hilt86)\
**Post date:** [August 29, 2019, 9:48pm UTC](https://discuss.elastic.co/t/fielddata-error-preventing-authentications-tab-populating/197337/3 "2019-08-29T21:48:12Z")

</div>

Thanks @cwurm! Yes I've run the setup command, deleted all filebeat indexes. Here's the template [current filebeat template](https://gist.github.com/hilt86/7b1e673c7d045fadfa94970eda6bc724).

If I inspect the mapping for user :

```auto
      "user": {
        "properties": {
          "name": {
            "type": "text",
            "fields": {
              "keyword": {
                "type": "keyword",
                "ignore_above": 256
              }
            }
          }
        }

```

I'm stumped for now...any other suggestions? Re-indexing doesn't appeal as I can just delete my indexes as I can do without the data for a little while, but hopefully not much longer!

---

<div class="post-metadata">

**Author:** ![hilt86](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hilt86/32/20308_2.png) [@hilt86](https://discuss.elastic.co/u/hilt86)\
**Post date:** [September 4, 2019, 3:41am UTC](https://discuss.elastic.co/t/fielddata-error-preventing-authentications-tab-populating/197337/4 "2019-09-04T03:41:04Z")

</div>

Here are the steps I took to fix the problem :

- Stop all filebeat services from sending data (this was apparently what prevented index template from applying)
- Delete all filebeat indexes
- run `sudo filebeat setup` on a node

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 2, 2019, 3:41am UTC](https://discuss.elastic.co/t/fielddata-error-preventing-authentications-tab-populating/197337/5 "2019-10-02T03:41:05Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
