# Fielddata is disabled on text fields by default. Set fielddata=true on \[host.name\] in order to load fielddata in memory by uninverting the inverted index

**URL:** <https://discuss.elastic.co/t/fielddata-is-disabled-on-text-fields-by-default-set-fielddata-true-on-host-name-in-order-to-load-fielddata-in-memory-by-uninverting-the-inverted-index/212111>\
**Category:** Beats\
**Tags:** metricbeat\
**Created:** [December 17, 2019, 7:56am UTC](https://discuss.elastic.co/t/fielddata-is-disabled-on-text-fields-by-default-set-fielddata-true-on-host-name-in-order-to-load-fielddata-in-memory-by-uninverting-the-inverted-index/212111 "2019-12-17T07:56:09Z")\
**Posts on this page:** 1\
**Showing post:** 3

<div class="post-metadata">

**Author:** ![skdasari](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/skdasari/32/50452_2.png) [@skdasari](https://discuss.elastic.co/u/skdasari)\
**Post date:** [December 18, 2019, 6:42am UTC](https://discuss.elastic.co/t/fielddata-is-disabled-on-text-fields-by-default-set-fielddata-true-on-host-name-in-order-to-load-fielddata-in-memory-by-uninverting-the-inverted-index/212111/3 "2019-12-18T06:42:19Z")

</div>

I think it might be an issue with the index mapping recently I have setup a lifecycle policy for the metricbeat index as it has like one month hot phase by default. I set it to one week and then applied delete phase to the policy. After this the index got messed up showing this error. Not sure what to do here because even after deleting the exxisting index the newly formed index is also giving the same error

---

_[View the full topic](https://discuss.elastic.co/t/fielddata-is-disabled-on-text-fields-by-default-set-fielddata-true-on-host-name-in-order-to-load-fielddata-in-memory-by-uninverting-the-inverted-index/212111)._
