# File input fails after upgrading logstash from 2.3.3 to 5.0.0-alpha4

**URL:** <https://discuss.elastic.co/t/file-input-fails-after-upgrading-logstash-from-2-3-3-to-5-0-0-alpha4/55023>\
**Category:** Logstash\
**Created:** [July 8, 2016, 7:05am UTC](https://discuss.elastic.co/t/file-input-fails-after-upgrading-logstash-from-2-3-3-to-5-0-0-alpha4/55023 "2016-07-08T07:05:01Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![YuWatanabe](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yuwatanabe/32/13259_2.png) [@YuWatanabe](https://discuss.elastic.co/u/YuWatanabe)\
**Post date:** [July 8, 2016, 7:05am UTC](https://discuss.elastic.co/t/file-input-fails-after-upgrading-logstash-from-2-3-3-to-5-0-0-alpha4/55023/1 "2016-07-08T07:05:01Z")

</div>

Hi!

I would like ask question about the file input for ver 5.0.0-alpha4.

**Problem**  
I just upgraded logstash from _2.3.3_ to _5.0.0-alpha4_ using _yum update_.  
However , file input for /var/log/message fails due to file permission error.

```
{:timestamp=>"2016-07-08T15:06:00.969000+0900", :message=>"Pipeline main started"}
{:timestamp=>"2016-07-08T15:11:01.214000+0900", :message=>"failed to open /var/log/yum.log: Permission denied - /var/log/yum.log", :level=>:warn}
{:timestamp=>"2016-07-08T15:11:01.215000+0900", :message=>"failed to open /var/log/messages: Permission denied - /var/log/messages", :level=>:warn}

```

`Analysis`  
I have set up LS\_USER in /etc/sysconfig/logstash but the user of the process is logstash.

```
[root@ip-172-30-1-196 logstash]# cat /etc/sysconfig/logstash
###############################
# Default settings for logstash
###############################

# Override Java location
#JAVACMD=/usr/bin/java

# Set a home directory
#LS_HOME=/var/lib/logstash

# Arguments to pass to logstash agent
#LS_OPTS=""

# Arguments to pass to java
#LS_HEAP_SIZE="1g"
#LS_JAVA_OPTS="-Djava.io.tmpdir=$HOME"

# pidfiles aren't used for upstart; this is for sysv users.
#LS_PIDFILE=/var/run/logstash.pid

# user id to be invoked as; for upstart: edit /etc/init/logstash.conf
#LS_USER=logstash
LS_USER=root

# logstash logging
#LS_LOG_FILE=/var/log/logstash/logstash.log
#LS_USE_GC_LOGGING="true"
#LS_GC_LOG_FILE=/var/log/logstash/gc.log

# logstash configuration directory
#LS_CONF_DIR=/etc/logstash/conf.d

# Open file limit; cannot be overridden in upstart
#LS_OPEN_FILES=16384

# Nice level
#LS_NICE=19

# If this is set to 1, then when `stop` is called, if the process has
# not exited within a reasonable time, SIGKILL will be sent next.
# The default behavior is to simply log a message "program stop failed; still running"
#KILL_ON_STOP_TIMEOUT=0

[root@ip-172-30-1-196 logstash]# ps -eF | grep logstash
logstash 12339 1 2 916386 468516 0 15:05 ? 00:01:09 /usr/bin/java -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -XX:+DisableExplicitGC -Djava.awt.headless=true -Dfile.encoding=UTF-8 -XX:+HeapDumpOnOutOfMemoryError -Xmx1g -Xms256m -Xss2048k -Djffi.boot.library.path=/usr/share/logstash/vendor/jruby/lib/jni -Xbootclasspath/a:/usr/share/logstash/vendor/jruby/lib/jruby.jar -classpath : -Djruby.home=/usr/share/logstash/vendor/jruby -Djruby.lib=/usr/share/logstash/vendor/jruby/lib -Djruby.script=jruby -Djruby.shell=/bin/sh org.jruby.Main --1.9 /usr/share/logstash/lib/bootstrap/environment.rb logstash/runner.rb --path.settings /etc/logstash
root 12999 12895 0 28161 956 1 16:01 pts/0 00:00:00 grep --color=auto logstash

```

SInce the default permission is 600 , logstash fails to access the file.

```
[root@ip-172-30-1-196 logstash]# ls -ltr /var/log/messages
-rw-------. 1 root root 24178653 Jul 8 16:03 /var/log/messages

```

It looks like logstash is ignoring the `LS_USER` option.

**Question**  
Is there any other option to start the logstash as root user?

Thanks,  
Yu Watanabe

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 4:48am UTC](https://discuss.elastic.co/t/file-input-fails-after-upgrading-logstash-from-2-3-3-to-5-0-0-alpha4/55023/2 "2017-07-06T04:48:55Z")

</div>


