# File not readable (please check user and group permissions for the path)

**URL:** <https://discuss.elastic.co/t/file-not-readable-please-check-user-and-group-permissions-for-the-path/252130>\
**Category:** Logstash\
**Created:** [October 15, 2020, 4:38am UTC](https://discuss.elastic.co/t/file-not-readable-please-check-user-and-group-permissions-for-the-path/252130 "2020-10-15T04:38:42Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![BH\_BV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bh_bv/32/77235_2.png) [@BH\_BV](https://discuss.elastic.co/u/BH_BV)\
**Post date:** [October 15, 2020, 4:38am UTC](https://discuss.elastic.co/t/file-not-readable-please-check-user-and-group-permissions-for-the-path/252130/1 "2020-10-15T04:38:43Z")

</div>

im using docker-compose and suddenly logstash now unable to read the driver, but driver is in mounted folder inside the container with full read write permissions. whats possible the problem?

```
logstash_1 | Error: unable to load /opt/cls/drivers/ojdbc7.jar from :jdbc_driver_library, file not readable (please check user and group permissions for the path)
logstash_1 | Exception: LogStash::PluginLoadingError
logstash_1 | Stack: /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.0.6/lib/logstash/plugin_mixins/jdbc/common.rb:47:in `block in load_driver_jars'
logstash_1 | org/jruby/RubyArray.java:1809:in `each'
logstash_1 | /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.0.6/lib/logstash/plugin_mixins/jdbc/common.rb:42:in `load_driver_jars'
logstash_1 | /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.0.6/lib/logstash/plugin_mixins/jdbc/common.rb:25:in `load_driver'
logstash_1 | /usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.0.6/lib/logstash/inputs/jdbc.rb:275:in `run'
logstash_1 | /usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:378:in `inputworker'
logstash_1 | /usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:369:in `block in start_input'
logstash_1 | [2020-10-15T04:27:59,425][ERROR][logstash.javapipeline][m_jdbc][2ba59a8996c94f5e2bf594d454eaf20a24a2e7f765205d242caa19689c2c6453] A plugin had an unrecoverable error. Will restart this plugin.
```

---

<div class="post-metadata">

**Author:** ![grumo35](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/grumo35/32/59451_2.png) [@grumo35](https://discuss.elastic.co/u/grumo35)\
**Post date:** [October 15, 2020, 2:43pm UTC](https://discuss.elastic.co/t/file-not-readable-please-check-user-and-group-permissions-for-the-path/252130/2 "2020-10-15T14:43:49Z")

</div>

> [@BH\_BV](#):
>
> `jdbc_driver_library, file not readable (please check user and group permissions for the path)`

What's the user running logstash ? It looks like you're using jdbc plugin maybe you have authentication problems ? it might be useful to double check credentials.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 12, 2020, 2:43pm UTC](https://discuss.elastic.co/t/file-not-readable-please-check-user-and-group-permissions-for-the-path/252130/3 "2020-11-12T14:43:55Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
