# Filebeat 403 error to SQS

**URL:** <https://discuss.elastic.co/t/filebeat-403-error-to-sqs/269205>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [April 5, 2021, 4:37am UTC](https://discuss.elastic.co/t/filebeat-403-error-to-sqs/269205 "2021-04-05T04:37:17Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![paano](https://avatars.discourse-cdn.com/v4/letter/p/cab0a1/32.png) [@paano](https://discuss.elastic.co/u/paano)\
**Post date:** [April 5, 2021, 4:37am UTC](https://discuss.elastic.co/t/filebeat-403-error-to-sqs/269205/1 "2021-04-05T04:37:17Z")

</div>

Following the document from elastic blog, S3 log to Elastic using filebeat and SQS, i keep getting error  
`2021-04-03T13:45:04.022Z ERROR [input.aws-s3] awss3/collector.go:101 SQS ReceiveMessageRequest failed: AccessDenied: Access to the resource https://sqs.us-east-1.amazonaws.com/ is denied.`

```
`status code: 403, request id: 4d205118-6b7e-545d-96f0-09fa18e103cd {"queue_url": "https://sqs.us-east-1.amazonaws.com/12345678901/log-queue-dev", "region": "us-east-1"}`

```

ANy suggestion what policy is missing in the doc([blog](https://www.elastic.co/blog/getting-aws-logs-from-s3-using-filebeat-and-the-elastic-stack))

---

<div class="post-metadata">

**Author:** ![Kaiyan\_Sheng](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kaiyan_sheng/32/38247_2.png) [@Kaiyan\_Sheng](https://discuss.elastic.co/u/Kaiyan_Sheng)\
**Post date:** [April 5, 2021, 3:29pm UTC](https://discuss.elastic.co/t/filebeat-403-error-to-sqs/269205/2 "2021-04-05T15:29:55Z")

</div>

Sorry the blog post is not up-to-date. Could you try adding these permissions please? [AWS S3 input | Filebeat Reference [7.12] | Elastic](https://www.elastic.co/guide/en/beats/filebeat/7.12/filebeat-input-aws-s3.html#_aws_permissions_2)

---

<div class="post-metadata">

**Author:** ![paano](https://avatars.discourse-cdn.com/v4/letter/p/cab0a1/32.png) [@paano](https://discuss.elastic.co/u/paano)\
**Post date:** [April 5, 2021, 5:52pm UTC](https://discuss.elastic.co/t/filebeat-403-error-to-sqs/269205/3 "2021-04-05T17:52:23Z")

</div>

I did try adding the permission yet see the 403 error. Any other debug command i can put on filebeat to verify what it is missing.

@Kaiyan_Sheng  
thanks for pointing out the permission, added them.

---

<div class="post-metadata">

**Author:** ![paano](https://avatars.discourse-cdn.com/v4/letter/p/cab0a1/32.png) [@paano](https://discuss.elastic.co/u/paano)\
**Post date:** [April 8, 2021, 12:16am UTC](https://discuss.elastic.co/t/filebeat-403-error-to-sqs/269205/4 "2021-04-08T00:16:20Z")

</div>

i was able to resolve it. It was AWS KMS issue.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 6, 2021, 2:16am UTC](https://discuss.elastic.co/t/filebeat-403-error-to-sqs/269205/5 "2021-05-06T02:16:55Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
