# Filebeat 5.3 sends to elasticsearch 7.0.1

**URL:** https://discuss.elastic.co/t/filebeat-5-3-sends-to-elasticsearch-7-0-1/184482
**Category:** Beats
**Tags:** filebeat
**Created:** [June 6, 2019, 2:27am UTC](https://discuss.elastic.co/t/filebeat-5-3-sends-to-elasticsearch-7-0-1/184482 "2019-06-06T02:27:42Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![OcanGo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ocango/32/47591_2.png) [@OcanGo](https://discuss.elastic.co/u/OcanGo)
#### Post date: [June 6, 2019, 2:27am UTC](https://discuss.elastic.co/t/filebeat-5-3-sends-to-elasticsearch-7-0-1/184482/1 "2019-06-06T02:27:42Z")

</div>

I send to elasticsearch 5.3 by using filebeat 5.3 before.Now, a new elasticsearch(7.0.1) is installed into a new server.When I want to sends to elasticsearch(7.0.1) by filebeat 5.3.It seems that because elasticsearch(7.0.1) cannot loads the index template from filebeat(5.3). I see it output the error as follow():

```
{
	"error": {
		"root_cause": [{
			"type": "mapper_parsing_exception",
			"reason": "Root mapping definition has unsupported parameters: [_default_ : {_meta={version=5.3.0}, dynamic_templates=[{strings_as_keyword={m......"
		}],
		"type": "mapper_parsing_exception",
		"reason": "Failed to parse mapping [_doc]: Root mapping definition has unsupported parameters: [_default_ : {_meta={version=5.3.0}, dynamic_templa......",
		"caused_by": {
			"type": "mapper_parsing_exception",
			"reason": "Root mapping definition has unsupported parameters: [_default_ : {_meta={version=5.3.0}......"
		}
	},
	"status": 400
}

```

So-----  
1.It looks like I should alter filebeat(5.3)'s `filebeat.template.json`.What should I do.  
or  
2.The question could not be settled inabstracto. Upgrading is the only way.  
I hope who can give me some guidance.Thanks

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [June 6, 2019, 2:47am UTC](https://discuss.elastic.co/t/filebeat-5-3-sends-to-elasticsearch-7-0-1/184482/2 "2019-06-06T02:47:23Z")

</div>

Welcome! 🙂

Check out [https://www.elastic.co/support/matrix#matrix\_compatibility](https://www.elastic.co/support/matrix#matrix_compatibility), but you will need to upgrade.

---

<div class="post-metadata">

### Author: ![OcanGo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ocango/32/47591_2.png) [@OcanGo](https://discuss.elastic.co/u/OcanGo)
#### Post date: [June 6, 2019, 7:09am UTC](https://discuss.elastic.co/t/filebeat-5-3-sends-to-elasticsearch-7-0-1/184482/3 "2019-06-06T07:09:50Z")

</div>

Very thanks for your share!  
I will update my Beats^\* and Logstash^\* based on the Support Matrix.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 4, 2019, 7:09am UTC](https://discuss.elastic.co/t/filebeat-5-3-sends-to-elasticsearch-7-0-1/184482/4 "2019-07-04T07:09:50Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
