# Filebeat (5.5 with modules) fails to start when ES is down

**URL:** <https://discuss.elastic.co/t/filebeat-5-5-with-modules-fails-to-start-when-es-is-down/109429>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [November 28, 2017, 3:58pm UTC](https://discuss.elastic.co/t/filebeat-5-5-with-modules-fails-to-start-when-es-is-down/109429 "2017-11-28T15:58:09Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![rodche](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rodche/32/24789_2.png) [@rodche](https://discuss.elastic.co/u/rodche)\
**Post date:** [November 28, 2017, 3:58pm UTC](https://discuss.elastic.co/t/filebeat-5-5-with-modules-fails-to-start-when-es-is-down/109429/1 "2017-11-28T15:58:09Z")

</div>

I simply copied here the same question (unanswered, auto-closed):

Whenever I use modules like syslog or nginx, I can’t get filebeat to start, if elasticsearch isn’t up and running. I get: " CRIT Exiting: Error creating ES client: Couldn’t connect to any of the configured Elasticsearch host"

Is there a way to force it to start and keep trying to connect, like it would if I wasn’t using modules, and like it does when ES goes down while filebeat is running? We have such situations often, because of running ES, Kibana and filebeats on different virtual machines, which reboot sometimes in random order...

---

<div class="post-metadata">

**Author:** ![ruflin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ruflin/32/3116_2.png) [@ruflin](https://discuss.elastic.co/u/ruflin)\
**Post date:** [November 29, 2017, 2:53am UTC](https://discuss.elastic.co/t/filebeat-5-5-with-modules-fails-to-start-when-es-is-down/109429/2 "2017-11-29T02:53:58Z")

</div>

Could you update to Filebeat 6.0 and check if you still see the same behaviour? I think we change the start logic here a bit.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 27, 2017, 2:54am UTC](https://discuss.elastic.co/t/filebeat-5-5-with-modules-fails-to-start-when-es-is-down/109429/3 "2017-12-27T02:54:24Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
