# Filebeat 5.6.4 Service can't be created : Access Denied

**URL:** <https://discuss.elastic.co/t/filebeat-5-6-4-service-cant-be-created-access-denied/123679>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [March 13, 2018, 5:55am UTC](https://discuss.elastic.co/t/filebeat-5-6-4-service-cant-be-created-access-denied/123679 "2018-03-13T05:55:34Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![arun3](https://avatars.discourse-cdn.com/v4/letter/a/bc8723/32.png) [@arun3](https://discuss.elastic.co/u/arun3)\
**Post date:** [March 13, 2018, 5:55am UTC](https://discuss.elastic.co/t/filebeat-5-6-4-service-cant-be-created-access-denied/123679/1 "2018-03-13T05:55:34Z")

</div>

When I am trying to install filebeat with "install-service-filebeat.ps1" , getting the below error.  
Please suggest.

PS C:\Users\Arun\filebeat-5.6.4\> PowerShell.exe -ExecutionPolicy UnRestricted -File .\install-service-filebeat.ps1.

Security warning  
Run only scripts that you trust. While scripts from the internet can be useful, this script can potentially harm your  
computer. Do you want to run C:\Users\Arun\filebeat-5.6.4\install-service-filebeat.ps1?  
[D] Do not run [R] Run once [S] Suspend [?] Help (default is "D"): R  
New-Service : Service 'filebeat (filebeat)' cannot be created due to the following error: Access is denied  
At C:\Users\Arun\filebeat-5.6.4\install-service-filebeat.ps1:12 char:1

- New-Service -name filebeat `
- 

```auto
  + CategoryInfo : PermissionDenied: (filebeat:String) [New-Service], ServiceCommandException
  + FullyQualifiedErrorId : CouldNotNewService,Microsoft.PowerShell.Commands.NewServiceCommand
```

---

<div class="post-metadata">

**Author:** ![exekias](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/exekias/32/28718_2.png) [@exekias](https://discuss.elastic.co/u/exekias)\
**Post date:** [March 13, 2018, 11:24am UTC](https://discuss.elastic.co/t/filebeat-5-6-4-service-cant-be-created-access-denied/123679/2 "2018-03-13T11:24:12Z")

</div>

Hi @arun3,

I'm guessing you don't have enough permissions to install new applications. You would need to run this as the administrator user.

Best regards

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 10, 2018, 11:24am UTC](https://discuss.elastic.co/t/filebeat-5-6-4-service-cant-be-created-access-denied/123679/3 "2018-04-10T11:24:17Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
