# Filebeat 503 method not allowed

**URL:** https://discuss.elastic.co/t/filebeat-503-method-not-allowed/275720
**Category:** Beats
**Tags:** filebeat
**Created:** [June 11, 2021, 8:28pm UTC](https://discuss.elastic.co/t/filebeat-503-method-not-allowed/275720 "2021-06-11T20:28:30Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![burtonrs](https://avatars.discourse-cdn.com/v4/letter/b/35a633/32.png) [@burtonrs](https://discuss.elastic.co/u/burtonrs)
#### Post date: [June 11, 2021, 8:28pm UTC](https://discuss.elastic.co/t/filebeat-503-method-not-allowed/275720/1 "2021-06-11T20:28:30Z")

</div>

Filebeat is attempting to send logs, but not working at all. Getting error below. HELP!!!!

```auto
2021-06-11T15:25:54.596-0400 DEBUG [input] input/input.go:139 Run input
2021-06-11T15:25:54.597-0400 DEBUG [input] log/input.go:205 Start next scan
2021-06-11T15:25:54.597-0400 DEBUG [input] log/input.go:439 Check file for harvesting: /tmp/test
2021-06-11T15:25:54.597-0400 DEBUG [input] log/input.go:530 Update existing file for harvesting: /tmp/test, offset: 268
2021-06-11T15:25:54.597-0400 DEBUG [input] log/input.go:583 Harvester for file is still running: /tmp/test
2021-06-11T15:25:54.597-0400 DEBUG [input] log/input.go:226 input states cleaned up. Before: 1, After: 1, Pending: 0
2021-06-11T15:25:59.599-0400 DEBUG [harvester] log/log.go:107 End of file reached: /tmp/test; Backoff now.
2021-06-11T15:26:01.845-0400 ERROR [publisher_pipeline_output] pipeline/output.go:154 Failed to connect to backoff(elasticsearch(http://IP:80/elasticsearch)): Connection marked as failed because the onConnect callback failed: failed to create alias: {"error":"Incorrect HTTP method for uri [/<filebeat-7.12.0-{now/d}-000001>] and method [PUT], allowed: [POST]","status":405}: 405 Method Not Allowed: {"error":"Incorrect HTTP method for uri [/<filebeat-7.12.0-{now/d}-000001>] and method [PUT], allowed: [POST]","status":405}

```

---

<div class="post-metadata">

### Author: ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)
#### Post date: [June 11, 2021, 9:02pm UTC](https://discuss.elastic.co/t/filebeat-503-method-not-allowed/275720/2 "2021-06-11T21:02:15Z")

</div>

Hi @burtonrs Welcome to the community!

We can't help unless you post your filebeat configuration 🙂

`filebeat.yml`

First thing I notice is Elasticsearch typically does not run on port 80 how did you install Elasticsearch?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 9, 2021, 11:02pm UTC](https://discuss.elastic.co/t/filebeat-503-method-not-allowed/275720/3 "2021-07-09T23:02:28Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
