# Filebeat always need kibana now?

**URL:** <https://discuss.elastic.co/t/filebeat-always-need-kibana-now/236637>\
**Category:** Beats\
**Created:** [June 11, 2020, 7:43am UTC](https://discuss.elastic.co/t/filebeat-always-need-kibana-now/236637 "2020-06-11T07:43:01Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![azteker](https://avatars.discourse-cdn.com/v4/letter/a/aca169/32.png) [@azteker](https://discuss.elastic.co/u/azteker)\
**Post date:** [June 11, 2020, 7:43am UTC](https://discuss.elastic.co/t/filebeat-always-need-kibana-now/236637/1 "2020-06-11T07:43:01Z")

</div>

I don't want to set kibana and only need the filebeat to send data. But now I cannot start my filebeat and get this error:  
`Exiting: Error importing Kibana dashboards: fail to create the Kibana loader: Error creating Kibana client: Error creating Kibana client: fail to get the Kibana version`  
Can I run filebeat without kibana?

---

<div class="post-metadata">

**Author:** ![shaunak](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shaunak/32/6643_2.png) [@shaunak](https://discuss.elastic.co/u/shaunak)\
**Post date:** [June 11, 2020, 10:05am UTC](https://discuss.elastic.co/t/filebeat-always-need-kibana-now/236637/2 "2020-06-11T10:05:39Z")

</div>

Hi @azteker, welcome to the Elastic community forums!

What version of Filebeat are you using? Also, could you share you `filebeat.yml` configuration please (after redacting any sensitive information in it)?

Thanks,

Shaunak

---

<div class="post-metadata">

**Author:** ![azteker](https://avatars.discourse-cdn.com/v4/letter/a/aca169/32.png) [@azteker](https://discuss.elastic.co/u/azteker)\
**Post date:** [June 11, 2020, 5:55pm UTC](https://discuss.elastic.co/t/filebeat-always-need-kibana-now/236637/3 "2020-06-11T17:55:35Z")

</div>

@shaunak

My filebeat version is 6.8.0

filebeat.yml follows:

```
filebeat.inputs:

- type: log

  enabled: true

  paths:
    - /var2/log/cloud/*.log

filebeat.config.modules:
  path: ${path.config}/modules.d/*.yml

  reload.enabled: false

setup.template.settings:
  index.number_of_shards: 3

setup.dashboards.enabled: true
setup.dashboards.beat:

setup.kibana:

  host: "10.28.1.17:80"

  protocol: "http"
  username: "admin"
  password: "admin"

output.logstash:

  hosts: ["10.28.1.17:5044"]

  ssl.enabled: false
  ssl.certificate_authorities: ["/etc/beat/beat-forwarder.crt"]

  ssl.certificate: "/etc/beat/beat-forwarder.crt"

  ssl.key: "/etc/beat/beat-forwarder.key"

processors:
  - add_host_metadata: ~
  - add_cloud_metadata: ~
```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 9, 2020, 7:55pm UTC](https://discuss.elastic.co/t/filebeat-always-need-kibana-now/236637/4 "2020-07-09T19:55:42Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
