# Filebeat aws region error

**URL:** https://discuss.elastic.co/t/filebeat-aws-region-error/225832
**Category:** Beats
**Tags:** filebeat
**Created:** [March 31, 2020, 10:21am UTC](https://discuss.elastic.co/t/filebeat-aws-region-error/225832 "2020-03-31T10:21:40Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![Samerd](https://avatars.discourse-cdn.com/v4/letter/s/c4cdca/32.png) [@Samerd](https://discuss.elastic.co/u/Samerd)
#### Post date: [March 31, 2020, 10:21am UTC](https://discuss.elastic.co/t/filebeat-aws-region-error/225832/1 "2020-03-31T10:21:40Z")

</div>

hi

im tring to enable aws elb to send logs for my ELb.

this is my AWS module config:

![filebeat_aws](https://us1.discourse-cdn.com/elastic/original/3X/1/8/18428eac2cb8543e518ee7669ea634da9269a670.png)

and i got this error message :  
ERROR instance/beat.go:933 Exiting: Fileset aws/regions is configured but doesn't exist

---

<div class="post-metadata">

### Author: ![Mike.Barretta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mike.barretta/32/16688_2.png) [@Mike.Barretta](https://discuss.elastic.co/u/Mike.Barretta)
#### Post date: [April 1, 2020, 3:32pm UTC](https://discuss.elastic.co/t/filebeat-aws-region-error/225832/2 "2020-04-01T15:32:53Z")

</div>

@Samerd There is no `us-central-1` region in AWS. See the list at: [https://docs.aws.amazon.com/general/latest/gr/rande.html](https://docs.aws.amazon.com/general/latest/gr/rande.html)

---

<div class="post-metadata">

### Author: ![Samerd](https://avatars.discourse-cdn.com/v4/letter/s/c4cdca/32.png) [@Samerd](https://discuss.elastic.co/u/Samerd)
#### Post date: [April 2, 2020, 6:56am UTC](https://discuss.elastic.co/t/filebeat-aws-region-error/225832/3 "2020-04-02T06:56:13Z")

</div>

thanks , bad mistake .. but i fixed it to eu-central-1 , and i still getting the same error after trying restart the service

---

<div class="post-metadata">

### Author: ![Mike.Barretta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mike.barretta/32/16688_2.png) [@Mike.Barretta](https://discuss.elastic.co/u/Mike.Barretta)
#### Post date: [April 2, 2020, 2:31pm UTC](https://discuss.elastic.co/t/filebeat-aws-region-error/225832/4 "2020-04-02T14:31:09Z")

</div>

@Samerd Looking more closely, your configuration isn't correct: there is no `regions` field under the aws modules. Also, there is no `aws.elb.name` field.

For ELB, you'd be encoding the region in the URL for the SQS queue where the ELB logs are written:

```auto
- module: aws
  elb:
    enabled: true

    # AWS SQS queue url
    var.queue_url: https://sqs.eu-central-1.amazonaws.com/123456/myqueue

```

[The docs](https://www.elastic.co/guide/en/beats/filebeat/current/filebeat-module-aws.html) have the allowed configuration settings, and also explain how to configure the various AWS services to send their logs to S3 and enable SQS notifications.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [April 30, 2020, 2:31pm UTC](https://discuss.elastic.co/t/filebeat-aws-region-error/225832/5 "2020-04-30T14:31:09Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
