# Filebeat can not talk to ELK on AWS EKS

**URL:** https://discuss.elastic.co/t/filebeat-can-not-talk-to-elk-on-aws-eks/329600
**Category:** Elasticsearch
**Tags:** elastic-stack-monitoring
**Created:** [April 7, 2023, 8:41pm UTC](https://discuss.elastic.co/t/filebeat-can-not-talk-to-elk-on-aws-eks/329600 "2023-04-07T20:41:35Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![williamsun](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/williamsun/32/119245_2.png) [@williamsun](https://discuss.elastic.co/u/williamsun)
#### Post date: [April 7, 2023, 8:41pm UTC](https://discuss.elastic.co/t/filebeat-can-not-talk-to-elk-on-aws-eks/329600/1 "2023-04-07T20:41:35Z")

</div>

Hello Everyone,

I am using the follow doc to setup the filebeat on EKS.

> **[Run Filebeat on Kubernetes | Filebeat Reference \[8.7\] | Elastic](https://www.elastic.co/guide/en/beats/filebeat/current/running-on-kubernetes.html)**

curl -L -O [https://raw.githubusercontent.com/elastic/beats/8.7/deploy/kubernetes/filebeat-kubernetes.yaml](https://raw.githubusercontent.com/elastic/beats/8.7/deploy/kubernetes/filebeat-kubernetes.yaml)

Default Setting does not work

- name: ELASTICSEARCH\_HOST  
value: elasticsearch
- name: ELASTICSEARCH\_PORT  
value: "9200"

for ELASTICSEARCH\_HOST.

ELK on AWS EKS is setup from the following doc.

> **[Deploy ECK in your Kubernetes cluster | Elastic Cloud on Kubernetes \[master\]...](https://www.elastic.co/guide/en/cloud-on-k8s/master/k8s-deploy-eck.html)**

Here is the error when configure the host to one of the elastic service quickstart-es-http  
after elasticsearch setting does not work for host.

By configuring the ingress service for Elastic, it appears that elastic 9200 is using tls. But Filebeat 8.7 is trying to connect to it with http, not sure whether it is the problem.

Thank you very much for your help in advance!

```auto
{"log.level":"info","@timestamp":"2023-04-07T20:19:29.068Z","log.logger":"publisher_pipeline_output","log.origin":{"file.name":"pipeline/client_worker.go","file.line":141},"message":"Attempting to reconnect to backoff(elasticsearch(http://quickstart-es-http:9200)) with 4 reconnect attempt(s)","service.name":"filebeat","ecs.version":"1.6.0"}

{"log.level":"warn","@timestamp":"2023-04-07T20:19:29.072Z","log.logger":"transport","log.origin":{"file.name":"transport/tcp.go","file.line":52},"message":"DNS lookup failure \"quickstart-es-http\": lookup quickstart-es-http on 172.20.0.10:53: no such host","service.name":"filebeat","ecs.version":"1.6.0"}

{"log.level":"error","@timestamp":"2023-04-07T20:19:29.072Z","log.logger":"esclientleg","log.origin":{"file.name":"transport/logging.go","file.line":38},"message":"Error dialing lookup quickstart-es-http on 172.20.0.10:53: no such host","service.name":"filebeat","network":"tcp","address":"quickstart-es-http:9200","ecs.version":"1.6.0"}

```

Thank you very much!

---

<div class="post-metadata">

### Author: ![williamsun](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/williamsun/32/119245_2.png) [@williamsun](https://discuss.elastic.co/u/williamsun)
#### Post date: [April 7, 2023, 10:01pm UTC](https://discuss.elastic.co/t/filebeat-can-not-talk-to-elk-on-aws-eks/329600/2 "2023-04-07T22:01:25Z")

</div>

Just want to add. I am able to send the filebeat log to Elastic's ingress URL on ALB. But I would like to try to send the logs internally. This is where I have issues. Thank you very much!

---

<div class="post-metadata">

### Author: ![Vivek\_Shinde](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/vivek_shinde/32/117294_2.png) [@Vivek\_Shinde](https://discuss.elastic.co/u/Vivek_Shinde)
#### Post date: [April 8, 2023, 9:49am UTC](https://discuss.elastic.co/t/filebeat-can-not-talk-to-elk-on-aws-eks/329600/3 "2023-04-08T09:49:31Z")

</div>

The error shows that quickstart-es-http is not resolved by filebeat. Maybe you should use service FQDN like quickstart-es-http.namespace.svc.cluster.local.

Regarding connecting with TLS, this document can help you - [Configure SSL | Filebeat Reference [8.7] | Elastic](https://www.elastic.co/guide/en/beats/filebeat/current/configuration-ssl.html)

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [May 6, 2023, 9:49am UTC](https://discuss.elastic.co/t/filebeat-can-not-talk-to-elk-on-aws-eks/329600/4 "2023-05-06T09:49:42Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
