# Filebeat can't load template due to circuitbreaker

**URL:** <https://discuss.elastic.co/t/filebeat-cant-load-template-due-to-circuitbreaker/197004>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [August 27, 2019, 9:09pm UTC](https://discuss.elastic.co/t/filebeat-cant-load-template-due-to-circuitbreaker/197004 "2019-08-27T21:09:40Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![rectalogic](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rectalogic/32/44827_2.png) [@rectalogic](https://discuss.elastic.co/u/rectalogic)\
**Post date:** [August 27, 2019, 9:09pm UTC](https://discuss.elastic.co/t/filebeat-cant-load-template-due-to-circuitbreaker/197004/1 "2019-08-27T21:09:41Z")

</div>

I'm upgrading elasticsearch/filebeat from 6.5.2 to 7.3.0

filebeat is failing to start with this error:

`Error loading Elasticsearch template: could not load template. Elasticsearch returned: couldn't load template: couldn't load json. Error: 429 Too Many Requests: {"error":{"root_cause":[{"type":"circuit_breaking_exception","reason":"[parent] Data too large, data for [<http_request>] would be [1005387694/958.8mb], which is larger than the limit of [1003493785/957mb], real usage: [1005306456/958.7mb], new bytes reserved: [81238/79.3kb], usages [request=0/0b, fielddata=0/0b, in_flight_requests=81238/79.3kb, accounting=88508810/84.4mb]","bytes_wanted":1005387694,"bytes_limit":1003493785,"durability":"PERMANENT"}]`

Full error message which shows a massive template being uploaded:

> <https://gist.github.com/rectalogic/530d8615022b74cfc5f0c6625783ebdb>

I tried increasing swap on the ES box, and increasing java -Xmx/-Xms

Is this somehow due to using setup.template.append\_fields? It was working fine in 6.5.2

---

<div class="post-metadata">

**Author:** ![rectalogic](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rectalogic/32/44827_2.png) [@rectalogic](https://discuss.elastic.co/u/rectalogic)\
**Post date:** [August 28, 2019, 3:01pm UTC](https://discuss.elastic.co/t/filebeat-cant-load-template-due-to-circuitbreaker/197004/2 "2019-08-28T15:01:09Z")

</div>

Had to upgrade filebeat to 6.7.2 before upgrading to 7.3.0

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 25, 2019, 3:01pm UTC](https://discuss.elastic.co/t/filebeat-cant-load-template-due-to-circuitbreaker/197004/3 "2019-09-25T15:01:11Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
