# Filebeat can't send logs after Elasticsearch cluster failure

**URL:** <https://discuss.elastic.co/t/filebeat-cant-send-logs-after-elasticsearch-cluster-failure/175982>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [April 9, 2019, 8:40am UTC](https://discuss.elastic.co/t/filebeat-cant-send-logs-after-elasticsearch-cluster-failure/175982 "2019-04-09T08:40:40Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![gchermennov](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gchermennov/32/10471_2.png) [@gchermennov](https://discuss.elastic.co/u/gchermennov)\
**Post date:** [April 9, 2019, 8:40am UTC](https://discuss.elastic.co/t/filebeat-cant-send-logs-after-elasticsearch-cluster-failure/175982/1 "2019-04-09T08:40:40Z")

</div>

We recently had a problem when ES cluster failed. The problem was resolved, but filebeat failed to send new data after the failure.   
  
Here's a portion of the logs - it seems to retry forever but can't send the data:

```
    2019-04-08T11:52:04.182+0300 INFO elasticsearch/client.go:690 Connected to Elasticsearch version 6.4.0
    2019-04-08T11:52:04.185+0300 INFO template/load.go:73 Template already exists and will not be overwritten.
    2019-04-08T11:52:04.185+0300 INFO [publish] pipeline/retry.go:172 retryer: send unwait-signal to consumer
    2019-04-08T11:52:04.185+0300 INFO [publish] pipeline/retry.go:174 done
    2019-04-08T11:52:59.058+0300 INFO [publish] pipeline/retry.go:149 retryer: send wait signal to consumer
    2019-04-08T11:52:59.058+0300 INFO [publish] pipeline/retry.go:151 done
    2019-04-08T11:53:00.065+0300 ERROR pipeline/output.go:92 Failed to publish events: temporary bulk send failure
    2019-04-08T11:53:00.065+0300 INFO [publish] pipeline/retry.go:172 retryer: send unwait-signal to consumer
    2019-04-08T11:53:00.065+0300 INFO [publish] pipeline/retry.go:174 done
    2019-04-08T11:53:00.065+0300 INFO [publish] pipeline/retry.go:149 retryer: send wait signal to consumer
    2019-04-08T11:53:00.065+0300 INFO [publish] pipeline/retry.go:151 done

```

I restarted Filebeat service and all data was sent to ES without any problem.  
Is this a known issue? Filebeat version is quite old, should I update?  
I'm running Filebeat 6.3.0 as a service on Windows. Elasticsearch version is 6.4.0.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 7, 2019, 8:46am UTC](https://discuss.elastic.co/t/filebeat-cant-send-logs-after-elasticsearch-cluster-failure/175982/2 "2019-05-07T08:46:27Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
