# Filebeat configuration file

**URL:** https://discuss.elastic.co/t/filebeat-configuration-file/139488
**Category:** Beats
**Created:** [July 11, 2018, 7:00am UTC](https://discuss.elastic.co/t/filebeat-configuration-file/139488 "2018-07-11T07:00:04Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![CCH0124](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cch0124/32/36436_2.png) [@CCH0124](https://discuss.elastic.co/u/CCH0124)
#### Post date: [July 11, 2018, 7:00am UTC](https://discuss.elastic.co/t/filebeat-configuration-file/139488/1 "2018-07-11T07:00:05Z")

</div>

Kibana has used nginx as a reverse proxy.  
kibana version 6.2  
filebeat version 6.3

```auto
filebeat.config:
  inputs:
    enabled: true
  modules:
    enabled: true

filebeat.inputs:
  enabled: true

filebeat.modules:
  - module: system
    syslog:
      enabled: true
      var.path: ["/var/log/syslog*"]
      var.convert_timezone: true
      input:
        exclude_files: ['.gz$']
    auth:
      enabled: true
      var.path: ["/var/log/auth*"]
      var.convert_timezone: true
      input:
        exclude_files: ['.gz$']

output.elasticsearch:
  enabled: false

output.logstash:
  enabled: true
  hosts: ["192.168.XX.XX:10514"]
  ssl.enabled: false

setup.kibana:
  enabled: true
  host: "192.168.XX.XX:8080"
  username: "XXX"
  password: "XXX"
  ssl.enabled: false

#setup.dashboards.enabled: true

```

When the setup.dashboards.enabled: true annotation is removed, the following error occurs when running docker

```auto
2018-07-11T06:51:24.926Z ERROR instance/beat.go:691 Exiting: Error importing Kibana dashboards: fail to create the Kibana loader: Error creating Kibana client: Error creating Kibana client: fail to get the Kibana version: HTTP GET request to /api/status fails: parsing kibana response: invalid character '<' looking for beginning of ./html>nter>nginx/1.13.12</center>center>d>
Exiting: Error importing Kibana dashboards: fail to create the Kibana loader: Error creating Kibana client: Error creating Kibana client: fail to get the Kibana version: HT ./html>nter>nginx/1.13.12</center>center>d> kibana response: invalid character '<' looking for beginning of value. Response: <html>

```

---

<div class="post-metadata">

### Author: ![kvch](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kvch/32/72058_2.png) [@kvch](https://discuss.elastic.co/u/kvch)
#### Post date: [July 11, 2018, 7:18am UTC](https://discuss.elastic.co/t/filebeat-configuration-file/139488/2 "2018-07-11T07:18:49Z")

</div>

Your Filebeat configuration is correct. However, your reverse proxy is configured incorrectly. Filebeat should be getting a JSON response from Kibana which contains its version info. But in your case the response is some HTML returned by NGINX. Are you sure you configured it correctly?

---

<div class="post-metadata">

### Author: ![CCH0124](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cch0124/32/36436_2.png) [@CCH0124](https://discuss.elastic.co/u/CCH0124)
#### Post date: [July 11, 2018, 9:12am UTC](https://discuss.elastic.co/t/filebeat-configuration-file/139488/3 "2018-07-11T09:12:47Z")

</div>

But I execute curl and display information normally.

```auto
curl http://192.168.XX.XX:8080/api/status

```

---

<div class="post-metadata">

### Author: ![kvch](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kvch/32/72058_2.png) [@kvch](https://discuss.elastic.co/u/kvch)
#### Post date: [July 11, 2018, 10:19am UTC](https://discuss.elastic.co/t/filebeat-configuration-file/139488/4 "2018-07-11T10:19:35Z")

</div>

Do you execute this command inside the Docker container where Filebeat fails to fetch the data?

---

<div class="post-metadata">

### Author: ![CCH0124](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cch0124/32/36436_2.png) [@CCH0124](https://discuss.elastic.co/u/CCH0124)
#### Post date: [July 13, 2018, 12:42am UTC](https://discuss.elastic.co/t/filebeat-configuration-file/139488/5 "2018-07-13T00:42:37Z")

</div>

Can be executed normally.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [August 10, 2018, 2:42am UTC](https://discuss.elastic.co/t/filebeat-configuration-file/139488/6 "2018-08-10T02:42:41Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
