# Filebeat configuration - ssl.verification\_mode: none doesn't work

**URL:** https://discuss.elastic.co/t/filebeat-configuration-ssl-verification-mode-none-doesnt-work/166327
**Category:** Beats
**Tags:** elastic-stack-security, filebeat
**Created:** [January 30, 2019, 10:13am UTC](https://discuss.elastic.co/t/filebeat-configuration-ssl-verification-mode-none-doesnt-work/166327 "2019-01-30T10:13:25Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![kacedn](https://avatars.discourse-cdn.com/v4/letter/k/b5a626/32.png) [@kacedn](https://discuss.elastic.co/u/kacedn)
#### Post date: [January 30, 2019, 10:13am UTC](https://discuss.elastic.co/t/filebeat-configuration-ssl-verification-mode-none-doesnt-work/166327/1 "2019-01-30T10:13:25Z")

</div>

Hello

Version of filebeat : 6.3.0

I don't understand why ssl.verification\_mode is ignored.  
In filebeat.yml, i am trying to configure ssl for ElasticSearchOutput.

[https://www.elastic.co/guide/en/beats/filebeat/current/configuration-ssl.html](https://www.elastic.co/guide/en/beats/filebeat/current/configuration-ssl.html)

I am want to disable ssl verification to allow all connection.  
I put "ssl.verification\_mode: none" in filebeat.yml but in Filebeat log i still have error about certificate.  
I try many things without success.

filebeat.yml

```
#-------------------------- Elasticsearch output ------------------------------
output.elasticsearch:
  hosts: ["https://myurl:443/elastic"]
  ssl.verification_mode: none
  proxy_url: http://myproxy:8080
  index: "filebeat-%{[fields.type]:other}-%{[beat.version]}-%{+yyyy.MM.dd}"

```

Filebeat Log

```
2019-01-30T09:49:46.389+0100	ERROR	pipeline/output.go:74	Failed to connect: Get https://myurl:443: x509: certificate signed by unknown authority
2019-01-30T09:49:50.283+0100	ERROR	pipeline/output.go:74	Failed to connect: Get https://myurl:443: x509: certificate signed by unknown authority
2019-01-30T09:49:55.301+0100	ERROR	pipeline/output.go:74	Failed to connect: Get https://myurl:443: x509: certificate signed by unknown authority
2019-01-30T09:49:55.301+0100	INFO	[publish]	pipeline/retry.go:149	retryer: send wait signal to consumer
2019-01-30T09:49:55.301+0100	INFO	[publish]	pipeline/retry.go:151 done

```

Thanks in advance  
Nabil

---

<div class="post-metadata">

### Author: ![kvch](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kvch/32/72058_2.png) [@kvch](https://discuss.elastic.co/u/kvch)
#### Post date: [January 30, 2019, 12:56pm UTC](https://discuss.elastic.co/t/filebeat-configuration-ssl-verification-mode-none-doesnt-work/166327/2 "2019-01-30T12:56:59Z")

</div>

Could you please format your configuration `</>`? It is possible that there is a whitespace error in your file. Thus, Filebeat does not pick up the configuration correctly.

---

<div class="post-metadata">

### Author: ![kacedn](https://avatars.discourse-cdn.com/v4/letter/k/b5a626/32.png) [@kacedn](https://discuss.elastic.co/u/kacedn)
#### Post date: [January 30, 2019, 2:47pm UTC](https://discuss.elastic.co/t/filebeat-configuration-ssl-verification-mode-none-doesnt-work/166327/3 "2019-01-30T14:47:49Z")

</div>

@kvch thanks sorry it was my first post.  
Locally fine but it doesn't work with proxy and ssl configuration.  
Does the 'ssl.verification\_mode : none' parameter work for you ?

Does it works only in x-pack feature?

---

<div class="post-metadata">

### Author: ![kacedn](https://avatars.discourse-cdn.com/v4/letter/k/b5a626/32.png) [@kacedn](https://discuss.elastic.co/u/kacedn)
#### Post date: [February 6, 2019, 11:13am UTC](https://discuss.elastic.co/t/filebeat-configuration-ssl-verification-mode-none-doesnt-work/166327/4 "2019-02-06T11:13:23Z")

</div>

Help me please!!

---

<div class="post-metadata">

### Author: ![ikakavas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ikakavas/32/34430_2.png) [@ikakavas](https://discuss.elastic.co/u/ikakavas)
#### Post date: [February 6, 2019, 12:36pm UTC](https://discuss.elastic.co/t/filebeat-configuration-ssl-verification-mode-none-doesnt-work/166327/5 "2019-02-06T12:36:02Z")

</div>

Hi @kacedn!

Please be patient in waiting for responses to your question and refrain from  
pinging multiple times asking for a response or opening multiple topics for  
the same question. This is a community forum, it may take time for someone to  
reply to your question. For more information please refer to the [Community  
Code of Conduct](https://www.elastic.co/community/codeofconduct) specifically  
the section "Be patient".

If you are in need of a service with an SLA that covers response times for  
questions then you may want to consider talking to us about a  
[subscription](https://www.elastic.co/subscriptions).

Since you are using a non https proxy `proxy_url: http://myproxy:8080`, and the filebeat will talk to the proxy over plain http, I don't think you need to set `ssl.verification_mode: none`. There is no TLS connection for which to _not_ do verification.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [March 6, 2019, 12:36pm UTC](https://discuss.elastic.co/t/filebeat-configuration-ssl-verification-mode-none-doesnt-work/166327/6 "2019-03-06T12:36:03Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
