# Filebeat coredns module doesn't work with default coredns/docker logging

**URL:** <https://discuss.elastic.co/t/filebeat-coredns-module-doesnt-work-with-default-coredns-docker-logging/202392>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [October 4, 2019, 9:25pm UTC](https://discuss.elastic.co/t/filebeat-coredns-module-doesnt-work-with-default-coredns-docker-logging/202392 "2019-10-04T21:25:03Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![MangledDeutz](https://avatars.discourse-cdn.com/v4/letter/m/c0e974/32.png) [@MangledDeutz](https://discuss.elastic.co/u/MangledDeutz)\
**Post date:** [October 4, 2019, 9:25pm UTC](https://discuss.elastic.co/t/filebeat-coredns-module-doesnt-work-with-default-coredns-docker-logging/202392/1 "2019-10-04T21:25:03Z")

</div>

See [Filebeat Autodiscovery for coredns in docker, what labels to use?](https://discuss.elastic.co/t/filebeat-autodiscovery-for-coredns-in-docker-what-labels-to-use/201530)

When using docker + hints, the filebeat coredns module silently fail sending any data.

Turns out the ingester tries to parse a leading "timestamp" that is not there (and fails silently...).

Are we doing anything wrong here or is this a bug of the coredns ingester?

CoreDNS-1.6.3  
Docker version 19.03.2, build 6a30dfc  
ELK 7.3.2

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 2, 2019, 12:42am UTC](https://discuss.elastic.co/t/filebeat-coredns-module-doesnt-work-with-default-coredns-docker-logging/202392/3 "2019-11-02T00:42:48Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
