# Filebeat dashboard creation via Docker errors on Kibana host

**URL:** <https://discuss.elastic.co/t/filebeat-dashboard-creation-via-docker-errors-on-kibana-host/110951>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [December 10, 2017, 2:56am UTC](https://discuss.elastic.co/t/filebeat-dashboard-creation-via-docker-errors-on-kibana-host/110951 "2017-12-10T02:56:22Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![claflico](https://avatars.discourse-cdn.com/v4/letter/c/71c47a/32.png) [@claflico](https://discuss.elastic.co/u/claflico)\
**Post date:** [December 10, 2017, 2:56am UTC](https://discuss.elastic.co/t/filebeat-dashboard-creation-via-docker-errors-on-kibana-host/110951/1 "2017-12-10T02:56:22Z")

</div>

Trying to setup an ELK:6.0.1 stack and \*beat:6.0.1 via CentOS 7, Docker 17.09, & Rancher 1.6.12 for a presentation I'm giving this week at a DevOps MeetUp. Am trying to set everything up without having to create custom images or mounting custom config files like I usually have to.

Using the following guides:

> **[elastic/beats-docker](https://github.com/elastic/beats-docker)**
>
> beats-docker - Official Beats Docker images

  
[https://www.elastic.co/guide/en/beats/filebeat/current/filebeat-configuration.html](https://www.elastic.co/guide/en/beats/filebeat/current/filebeat-configuration.html)  
[https://www.elastic.co/guide/en/beats/filebeat/current/filebeat-template.html](https://www.elastic.co/guide/en/beats/filebeat/current/filebeat-template.html)  
[https://www.elastic.co/guide/en/beats/filebeat/current/load-kibana-dashboards.html](https://www.elastic.co/guide/en/beats/filebeat/current/load-kibana-dashboards.html)

After loading the template I use the following docker-compose config to try and load the dashboard:  
filebeat-dashboard:  
image: [docker.elastic.co/beats/filebeat:6.0.1](http://docker.elastic.co/beats/filebeat:6.0.1)  
environment:  
output.logstash.enabled: 'false'  
output.elasticsearch.hosts: '["elasticsearch:9200"]'  
setup.kibana.host: kibana:5601  
depends\_on:  
- filebeat-template  
- kibana  
command:  
- setup  
- --dashboards  
labels:  
io.rancher.container.start\_once: 'true'  
io.rancher.container.hostname\_override: container\_name  
io.rancher.container.pull\_image: always

When I start the container in Rancher I get the following:  
Exiting: Error importing Kibana dashboards: fail to create the Kibana loader: Error creating Kibana client: fail to get the Kibana version:HTTP GET request to /api/status fails: fail to execute the HTTP GET request: Get [http://localhost:5601/api/status:](http://localhost:5601/api/status:) dial tcp 127.0.0.1:5601: getsockopt: connection refused. Response: .

Only way I was able to get it to work was create a custom filebeat.yml file on the host and mount it inside the container which is what I am trying to avoid:  
filebeat.config:  
prospectors:  
path: ${path.config}/prospectors.d/_.yml  
reload.enabled: false  
modules:  
path: ${path.config}/modules.d/_.yml  
reload.enabled: false  
processors:  
#- add\_cloud\_metadata: #added for forum formatting  
output.elasticsearch:  
hosts: ['elasticsearch:9200']  
setup.kibana:  
host: "kibana:5601"

filebeat-dashboard:  
image: [docker.elastic.co/beats/filebeat:6.0.1](http://docker.elastic.co/beats/filebeat:6.0.1)  
environment:  
output.logstash.enabled: 'false'  
output.elasticsearch.hosts: '["elasticsearch:9200"]'  
setup.kibana.host: kibana:5601  
depends\_on:  
- filebeat-template  
- kibana  
volumes:  
- /mnt/docker/config/filebeat.yml:/usr/share/filebeat/filebeat.yml:ro  
command:  
- setup  
- --dashboards  
labels:  
io.rancher.container.start\_once: 'true'  
io.rancher.container.hostname\_override: container\_name  
io.rancher.container.pull\_image: always

So specifying "setup.kibana.host: kibana:5601" as an environment variable appears to have no effect.

---

<div class="post-metadata">

**Author:** ![exekias](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/exekias/32/28718_2.png) [@exekias](https://discuss.elastic.co/u/exekias)\
**Post date:** [December 11, 2017, 3:20pm UTC](https://discuss.elastic.co/t/filebeat-dashboard-creation-via-docker-errors-on-kibana-host/110951/2 "2017-12-11T15:20:52Z")

</div>

Hi,

You could use `-E` flag to override configuration settings, so passing `-E setup.kibana.host="kibana:5601"` should work.

Best regards

---

<div class="post-metadata">

**Author:** ![claflico](https://avatars.discourse-cdn.com/v4/letter/c/71c47a/32.png) [@claflico](https://discuss.elastic.co/u/claflico)\
**Post date:** [December 11, 2017, 3:33pm UTC](https://discuss.elastic.co/t/filebeat-dashboard-creation-via-docker-errors-on-kibana-host/110951/3 "2017-12-11T15:33:50Z")

</div>

Thanks but I already have that specified in my environment via the compose file:

environment:  
output.logstash.enabled: 'false'  
output.elasticsearch.hosts: '["elasticsearch:9200"]'  
setup.kibana.host: kibana:5601

When I run "env" from within the non-setup, long-running container I see setup.kibana.host as an environment variable so it is at least getting set. I can't verify it in the setup container since it exits as soon as the script fails.

---

<div class="post-metadata">

**Author:** ![exekias](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/exekias/32/28718_2.png) [@exekias](https://discuss.elastic.co/u/exekias)\
**Post date:** [December 11, 2017, 3:49pm UTC](https://discuss.elastic.co/t/filebeat-dashboard-creation-via-docker-errors-on-kibana-host/110951/4 "2017-12-11T15:49:53Z")

</div>

Sorry I didn't explain myself well, the `-E` parameter is for filebeat, it allows you to override default settings

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 8, 2018, 3:50pm UTC](https://discuss.elastic.co/t/filebeat-dashboard-creation-via-docker-errors-on-kibana-host/110951/5 "2018-01-08T15:50:03Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
