# Filebeat dashboards are not loaded in kibana - Running on AWS

**URL:** https://discuss.elastic.co/t/filebeat-dashboards-are-not-loaded-in-kibana-running-on-aws/259204
**Category:** Kibana
**Created:** [December 20, 2020, 9:37pm UTC](https://discuss.elastic.co/t/filebeat-dashboards-are-not-loaded-in-kibana-running-on-aws/259204 "2020-12-20T21:37:04Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![ats](https://avatars.discourse-cdn.com/v4/letter/a/da6949/32.png) [@ats](https://discuss.elastic.co/u/ats)
#### Post date: [December 20, 2020, 9:37pm UTC](https://discuss.elastic.co/t/filebeat-dashboards-are-not-loaded-in-kibana-running-on-aws/259204/1 "2020-12-20T21:37:04Z")

</div>

## I am running 3 nodes in AWS: 1 master and 2 data nodes for Elasticsearch. I installed kibana fine with no issues. Now I'm running into an issue with setting up filebeat dashboard in Kibana. Getting the following error

root@ip-172-31-68-160:~# filebeat setup

Overwriting ILM policy is disabled. Set `setup.ilm.overwrite: true` for enabling.

Index setup finished.

Loading dashboards (Kibana must be running and reachable)

## Exiting: error connecting to Kibana: fail to get the Kibana version: HTTP GET request to [http://172.21.68.160:8080/api/status](http://172.21.68.160:8080/api/status) fails: fail to execute the HTTP GET request: Get "[http://172.21.68.160:8080/api/status](http://172.21.68.160:8080/api/status)": context deadline exceeded (Client.Timeout exceeded while awaiting headers). Response: .

I can hit the URL [http://my](http://my) public ip/api/status fine though but for some reason the filebeat setup is failing.

---

<div class="post-metadata">

### Author: ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)
#### Post date: [December 20, 2020, 9:55pm UTC](https://discuss.elastic.co/t/filebeat-dashboards-are-not-loaded-in-kibana-running-on-aws/259204/2 "2020-12-20T21:55:51Z")

</div>

Is the IP address right in your configuration?

Your prompt shows that the private IP of your machine is `172.31.68.160`, but your error shows that it is trying to reach the private IP `172.21.68.160`.

Can you share your `filebeat.yml` and `kibana.yml` files?

---

<div class="post-metadata">

### Author: ![ats](https://avatars.discourse-cdn.com/v4/letter/a/da6949/32.png) [@ats](https://discuss.elastic.co/u/ats)
#### Post date: [December 20, 2020, 10:07pm UTC](https://discuss.elastic.co/t/filebeat-dashboards-are-not-loaded-in-kibana-running-on-aws/259204/3 "2020-12-20T22:07:19Z")

</div>

Yaaas!! It was a typo. I caught it too. Thanks !

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [December 21, 2020, 3:31am UTC](https://discuss.elastic.co/t/filebeat-dashboards-are-not-loaded-in-kibana-running-on-aws/259204/4 "2020-12-21T03:31:57Z")

</div>

> [@ats](#):
>
> I am running 3 nodes in AWS

Is that their service, or on EC2.

> [@ats](#):
>
> 1 master and 2 data nodes for Elasticsearch

That's not ideal if that is only 1 master eligible node, as you have no quorum.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [January 18, 2021, 3:32am UTC](https://discuss.elastic.co/t/filebeat-dashboards-are-not-loaded-in-kibana-running-on-aws/259204/5 "2021-01-18T03:32:00Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
