# Filebeat DNS resolution fail

**URL:** https://discuss.elastic.co/t/filebeat-dns-resolution-fail/223970
**Category:** Beats
**Tags:** filebeat
**Created:** [March 17, 2020, 4:15pm UTC](https://discuss.elastic.co/t/filebeat-dns-resolution-fail/223970 "2020-03-17T16:15:22Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![Ondra](https://avatars.discourse-cdn.com/v4/letter/o/da6949/32.png) [@Ondra](https://discuss.elastic.co/u/Ondra)
#### Post date: [March 17, 2020, 4:15pm UTC](https://discuss.elastic.co/t/filebeat-dns-resolution-fail/223970/1 "2020-03-17T16:15:23Z")

</div>

Hello,

I have encountered similar issue as in this thread: [DNS lookup failure "elasticsearch":](https://discuss.elastic.co/t/dns-lookup-failure-elasticsearch/216140/3)

Unfortunatelly the filebeat is not able to resolve elasticsearch name.

```auto
2020-03-17T16:01:06.506Z ERROR pipeline/output.go:100 Failed to connect to backoff(elasticsearch(https://quickstart-es-http:9200)): Get https://quickstart-es-http:9200: lookup quickstart-es-http on 10.152.183.10:53: server misbehaving

2020-03-17T16:01:06.506Z INFO pipeline/output.go:93 Attempting to reconnect to backoff(elasticsearch(https://quickstart-es-http:9200)) with 33 reconnect attempt(s)

2020-03-17T16:01:06.506Z INFO [publisher] pipeline/retry.go:196 retryer: send unwait-signal to consumer

2020-03-17T16:01:06.506Z INFO [publisher] pipeline/retry.go:198 done

2020-03-17T16:01:06.506Z INFO [publisher] pipeline/retry.go:173 retryer: send wait signal to consumer

2020-03-17T16:01:06.506Z INFO [publisher] pipeline/retry.go:175 done

2020-03-17T16:01:14.513Z WARN transport/tcp.go:52 DNS lookup failure "quickstart-es-http": lookup quickstart-es-http on 10.152.183.10:53: server misbehaving

```

Curl to es from different POD works fine:

```auto
curl -u "elastic:password" -k "https://quickstart-es-http:9200"
{
  "name" : "quickstart-es-default-0",
  "cluster_name" : "quickstart",
  ....
  "version" : {
    "number" : "7.6.1",
    ....
}

```

elastic deployment: [https://www.elastic.co/guide/en/cloud-on-k8s/current/k8s-quickstart.html](https://www.elastic.co/guide/en/cloud-on-k8s/current/k8s-quickstart.html)  
filebeat deployment: [https://www.elastic.co/guide/en/beats/filebeat/master/running-on-kubernetes.html](https://www.elastic.co/guide/en/beats/filebeat/master/running-on-kubernetes.html)

Any ideas please?

Thank you!

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [April 14, 2020, 4:27pm UTC](https://discuss.elastic.co/t/filebeat-dns-resolution-fail/223970/2 "2020-04-14T16:27:46Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
